aboutsummaryrefslogtreecommitdiff
path: root/dns/py-dnspython
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-19 12:47:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-19 12:47:37 +0000
commit7afe451d0025a115f82ec640208a8983a69908cd (patch)
treefb88f782a2ef77706db4b8e2ee548d539db890d2 /dns/py-dnspython
parenta86c4c9aeff133334b55fb6c857c33d498dda93f (diff)
downloadports-7afe451d0025a115f82ec640208a8983a69908cd.tar.gz
ports-7afe451d0025a115f82ec640208a8983a69908cd.zip
- Update to 1.9.2
PR: 154535 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=269347
Diffstat (limited to 'dns/py-dnspython')
-rw-r--r--dns/py-dnspython/Makefile21
-rw-r--r--dns/py-dnspython/distinfo5
-rw-r--r--dns/py-dnspython/pkg-plist20
3 files changed, 31 insertions, 15 deletions
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index 9472c7f66612..9b6bad8b0435 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dnspython
-PORTVERSION= 1.8.0
+PORTVERSION= 1.9.2
CATEGORIES= dns python
MASTER_SITES= http://www.dnspython.org/kits/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,32 +17,45 @@ COMMENT= A DNS toolkit for Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+OPTIONS= PYCRYPTO "Enable pycrypto (part of dnssec needs it)" off
+
PORTDOCS= \
ChangeLog \
README \
TODO
EXAMPLE_FILES= \
ddns.py \
+ e164.py \
mx.py \
name.py \
reverse.py \
- xfr.py
+ reverse_name.py \
+ xfr.py \
+ zonediff.py
post-install:
# docs
-.ifndef(NOPORTDOCS)
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
# examples
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
.for file in ${EXAMPLE_FILES}
@${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
+.endif
# permission safeness
@${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/dns/*
@${CHMOD} -R a+X ${PYTHONPREFIX_SITELIBDIR}/dns/*
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PYCRYPTO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/py-dnspython/distinfo b/dns/py-dnspython/distinfo
index 9e034975a720..4cf15eeae78e 100644
--- a/dns/py-dnspython/distinfo
+++ b/dns/py-dnspython/distinfo
@@ -1,3 +1,2 @@
-MD5 (dnspython-1.8.0.tar.gz) = 77f379e0cb21e11470a35359e6211c53
-SHA256 (dnspython-1.8.0.tar.gz) = 8e9fd938bb695e0c5332f095b07a5aa8e4597cd8cc24ee9be5a15b463d7437ba
-SIZE (dnspython-1.8.0.tar.gz) = 108588
+SHA256 (dnspython-1.9.2.tar.gz) = 6a7dfbe1a34880b45b94988cb48ba12667d9a635fd9df061ea0a24d6f8b5f7e0
+SIZE (dnspython-1.9.2.tar.gz) = 122408
diff --git a/dns/py-dnspython/pkg-plist b/dns/py-dnspython/pkg-plist
index c15a20c0018b..0d86a33583e0 100644
--- a/dns/py-dnspython/pkg-plist
+++ b/dns/py-dnspython/pkg-plist
@@ -19,6 +19,9 @@
%%PYTHON_SITELIBDIR%%/dns/flags.py
%%PYTHON_SITELIBDIR%%/dns/flags.pyc
%%PYTHON_SITELIBDIR%%/dns/flags.pyo
+%%PYTHON_SITELIBDIR%%/dns/hash.py
+%%PYTHON_SITELIBDIR%%/dns/hash.pyc
+%%PYTHON_SITELIBDIR%%/dns/hash.pyo
%%PYTHON_SITELIBDIR%%/dns/inet.py
%%PYTHON_SITELIBDIR%%/dns/inet.pyc
%%PYTHON_SITELIBDIR%%/dns/inet.pyo
@@ -247,15 +250,16 @@
%%PYTHON_SITELIBDIR%%/dns/zone.py
%%PYTHON_SITELIBDIR%%/dns/zone.pyc
%%PYTHON_SITELIBDIR%%/dns/zone.pyo
-%%EXAMPLESDIR%%/ddns.py
-%%EXAMPLESDIR%%/mx.py
-%%EXAMPLESDIR%%/name.py
-%%EXAMPLESDIR%%/reverse.py
-%%EXAMPLESDIR%%/xfr.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ddns.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/e164.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mx.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/name.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reverse.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reverse_name.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xfr.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/zonediff.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%PYTHON_SITELIBDIR%%/dns/rdtypes/IN
@dirrm %%PYTHON_SITELIBDIR%%/dns/rdtypes/ANY
@dirrm %%PYTHON_SITELIBDIR%%/dns/rdtypes
@dirrm %%PYTHON_SITELIBDIR%%/dns
-@dirrm %%EXAMPLESDIR%%
-@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%