aboutsummaryrefslogtreecommitdiff
path: root/dns/py-idna
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:15:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:15:12 +0000
commit7d032d8fc174e2ce3c00e1d76daec9cb7d7f987d (patch)
treef81453e5e3fe76612dd13ae13c8fa95f3d4c2593 /dns/py-idna
parent8ab4e29e31fc32016f3397bcc33bc8da211003e2 (diff)
downloadports-7d032d8fc174e2ce3c00e1d76daec9cb7d7f987d.tar.gz
ports-7d032d8fc174e2ce3c00e1d76daec9cb7d7f987d.zip
dns/py-idna: Update to 3.4
Diffstat (limited to 'dns/py-idna')
-rw-r--r--dns/py-idna/Makefile5
-rw-r--r--dns/py-idna/distinfo6
-rw-r--r--dns/py-idna/files/setup.py21
3 files changed, 28 insertions, 4 deletions
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
index 56ff56e5bc0d..85225ff25da5 100644
--- a/dns/py-idna/Makefile
+++ b/dns/py-idna/Makefile
@@ -1,5 +1,5 @@
PORTNAME= idna
-PORTVERSION= 3.3
+PORTVERSION= 3.4
CATEGORIES= dns python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,4 +16,7 @@ USE_PYTHON= autoplist concurrent distutils unittest
NO_ARCH= yes
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/dns/py-idna/distinfo b/dns/py-idna/distinfo
index 1b8ff2324903..2973fe96d5da 100644
--- a/dns/py-idna/distinfo
+++ b/dns/py-idna/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1647264586
-SHA256 (idna-3.3.tar.gz) = 9d643ff0a55b762d5cdb124b8eaa99c66322e2157b69160bc32796e824360e6d
-SIZE (idna-3.3.tar.gz) = 286689
+TIMESTAMP = 1663672872
+SHA256 (idna-3.4.tar.gz) = 814f528e8dead7d329833b91c5faa87d60bf71824cd12a7530b5526063d02cb4
+SIZE (idna-3.4.tar.gz) = 183077
diff --git a/dns/py-idna/files/setup.py b/dns/py-idna/files/setup.py
new file mode 100644
index 000000000000..a7d30bb8e879
--- /dev/null
+++ b/dns/py-idna/files/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['idna']
+
+package_data = \
+{'': ['*']}
+
+setup(name='idna',
+ version='%%PORTVERSION%%',
+ description='Internationalized Domain Names in Applications (IDNA)',
+ author=None,
+ author_email='Kim Davies <kim@cynosure.com.au>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ python_requires='>=3.5',
+ )