aboutsummaryrefslogtreecommitdiff
path: root/dns/py-idna
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-11-02 16:30:46 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-11-02 16:30:46 +0000
commitf20b2099a625db1f0de5ea4080550dd39d0fec0d (patch)
tree2c6882debef2a3588942aea25d5372a4a76b630f /dns/py-idna
parent8d59010a018906df23f0339b80272d77403b5ba9 (diff)
downloadports-f20b2099a625db1f0de5ea4080550dd39d0fec0d.tar.gz
ports-f20b2099a625db1f0de5ea4080550dd39d0fec0d.zip
[NEW] dns/py-idna: Internationalized Domain Names in Applications (IDNA)
A library to support the Internationalised Domain Names in Applications (IDNA) protocol as specified in RFC 5891. This version of the protocol is often referred to as “IDNA2008” and can produce different res lts from the earlier standard from 2003. The library is also intended to act as a suitable drop-in replacement for the "encodings.idna" module that comes with the Python standard library but currently only supports the older 2003 specification. WWW: https://github.com/kjd/idna Noticed by: brnrd (for py-cryptography)
Notes
Notes: svn path=/head/; revision=400660
Diffstat (limited to 'dns/py-idna')
-rw-r--r--dns/py-idna/Makefile19
-rw-r--r--dns/py-idna/distinfo2
-rw-r--r--dns/py-idna/pkg-descr10
3 files changed, 31 insertions, 0 deletions
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
new file mode 100644
index 000000000000..5cbaaf1746bd
--- /dev/null
+++ b/dns/py-idna/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= idna
+PORTVERSION= 2.0
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Internationalized Domain Names in Applications (IDNA)
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/dns/py-idna/distinfo b/dns/py-idna/distinfo
new file mode 100644
index 000000000000..67e147b4fe87
--- /dev/null
+++ b/dns/py-idna/distinfo
@@ -0,0 +1,2 @@
+SHA256 (idna-2.0.tar.gz) = 16199aad938b290f5be1057c0e1efc6546229391c23cea61ca940c115f7d3d3b
+SIZE (idna-2.0.tar.gz) = 135150
diff --git a/dns/py-idna/pkg-descr b/dns/py-idna/pkg-descr
new file mode 100644
index 000000000000..dd2b68ff56ca
--- /dev/null
+++ b/dns/py-idna/pkg-descr
@@ -0,0 +1,10 @@
+A library to support the Internationalised Domain Names in Applications
+(IDNA) protocol as specified in RFC 5891. This version of the protocol
+is often referred to as "IDNA2008" and can produce different res
+lts from the earlier standard from 2003.
+
+The library is also intended to act as a suitable drop-in replacement
+for the "encodings.idna" module that comes with the Python standard
+library but currently only supports the older 2003 specification.
+
+WWW: https://github.com/kjd/idna