aboutsummaryrefslogtreecommitdiff
path: root/dns/py-idna
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:08 +0000
commitf4720fee2c41e96c74a9abaf487c7d93fe006eaf (patch)
tree25f956e27676d4daef4889641065141407db1b97 /dns/py-idna
parente5b2567786c89fbd0ffe512186fd883bc55104c2 (diff)
downloadports-f4720fee2c41e96c74a9abaf487c7d93fe006eaf.tar.gz
ports-f4720fee2c41e96c74a9abaf487c7d93fe006eaf.zip
dns/py-idna: Patch existing setup.py instead of providing a new one
- Do not bump PORTREVISION because the package is unchanged
Diffstat (limited to 'dns/py-idna')
-rw-r--r--dns/py-idna/Makefile5
-rw-r--r--dns/py-idna/files/patch-setup.py6
-rw-r--r--dns/py-idna/files/setup.py21
3 files changed, 8 insertions, 24 deletions
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
index a20d8feec47a..2df8d5fa6715 100644
--- a/dns/py-idna/Makefile
+++ b/dns/py-idna/Makefile
@@ -11,12 +11,11 @@ WWW= https://github.com/kjd/idna
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+
USES= python:3.5+
USE_PYTHON= autoplist concurrent distutils unittest
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/dns/py-idna/files/patch-setup.py b/dns/py-idna/files/patch-setup.py
new file mode 100644
index 000000000000..ef23da1c27a3
--- /dev/null
+++ b/dns/py-idna/files/patch-setup.py
@@ -0,0 +1,6 @@
+--- setup.py.orig 2022-09-14 00:01:44 UTC
++++ setup.py
+@@ -1,2 +1,2 @@
+ from setuptools import setup
+-setup()
++setup(use_scm_version=True)
diff --git a/dns/py-idna/files/setup.py b/dns/py-idna/files/setup.py
deleted file mode 100644
index a7d30bb8e879..000000000000
--- a/dns/py-idna/files/setup.py
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['idna']
-
-package_data = \
-{'': ['*']}
-
-setup(name='idna',
- version='%%PORTVERSION%%',
- description='Internationalized Domain Names in Applications (IDNA)',
- author=None,
- author_email='Kim Davies <kim@cynosure.com.au>',
- url=None,
- packages=packages,
- package_data=package_data,
- python_requires='>=3.5',
- )