aboutsummaryrefslogtreecommitdiff
path: root/dns/py-idna_ssl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-17 10:44:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-17 10:44:12 +0000
commit06cb642db4135835b1e7feb645de05f450708a6b (patch)
treee73da4bb498e936b74a31e195640dc37ae0296b8 /dns/py-idna_ssl
parent2d108a546df38779d682b3d9a3138fe68a22c6eb (diff)
downloadports-06cb642db4135835b1e7feb645de05f450708a6b.tar.gz
ports-06cb642db4135835b1e7feb645de05f450708a6b.zip
Add py-idna_ssl 1.0.1
idna-ssl patches ssl.match_hostname for Unicode(idna) domains support. WWW: https://pypi.python.org/pypi/idna_ssl WWW: https://github.com/aio-libs/idna-ssl
Notes
Notes: svn path=/head/; revision=464782
Diffstat (limited to 'dns/py-idna_ssl')
-rw-r--r--dns/py-idna_ssl/Makefile27
-rw-r--r--dns/py-idna_ssl/distinfo3
-rw-r--r--dns/py-idna_ssl/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/dns/py-idna_ssl/Makefile b/dns/py-idna_ssl/Makefile
new file mode 100644
index 000000000000..5e867d453783
--- /dev/null
+++ b/dns/py-idna_ssl/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= idna_ssl
+PORTVERSION= 1.0.1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= idna-ssl-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Patch ssl.match_hostname for Unicode(idna) domains support
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=2.3:www/py-aiohttp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python:3.3-3.6
+
+.include <bsd.port.mk>
diff --git a/dns/py-idna_ssl/distinfo b/dns/py-idna_ssl/distinfo
new file mode 100644
index 000000000000..d441258dad52
--- /dev/null
+++ b/dns/py-idna_ssl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521280682
+SHA256 (idna-ssl-1.0.1.tar.gz) = 1293f030bc608e9aa9cdee72aa93c1521bbb9c7698068c61c9ada6772162b979
+SIZE (idna-ssl-1.0.1.tar.gz) = 3385
diff --git a/dns/py-idna_ssl/pkg-descr b/dns/py-idna_ssl/pkg-descr
new file mode 100644
index 000000000000..f96b06db745f
--- /dev/null
+++ b/dns/py-idna_ssl/pkg-descr
@@ -0,0 +1,4 @@
+idna-ssl patches ssl.match_hostname for Unicode(idna) domains support.
+
+WWW: https://pypi.python.org/pypi/idna_ssl
+WWW: https://github.com/aio-libs/idna-ssl