aboutsummaryrefslogtreecommitdiff
path: root/dns/py-ns1-python/Makefile
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2019-05-22 21:23:36 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2019-05-22 21:23:36 +0000
commit6bc2b77d282cb5889903386d927fc806baa688b0 (patch)
treec7e728d4a8a5d7a8eb2e139e9845681a84fa0450 /dns/py-ns1-python/Makefile
parent9b27108d2a9bfb28c1e6368a467521cb404f3469 (diff)
downloadports-6bc2b77d282cb5889903386d927fc806baa688b0.tar.gz
ports-6bc2b77d282cb5889903386d927fc806baa688b0.zip
Notes
Diffstat (limited to 'dns/py-ns1-python/Makefile')
-rw-r--r--dns/py-ns1-python/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/dns/py-ns1-python/Makefile b/dns/py-ns1-python/Makefile
new file mode 100644
index 000000000000..546b1e50fba3
--- /dev/null
+++ b/dns/py-ns1-python/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= ns1-python
+DISTVERSION= 0.9.19
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= Python SDK for accessing NS1, the Data Driven DNS platform
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>