aboutsummaryrefslogtreecommitdiff
path: root/dns/py-twistedNames
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:55:22 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:55:22 +0000
commit116dcd0a33d89080f859520d752a7fb419a023b1 (patch)
treed71f69892cfb253341b16b0fdaa3ddf4ffb015bf /dns/py-twistedNames
parent8d7a7e48d77cbbe093d9aef58119f8a066bfbd54 (diff)
downloadports-116dcd0a33d89080f859520d752a7fb419a023b1.tar.gz
ports-116dcd0a33d89080f859520d752a7fb419a023b1.zip
Notes
Diffstat (limited to 'dns/py-twistedNames')
-rw-r--r--dns/py-twistedNames/Makefile29
-rw-r--r--dns/py-twistedNames/distinfo2
-rw-r--r--dns/py-twistedNames/pkg-descr13
-rw-r--r--dns/py-twistedNames/pkg-plist56
4 files changed, 100 insertions, 0 deletions
diff --git a/dns/py-twistedNames/Makefile b/dns/py-twistedNames/Makefile
new file mode 100644
index 000000000000..b27bd617da71
--- /dev/null
+++ b/dns/py-twistedNames/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedNames
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedNames
+PORTVERSION= 0.1.0
+CATEGORIES= dns devel python
+MASTER_SITES= http://twistedmatrix.com/downloads/Names/0.1/ \
+ http://tmrc.mit.edu/mirror/twisted/Names/0.2/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedNames-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= A DNS protocol implementation with client and server
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedNames-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>
diff --git a/dns/py-twistedNames/distinfo b/dns/py-twistedNames/distinfo
new file mode 100644
index 000000000000..537481afb6ad
--- /dev/null
+++ b/dns/py-twistedNames/distinfo
@@ -0,0 +1,2 @@
+MD5 (TwistedNames-0.1.0.tar.bz2) = 1489cb84aa4abfd371441090e5e12f0e
+SIZE (TwistedNames-0.1.0.tar.bz2) = 28486
diff --git a/dns/py-twistedNames/pkg-descr b/dns/py-twistedNames/pkg-descr
new file mode 100644
index 000000000000..5d718dcfd93d
--- /dev/null
+++ b/dns/py-twistedNames/pkg-descr
@@ -0,0 +1,13 @@
+Twisted Names is both a domain name server as well as a client resolver
+library. Twisted Names comes with an "out of the box" nameserver which can
+read most BIND-syntax zone files as well as a simple Python-based
+configuration format. Twisted Names can act as an authoritative server,
+perform zone transfers from a master to act as a secondary, act as a caching
+nameserver, or any combination of these. Twisted Names' client resolver
+library provides functions to query for all commonly used record types as
+well as a replacement for the blocking gethostbyname() function provided by
+the Python stdlib socket module.
+
+Twisted Names is available under the MIT Free Software licence.
+
+WWW: http://twistedmatrix.com/
diff --git a/dns/py-twistedNames/pkg-plist b/dns/py-twistedNames/pkg-plist
new file mode 100644
index 000000000000..3e750cbbd72e
--- /dev/null
+++ b/dns/py-twistedNames/pkg-plist
@@ -0,0 +1,56 @@
+%%S%%/twisted/names/__init__.py
+%%S%%/twisted/names/__init__.pyc
+%%S%%/twisted/names/__init__.pyo
+%%S%%/twisted/names/authority.py
+%%S%%/twisted/names/authority.pyc
+%%S%%/twisted/names/authority.pyo
+%%S%%/twisted/names/cache.py
+%%S%%/twisted/names/cache.pyc
+%%S%%/twisted/names/cache.pyo
+%%S%%/twisted/names/client.py
+%%S%%/twisted/names/client.pyc
+%%S%%/twisted/names/client.pyo
+%%S%%/twisted/names/common.py
+%%S%%/twisted/names/common.pyc
+%%S%%/twisted/names/common.pyo
+%%S%%/twisted/names/dns.py
+%%S%%/twisted/names/dns.pyc
+%%S%%/twisted/names/dns.pyo
+%%S%%/twisted/names/hosts.py
+%%S%%/twisted/names/hosts.pyc
+%%S%%/twisted/names/hosts.pyo
+%%S%%/twisted/names/resolve.py
+%%S%%/twisted/names/resolve.pyc
+%%S%%/twisted/names/resolve.pyo
+%%S%%/twisted/names/root.py
+%%S%%/twisted/names/root.pyc
+%%S%%/twisted/names/root.pyo
+%%S%%/twisted/names/secondary.py
+%%S%%/twisted/names/secondary.pyc
+%%S%%/twisted/names/secondary.pyo
+%%S%%/twisted/names/server.py
+%%S%%/twisted/names/server.pyc
+%%S%%/twisted/names/server.pyo
+%%S%%/twisted/names/srvconnect.py
+%%S%%/twisted/names/srvconnect.pyc
+%%S%%/twisted/names/srvconnect.pyo
+%%S%%/twisted/names/tap.py
+%%S%%/twisted/names/tap.pyc
+%%S%%/twisted/names/tap.pyo
+%%S%%/twisted/names/test/__init__.py
+%%S%%/twisted/names/test/__init__.pyc
+%%S%%/twisted/names/test/__init__.pyo
+%%S%%/twisted/names/test/test_dns.py
+%%S%%/twisted/names/test/test_dns.pyc
+%%S%%/twisted/names/test/test_dns.pyo
+%%S%%/twisted/names/test/test_names.py
+%%S%%/twisted/names/test/test_names.pyc
+%%S%%/twisted/names/test/test_names.pyo
+%%S%%/twisted/names/test/test_rootresolve.py
+%%S%%/twisted/names/test/test_rootresolve.pyc
+%%S%%/twisted/names/test/test_rootresolve.pyo
+%%S%%/twisted/plugins/twisted_names.py
+%%S%%/twisted/plugins/twisted_names.pyc
+%%S%%/twisted/plugins/twisted_names.pyo
+@dirrm %%S%%/twisted/names/test
+@dirrm %%S%%/twisted/names