aboutsummaryrefslogtreecommitdiff
path: root/dns/subfinder
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-21 08:47:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-21 08:47:56 +0000
commit5b462c9cc6bb217a56ce9ce77580b865df083255 (patch)
tree9652a0bcd3f92df3fe4263445520fe6147d786b3 /dns/subfinder
parentae93af18a17777e9d695cca7715f1ec1100a1ac6 (diff)
downloadports-5b462c9cc6bb217a56ce9ce77580b865df083255.tar.gz
ports-5b462c9cc6bb217a56ce9ce77580b865df083255.zip
Notes
Diffstat (limited to 'dns/subfinder')
-rw-r--r--dns/subfinder/Makefile23
-rw-r--r--dns/subfinder/distinfo9
-rw-r--r--dns/subfinder/pkg-descr11
3 files changed, 43 insertions, 0 deletions
diff --git a/dns/subfinder/Makefile b/dns/subfinder/Makefile
new file mode 100644
index 000000000000..e3cab9f7744b
--- /dev/null
+++ b/dns/subfinder/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= subfinder
+DISTVERSION= 1.2-6
+DISTVERSIONSUFFIX= -g357c340
+CATEGORIES= dns
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Subdomain discovery tool that discovers valid subdomains for websites
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+USE_GITHUB= yes
+GH_TUPLE= subfinder:urlx:8e731c8:urlx/vendor/github.com/subfinder/urlx \
+ bogdanovich:dns_resolver:a8e42bc:dns_resolver/vendor/github.com/bogdanovich/dns_resolver \
+ miekg:dns:ccd41ff:dns/vendor/github.com/miekg/dns
+GO_PKGNAME= github.com/${PORTNAME}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/dns/subfinder/distinfo b/dns/subfinder/distinfo
new file mode 100644
index 000000000000..1d6d2e8f2bfc
--- /dev/null
+++ b/dns/subfinder/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1558427367
+SHA256 (subfinder-subfinder-1.2-6-g357c340_GH0.tar.gz) = 1a28561626aba3005091287655976da0da4d42562b4cb35b275dcf8b0cf88ac1
+SIZE (subfinder-subfinder-1.2-6-g357c340_GH0.tar.gz) = 34779
+SHA256 (subfinder-urlx-8e731c8_GH0.tar.gz) = 18be61066860462179203d4b6d0c0261609611a8d43523a4e801a24c2ec5e42f
+SIZE (subfinder-urlx-8e731c8_GH0.tar.gz) = 1851
+SHA256 (bogdanovich-dns_resolver-a8e42bc_GH0.tar.gz) = 6bb6328732e6c181020a98c84dad46a3d0f74634490e101e31280c257993e635
+SIZE (bogdanovich-dns_resolver-a8e42bc_GH0.tar.gz) = 2981
+SHA256 (miekg-dns-ccd41ff_GH0.tar.gz) = b43654f9689ea9ee6757ecb5da4e28f9ccf5b3dfe81630a7eeb38c39bcf1b347
+SIZE (miekg-dns-ccd41ff_GH0.tar.gz) = 3887272
diff --git a/dns/subfinder/pkg-descr b/dns/subfinder/pkg-descr
new file mode 100644
index 000000000000..c3f0ce38f8db
--- /dev/null
+++ b/dns/subfinder/pkg-descr
@@ -0,0 +1,11 @@
+SubFinder is a subdomain discovery tool that discovers valid subdomains for
+websites by using passive online sources. It has a simple modular architecture
+and has been aimed as a successor to sublist3r project. SubFinder uses Passive
+Sources, Search Engines, Pastebins, Internet Archives, etc to find subdomains
+and then it uses a permutation module inspired by altdns to generate
+permutations and resolve them quickly using a powerful bruteforcing engine. It
+can also perform plain bruteforce if needed. The tool is highly customizable,
+and the code is built with a modular approach in mind making it easy to add
+functionalities and remove errors.
+
+WWW: https://github.com/subfinder/subfinder