aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-02-09 19:49:01 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-02-09 19:49:01 +0000
commitb511b451f1d3d306768a2ca86c6a015dc7fa2d2f (patch)
tree21707b4a7723db2b60928cb95140d4149b7a9be6 /dns/unbound
parentbbd134e06dab90b37e2c9383998eb7a1866d1016 (diff)
downloadports-b511b451f1d3d306768a2ca86c6a015dc7fa2d2f.tar.gz
ports-b511b451f1d3d306768a2ca86c6a015dc7fa2d2f.zip
dns/unbound: Update to 1.13.1
Changes: https://nlnetlabs.nl/news/2021/Feb/09/unbound-1.13.1-released/ PR: 253376 Submitted by: Jaap Akkerhuis <jaap AT NLnetLabs DOT nl> (maintainer)
Notes
Notes: svn path=/head/; revision=564806
Diffstat (limited to 'dns/unbound')
-rw-r--r--dns/unbound/Makefile23
-rw-r--r--dns/unbound/distinfo6
-rw-r--r--dns/unbound/files/patch-Issue376156
-rw-r--r--dns/unbound/pkg-plist2
4 files changed, 15 insertions, 172 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 161a4389074f..098eb4ff395b 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unbound
-PORTVERSION= 1.13.0
-PORTREVISION= 1
+PORTVERSION= 1.13.1
CATEGORIES= dns
MASTER_SITES= https://www.nlnetlabs.nl/downloads/unbound/ \
https://distfiles.crux.guru/
@@ -29,17 +28,17 @@ GROUPS= ${PORTNAME}
USE_RC_SUBR= unbound
-PORTDOCS= CNAME-basedRedirectionDesignNotes.pdf CREDITS Changelog \
- FEATURES IP-BasedActions.pdf LICENSE README README.DNS64 \
- README.ipset.md README.svn README.tests TODO \
- control_proto_spec.txt example.conf ietf67-design-02.odp \
- ietf67-design-02.pdf requirements.txt
+PORTDOCS= CREDITS Changelog FEATURES LICENSE README \
+ README.DNS64 README.ipset.md README.svn README.tests \
+ TODO control_proto_spec.txt ietf67-design-02.odp \
+ ietf67-design-02.pdf requirements.txt example.conf \
+ CNAME-basedRedirectionDesignNotes.pdf IP-BasedActions.pdf
OPTIONS_SUB= yes
-OPTIONS_DEFINE= DNSCRYPT DNSTAP DOCS DOH ECDSA EVAPI FILTER_AAAA GOST \
- HIREDIS LIBEVENT MUNIN_PLUGIN PYTHON SUBNET TFOCL TFOSE \
- THREADS
-OPTIONS_DEFAULT=DOH ECDSA GOST LIBEVENT THREADS
+OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN_PLUGIN DOCS LIBEVENT \
+ FILTER_AAAA DNSTAP DNSCRYPT SUBNET EVAPI TFOCL TFOSE \
+ HIREDIS DOH
+OPTIONS_DEFAULT=THREADS ECDSA LIBEVENT GOST DOH
LIBEVENT_DESC= Build against libevent
GOST_DESC= Enable GOST support (requires OpenSSL >= 1.0)
@@ -53,7 +52,7 @@ EVAPI_DESC= (Experimental) pluggable event based libunbound API support
TFOCL_DESC= Enable TCP Fast Open for client mode
TFOSE_DESC= Enable TCP Fast Open for server mode
HIREDIS_DESC= Enable hiredis support for the cachedb module
-DOH_DESC= Enable DNS-over-HTTPS supports
+DOH_DESC= Enable DNS-over-HTTPS support
STRIP_FILES= .libs/libunbound.so unbound-checkconf unbound \
unbound-control .libs/unbound-host .libs/unbound-anchor
diff --git a/dns/unbound/distinfo b/dns/unbound/distinfo
index 0e551d104a32..32a2fddfcc2d 100644
--- a/dns/unbound/distinfo
+++ b/dns/unbound/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1607786765
-SHA256 (unbound-1.13.0.tar.gz) = a954043a95b0326ca4037e50dace1f3a207a0a19e9a4a22f4c6718fc623db2a1
-SIZE (unbound-1.13.0.tar.gz) = 5950063
+TIMESTAMP = 1612858504
+SHA256 (unbound-1.13.1.tar.gz) = 8504d97b8fc5bd897345c95d116e0ee0ddf8c8ff99590ab2b4bd13278c9f50b8
+SIZE (unbound-1.13.1.tar.gz) = 5976957
diff --git a/dns/unbound/files/patch-Issue376 b/dns/unbound/files/patch-Issue376
deleted file mode 100644
index 0a930d2cc1ce..000000000000
--- a/dns/unbound/files/patch-Issue376
+++ /dev/null
@@ -1,156 +0,0 @@
-diff --git a/doc/Changelog b/doc/Changelog
-index 07a8e6ea4..3b831fea1 100644
---- doc/Changelog.orig
-+++ doc/Changelog
-@@ -1,3 +1,7 @@
-+16 December 2020: George
-+ - Fix error cases when udp-connect is set and send() returns an error
-+ (modified patch from Xin Li @delphij).
-+
- 30 November 2020: Wouter
- - Fix assertion failure on double callback when iterator loses
- interest in query at head of line that then has the tcp stream
-diff --git a/services/authzone.c b/services/authzone.c
-index 15be5d60c..e59548fc3 100644
---- services/authzone.c.orig
-+++ services/authzone.c
-@@ -6093,7 +6093,7 @@ xfr_probe_send_probe(struct auth_xfer* xfr, struct module_env* env,
-
- /* send udp packet */
- if(!comm_point_send_udp_msg(xfr->task_probe->cp, env->scratch_buffer,
-- (struct sockaddr*)&addr, addrlen)) {
-+ (struct sockaddr*)&addr, addrlen, 0)) {
- char zname[255+1], as[256];
- dname_str(xfr->name, zname);
- addr_to_str(&addr, addrlen, as, sizeof(as));
-diff --git a/services/outside_network.c b/services/outside_network.c
-index 0886907f7..d8f9874e6 100644
---- services/outside_network.c.orig
-+++ services/outside_network.c
-@@ -1899,17 +1899,10 @@ randomize_and_send_udp(struct pending* pend, sldns_buffer* packet, int timeout)
- log_assert(pend->pc && pend->pc->cp);
-
- /* send it over the commlink */
-- if(outnet->udp_connect) {
-- if(!comm_point_send_udp_msg(pend->pc->cp, packet, NULL, 0)) {
-- portcomm_loweruse(outnet, pend->pc);
-- return 0;
-- }
-- } else {
-- if(!comm_point_send_udp_msg(pend->pc->cp, packet,
-- (struct sockaddr*)&pend->addr, pend->addrlen)) {
-- portcomm_loweruse(outnet, pend->pc);
-- return 0;
-- }
-+ if(!comm_point_send_udp_msg(pend->pc->cp, packet,
-+ (struct sockaddr*)&pend->addr, pend->addrlen, outnet->udp_connect)) {
-+ portcomm_loweruse(outnet, pend->pc);
-+ return 0;
- }
-
- /* system calls to set timeout after sending UDP to make roundtrip
-diff --git a/testcode/fake_event.c b/testcode/fake_event.c
-index 75a6b8db9..5164332c0 100644
---- testcode/fake_event.c.orig
-+++ testcode/fake_event.c
-@@ -1766,7 +1766,7 @@ struct comm_point* outnet_comm_point_for_http(struct outside_network* outnet,
- }
-
- int comm_point_send_udp_msg(struct comm_point *c, sldns_buffer* packet,
-- struct sockaddr* addr, socklen_t addrlen)
-+ struct sockaddr* addr, socklen_t addrlen, int ATTR_UNUSED(is_connected))
- {
- struct fake_commpoint* fc = (struct fake_commpoint*)c;
- struct replay_runtime* runtime = fc->runtime;
-diff --git a/util/netevent.c b/util/netevent.c
-index 7c6da50be..88be007e7 100644
---- util/netevent.c.orig
-+++ util/netevent.c
-@@ -333,7 +333,7 @@ int tcp_connect_errno_needs_log(struct sockaddr* addr, socklen_t addrlen)
- /* send a UDP reply */
- int
- comm_point_send_udp_msg(struct comm_point *c, sldns_buffer* packet,
-- struct sockaddr* addr, socklen_t addrlen)
-+ struct sockaddr* addr, socklen_t addrlen, int is_connected)
- {
- ssize_t sent;
- log_assert(c->fd != -1);
-@@ -341,8 +341,8 @@ comm_point_send_udp_msg(struct comm_point *c, sldns_buffer* packet,
- if(sldns_buffer_remaining(packet) == 0)
- log_err("error: send empty UDP packet");
- #endif
-- if(addr) {
-- log_assert(addr && addrlen > 0);
-+ log_assert(addr && addrlen > 0);
-+ if(!is_connected) {
- sent = sendto(c->fd, (void*)sldns_buffer_begin(packet),
- sldns_buffer_remaining(packet), 0,
- addr, addrlen);
-@@ -367,9 +367,14 @@ comm_point_send_udp_msg(struct comm_point *c, sldns_buffer* packet,
- #endif
- int e;
- fd_set_block(c->fd);
-- sent = sendto(c->fd, (void*)sldns_buffer_begin(packet),
-- sldns_buffer_remaining(packet), 0,
-- addr, addrlen);
-+ if (!is_connected) {
-+ sent = sendto(c->fd, (void*)sldns_buffer_begin(packet),
-+ sldns_buffer_remaining(packet), 0,
-+ addr, addrlen);
-+ } else {
-+ sent = send(c->fd, (void*)sldns_buffer_begin(packet),
-+ sldns_buffer_remaining(packet), 0);
-+ }
- e = errno;
- fd_set_nonblock(c->fd);
- errno = e;
-@@ -378,8 +383,12 @@ comm_point_send_udp_msg(struct comm_point *c, sldns_buffer* packet,
- if(sent == -1) {
- if(!udp_send_errno_needs_log(addr, addrlen))
- return 0;
-- verbose(VERB_OPS, "sendto failed: %s", sock_strerror(errno));
-- log_addr(VERB_OPS, "remote address is",
-+ if (!is_connected) {
-+ verbose(VERB_OPS, "sendto failed: %s", sock_strerror(errno));
-+ } else {
-+ verbose(VERB_OPS, "send failed: %s", sock_strerror(errno));
-+ }
-+ log_addr(VERB_OPS, "remote address is",
- (struct sockaddr_storage*)addr, addrlen);
- return 0;
- } else if((size_t)sent != sldns_buffer_remaining(packet)) {
-@@ -764,7 +773,7 @@ comm_point_udp_callback(int fd, short event, void* arg)
- buffer = rep.c->buffer;
- #endif
- (void)comm_point_send_udp_msg(rep.c, buffer,
-- (struct sockaddr*)&rep.addr, rep.addrlen);
-+ (struct sockaddr*)&rep.addr, rep.addrlen, 0);
- }
- if(!rep.c || rep.c->fd != fd) /* commpoint closed to -1 or reused for
- another UDP port. Note rep.c cannot be reused with TCP fd. */
-@@ -3944,7 +3953,7 @@ comm_point_send_reply(struct comm_reply *repinfo)
- repinfo->addrlen, repinfo);
- else
- comm_point_send_udp_msg(repinfo->c, buffer,
-- (struct sockaddr*)&repinfo->addr, repinfo->addrlen);
-+ (struct sockaddr*)&repinfo->addr, repinfo->addrlen, 0);
- #ifdef USE_DNSTAP
- if(repinfo->c->dtenv != NULL &&
- repinfo->c->dtenv->log_client_response_messages)
-diff --git a/util/netevent.h b/util/netevent.h
-index 266a74ff3..810190683 100644
---- util/netevent.h.orig
-+++ util/netevent.h
-@@ -633,10 +633,11 @@ void comm_point_drop_reply(struct comm_reply* repinfo);
- * @param addr: where to send it to. If NULL, send is performed,
- * for connected sockets, to the connected address.
- * @param addrlen: length of addr.
-+ * @param is_connected: if the UDP socket is connect()ed.
- * @return: false on a failure.
- */
- int comm_point_send_udp_msg(struct comm_point* c, struct sldns_buffer* packet,
-- struct sockaddr* addr, socklen_t addrlen);
-+ struct sockaddr* addr, socklen_t addrlen,int is_connected);
-
- /**
- * Stop listening for input on the commpoint. No callbacks will happen.
diff --git a/dns/unbound/pkg-plist b/dns/unbound/pkg-plist
index 70585f43dc08..096f02fe14f8 100644
--- a/dns/unbound/pkg-plist
+++ b/dns/unbound/pkg-plist
@@ -5,7 +5,7 @@ libdata/pkgconfig/libunbound.pc
lib/libunbound.a
lib/libunbound.so
lib/libunbound.so.8
-lib/libunbound.so.8.1.11
+lib/libunbound.so.8.1.12
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unbound.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unboundmodule.py