aboutsummaryrefslogtreecommitdiff
path: root/dns/void-zones-tools
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-27 17:04:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-27 17:04:08 +0000
commit12c136c590d2508c5cbe1877207624f4d23bc3a9 (patch)
tree15eca32bd5c9021b0b60f1d09a9d676f804d7e3d /dns/void-zones-tools
parent26a462649b3a27072c6311d2c2232b3ad4381e88 (diff)
downloadports-12c136c590d2508c5cbe1877207624f4d23bc3a9.tar.gz
ports-12c136c590d2508c5cbe1877207624f4d23bc3a9.zip
dns/void-zones-tools: Respect CFLAGS and avoid using -march=native
It currently compiles with -march=native which breaks on some machines cc -march=native -mssse3 -ffast-math -std=c11 -g0 -Ofast -fstrict-aliasing -Wno-parentheses binutils.c -c -o binutils.o error: unknown target CPU 'k6-3' Given that the build is currently targeting the build host CPU, existing binary packages on pkg.FreeBSD.org (or elsewhere) might be broken on many machines too, so bump PORTREVISION to trigger a rebuild. PR: 230899 Submitted by: tobik Reported by: Marco Beishuizen <mbeis@xs4all.nl> Approved by: Vidar Karlsen <vidar@karlsen.tech> (maintainer) MFH: 2018Q3
Notes
Notes: svn path=/head/; revision=478228
Diffstat (limited to 'dns/void-zones-tools')
-rw-r--r--dns/void-zones-tools/Makefile2
-rw-r--r--dns/void-zones-tools/files/patch-Makefile19
2 files changed, 20 insertions, 1 deletions
diff --git a/dns/void-zones-tools/Makefile b/dns/void-zones-tools/Makefile
index 738b1b2e3443..058712575ef7 100644
--- a/dns/void-zones-tools/Makefile
+++ b/dns/void-zones-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= void-zones-tools
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= dns
MAINTAINER= vidar@karlsen.tech
diff --git a/dns/void-zones-tools/files/patch-Makefile b/dns/void-zones-tools/files/patch-Makefile
new file mode 100644
index 000000000000..453666088597
--- /dev/null
+++ b/dns/void-zones-tools/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2018-08-26 02:54:47 UTC
++++ Makefile
+@@ -25,15 +25,7 @@
+
+ CC ?= clang
+
+-.if $(MACHINE) == "i386" || $(MACHINE) == "amd64" || $(MACHINE) == "x86_64"
+-CFLAGS = $(CDEFS) -march=native -mssse3 -ffast-math
+-.elif $(MACHINE) == "arm"
+-CFLAGS = $(CDEFS) -fsigned-char
+-.else
+-CFLAGS = $(CDEFS)
+-.endif
+-
+-CFLAGS += -std=c11 -g0 -Ofast -fstrict-aliasing -Wno-parentheses
++CFLAGS += -std=c11 -fstrict-aliasing -Wno-parentheses
+ PREFIX ?= /usr/local
+
+ HEADERS = binutils.h store.h