aboutsummaryrefslogtreecommitdiff
path: root/dns/zonecheck/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-11-04 15:03:14 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-11-04 15:03:14 +0000
commitdd3641162f7817f696e81f0f85f7b7a53926197f (patch)
tree14b79a14b8aed8f7b569e3d8966a351b86bbd9b6 /dns/zonecheck/Makefile
parent33911e3f2e99af9246c1215b56c3b2608ef20c6e (diff)
downloadports-dd3641162f7817f696e81f0f85f7b7a53926197f.tar.gz
ports-dd3641162f7817f696e81f0f85f7b7a53926197f.zip
Notes
Diffstat (limited to 'dns/zonecheck/Makefile')
-rw-r--r--dns/zonecheck/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/dns/zonecheck/Makefile b/dns/zonecheck/Makefile
index 3bdfd20ad3d2..70d39ad99c77 100644
--- a/dns/zonecheck/Makefile
+++ b/dns/zonecheck/Makefile
@@ -6,30 +6,34 @@
#
PORTNAME= zonecheck
-PORTVERSION= 2.0.0b7
+PORTVERSION= 2.0.0b9
CATEGORIES= dns ipv6 ruby
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}/src
EXTRACT_SUFX= .tgz
MAINTAINER= janos.mohacsi@bsd.hu
-COMMENT= Perform consistency checks on DNS zone files
+COMMENT= Perform consistency checks on DNS zones
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
-
-BROKEN= "Broken dependency; will be removed after Feb 2"
+.if defined(WITH_X11)
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
+.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
USE_RUBY= yes
-NO_BUILD= yes
RUBY_VER= 1.8
-MAN1= zonecheck.1
+USE_RUBY_FEATURES= ruby18
-.include <bsd.port.pre.mk>
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= zonecheck.1
+DOCS= BUGS INSTALL README TODO
-.if ${RUBY_DEFAULT_VER} != ${RUBY_VER}
-BROKEN= Broken dependency. This might be only a package building issue. The problem is that the default Ruby version for i386 is ${RUBY_DEFAULT_VER}, while the default version for the other architectures is ${RUBY_VER}. This port requires Ruby ${RUBY_VER}. If you are using the right Ruby version, please remove the BROKEN line from the Makefile and try again.
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>