aboutsummaryrefslogtreecommitdiff
path: root/dns/zonenotify
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-16 08:42:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-16 08:42:05 +0000
commit4fd61099e1733bd5ee7554a49de05b31ecc3cec6 (patch)
tree7f9b4d117c15dff0df6f9b2fd73525b1b0801029 /dns/zonenotify
parent21febd9586fc45bed1cda3117a01c9a5bc706b72 (diff)
downloadports-4fd61099e1733bd5ee7554a49de05b31ecc3cec6.tar.gz
ports-4fd61099e1733bd5ee7554a49de05b31ecc3cec6.zip
Make port respect PREFIX.
Submitted by: pointyhat via kris Approved by: novel (mentor) (implicit)
Notes
Notes: svn path=/head/; revision=145536
Diffstat (limited to 'dns/zonenotify')
-rw-r--r--dns/zonenotify/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/dns/zonenotify/Makefile b/dns/zonenotify/Makefile
index 3e106d2a646d..e5c8a484f8ba 100644
--- a/dns/zonenotify/Makefile
+++ b/dns/zonenotify/Makefile
@@ -14,9 +14,15 @@ MASTER_SITES= http://morettoni.net/bsd/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A dns notify sender written in C
+USE_REINPLACE= yes
+
PLIST_FILES= bin/zonenotify
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
do-build:
${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} ${WRKSRC}/zonenotify.c