aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2021-03-12 08:41:52 +0000
committerDon Lewis <truckman@FreeBSD.org>2021-03-12 08:41:52 +0000
commit0204f3857481a9e8856135f80ff950e12584a882 (patch)
treea5bac9be17a2e9a6dfb9ba5780ad2ead6b32f329 /dns
parent7d9511aaceb9972a5651fe675638a27c32c63eb8 (diff)
downloadports-0204f3857481a9e8856135f80ff950e12584a882.tar.gz
ports-0204f3857481a9e8856135f80ff950e12584a882.zip
Add dns/dnsdbflex: Command line tool to use the DNSDB Flexible Search API
extensions. Sponsored by: Farsight Security, Inc.
Notes
Notes: svn path=/head/; revision=568149
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsdbflex/Makefile30
-rw-r--r--dns/dnsdbflex/distinfo3
-rw-r--r--dns/dnsdbflex/files/patch-Makefile15
-rw-r--r--dns/dnsdbflex/pkg-descr7
5 files changed, 56 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index e8bec8b7029a..afc8e3f4ee11 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -39,6 +39,7 @@
SUBDIR += dnscrypt-proxy2
SUBDIR += dnscrypt-wrapper
SUBDIR += dnsdbck
+ SUBDIR += dnsdbflex
SUBDIR += dnsdbq
SUBDIR += dnsdist
SUBDIR += dnsenum
diff --git a/dns/dnsdbflex/Makefile b/dns/dnsdbflex/Makefile
new file mode 100644
index 000000000000..0da074413d2e
--- /dev/null
+++ b/dns/dnsdbflex/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= dnsdbflex
+PORTVERSION= 1.0.4
+DISTVERSIONPREFIX= v
+CATEGORIES= dns
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Tool to use the DNSDB Flexible Search API extensions.
+
+LICENSE= APACHE20
+LICENSE_FILE_APACHE20= ${WRKSRC}/Apache-2.0
+
+LIB_DEPENDS= libjansson.so:devel/jansson \
+ libcurl.so:ftp/curl
+
+USES= compiler:c11 localbase
+USE_GITHUB= yes
+GH_ACCOUNT= farsightsec
+
+PORTSCOUT= limit:^[0-9]*\.[0-9]*\.[0-9]*$$
+
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${PREFIX}/share/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/dns/dnsdbflex/distinfo b/dns/dnsdbflex/distinfo
new file mode 100644
index 000000000000..d46a2693e3d4
--- /dev/null
+++ b/dns/dnsdbflex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613892179
+SHA256 (farsightsec-dnsdbflex-v1.0.4_GH0.tar.gz) = d07a4ce6ec0046db56bfa70932f5831427219dc2a206a2df3f382b883532dab4
+SIZE (farsightsec-dnsdbflex-v1.0.4_GH0.tar.gz) = 29121
diff --git a/dns/dnsdbflex/files/patch-Makefile b/dns/dnsdbflex/files/patch-Makefile
new file mode 100644
index 000000000000..71d87319bec9
--- /dev/null
+++ b/dns/dnsdbflex/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2020-10-14 17:44:31 UTC
++++ Makefile
+@@ -15,10 +15,10 @@
+ #
+
+ CURLINCL = `curl-config --cflags`
+-JANSINCL = -I/usr/local/include
++JANSINCL = -I$(LOCALBASE)/include
+
+ CURLLIBS = `[ ! -z "$$(curl-config --libs)" ] && curl-config --libs || curl-config --static-libs`
+-JANSLIBS = -L/usr/local/lib -ljansson
++JANSLIBS = -L$(LOCALBASE)/lib -ljansson
+
+ CWARN =-W -Wall -Wextra -Wcast-qual -Wpointer-arith -Wwrite-strings \
+ -Wmissing-prototypes -Wbad-function-cast -Wnested-externs \
diff --git a/dns/dnsdbflex/pkg-descr b/dns/dnsdbflex/pkg-descr
new file mode 100644
index 000000000000..d8334893344d
--- /dev/null
+++ b/dns/dnsdbflex/pkg-descr
@@ -0,0 +1,7 @@
+Command line tool to use the DNSDB Flexible Search API extensions on
+systems such as:
+ * the DNSDB Flex API server at Farsight Security
+
+An API key is required for operation.
+
+WWW: https://github.com/farsightsec/dnsdbflex