aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2022-06-26 11:30:57 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2022-06-26 19:43:25 +0000
commit0ea661c93be6c932e989181868913ad9caf36815 (patch)
tree81b1a1200c7268e6742250e6a6dfa36ebf7b3fb4 /dns
parentf7a54f55ba41d3f4967bd6a0d5715d4aa1cb393b (diff)
downloadports-0ea661c93be6c932e989181868913ad9caf36815.tar.gz
ports-0ea661c93be6c932e989181868913ad9caf36815.zip
dns/p5-DNS-nsdiff: add OPTIONS to select version of bind
Add a radiobutton option to select which of the availabile bind ports should be used to supply the `named-compilezone` executable that nsdiff depends on. Set the default to dns/bind918 as that's the recommended stable version from upstream.
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-DNS-nsdiff/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/dns/p5-DNS-nsdiff/Makefile b/dns/p5-DNS-nsdiff/Makefile
index 3ac8f8a9bc48..a206f3371209 100644
--- a/dns/p5-DNS-nsdiff/Makefile
+++ b/dns/p5-DNS-nsdiff/Makefile
@@ -2,6 +2,7 @@
PORTNAME= DNS-nsdiff
PORTVERSION= 1.82
+PORTREVISION= 1
CATEGORIES= dns perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,8 +12,19 @@ COMMENT= Create an "nsupdate" script from DNS zone file differences
LICENSE= CC0-1.0
-RUN_DEPENDS= nsupdate:dns/bind-tools \
- named-compilezone:dns/bind916
+RUN_DEPENDS= nsupdate:dns/bind-tools
+
+OPTIONS_RADIO= BIND
+OPTIONS_RADIO_BIND= BIND916 BIND918 BINDDEVEL
+OPTIONS_DEFAULT= BIND918
+
+BIND916_DESC= Use Bind 9.16 for named-compilezone
+BIND918_DESC= Use Bind 9.18 for named-compilezone
+BINDDEVEL_DESC= Use Bind 9-devel for named-compilezone
+
+BIND916_RUN_DEPENDS= named-compilezone:dns/bind916
+BIND918_RUN_DEPENDS= named-compilezone:dns/bind918
+BINDDEVEL_RUN_DEPENDS= named-compilezone:dns/bind9-devel
NO_ARCH= yes
USES= perl5