aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-05-21 12:39:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-05-21 12:51:36 +0000
commit1028dc308d951f61609a3c729e42bc79c11f3411 (patch)
tree48c12bfd334e322d3224f24b8b631a03b45475ad /dns
parentb2cf151291b6075a960575f0fa2d6f5565e6ce55 (diff)
downloadports-1028dc308d951f61609a3c729e42bc79c11f3411.tar.gz
ports-1028dc308d951f61609a3c729e42bc79c11f3411.zip
dns/bind911: Update to 9.11.32
Diffstat (limited to 'dns')
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl12
3 files changed, 10 insertions, 10 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index f80e86d7ed50..7d0d66d94648 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= cpe libedit pkgconfig
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.31
+ISCVERSION= 9.11.32
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index bdfd63ad0477..7881b45d36c3 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619513308
-SHA256 (bind-9.11.31.tar.gz) = f5f24457f42b2e86870d887596e47500e4d40521a098dcb96f3a06f18adfa36a
-SIZE (bind-9.11.31.tar.gz) = 8296079
+TIMESTAMP = 1621600149
+SHA256 (bind-9.11.32.tar.gz) = cbf8cb4b74dd1452d97c3a2a8c625ea346df8516b4b3508ef07443121a591342
+SIZE (bind-9.11.32.tar.gz) = 8300154
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index 2b11ce61b331..1776bb0c6724 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,7 +1,7 @@
- Add the min-cache-ttl config knob.
- Add the override-cache-ttl config knob.
---- bin/named/config.c.orig 2020-12-08 08:36:42 UTC
+--- bin/named/config.c.orig 2021-05-12 10:45:51 UTC
+++ bin/named/config.c
@@ -182,6 +182,8 @@ options {\n\
" max-acache-size 16M;\n\
@@ -12,9 +12,9 @@
max-clients-per-query 100;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
max-recursion-depth 7;\n\
---- bin/named/server.c.orig 2020-12-08 08:36:42 UTC
+--- bin/named/server.c.orig 2021-05-12 10:45:51 UTC
+++ bin/named/server.c
-@@ -3720,6 +3720,16 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -3721,6 +3721,16 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -31,7 +31,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2020-12-08 08:36:42 UTC
+--- lib/dns/include/dns/view.h.orig 2021-05-12 10:45:51 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,8 @@ struct dns_view {
bool requestnsid;
@@ -42,7 +42,7 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2020-12-08 08:36:42 UTC
+--- lib/dns/resolver.c.orig 2021-05-12 10:45:51 UTC
+++ lib/dns/resolver.c
@@ -5579,6 +5579,18 @@ cache_name(fetchctx_t *fctx, dns_message_t *rmessage,
}
@@ -63,7 +63,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-12-08 08:36:42 UTC
+--- lib/isccfg/namedconf.c.orig 2021-05-12 10:45:51 UTC
+++ lib/isccfg/namedconf.c
@@ -1773,6 +1773,8 @@ view_clauses[] = {
#endif