aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 11:37:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 11:37:25 +0000
commit1a724c79688a9195f9974709ed4e0d8fe5cab84d (patch)
tree7c7f6d52643d9ef342d7281f0da0e878eee5e15f /dns
parent8d5ae5fc00c1b94519780eda7f873fab021adaa1 (diff)
downloadports-1a724c79688a9195f9974709ed4e0d8fe5cab84d.tar.gz
ports-1a724c79688a9195f9974709ed4e0d8fe5cab84d.zip
dns/py-dns-lexicon: Add DDNS option
Diffstat (limited to 'dns')
-rw-r--r--dns/py-dns-lexicon/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/dns/py-dns-lexicon/Makefile b/dns/py-dns-lexicon/Makefile
index d9ed9762f98d..f769d3428328 100644
--- a/dns/py-dns-lexicon/Makefile
+++ b/dns/py-dns-lexicon/Makefile
@@ -23,13 +23,15 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= GRANSY LOCALZONE ROUTE53 SOFTLAYER TRANSIP
+OPTIONS_DEFINE= DDNS GRANSY LOCALZONE ROUTE53 SOFTLAYER TRANSIP
+DDNS_DESC= Dynamic DNS support
GRANSY_DESC= Gransy support
LOCALZONE_DESC= localzone support
ROUTE53_DESC= Route 53 support
SOFTLAYER_DESC= SoftLayer (IBM Cloud) support
TRANSIP_DESC= TransIP support
+DDNS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython2>=2<3:dns/py-dnspython2@${PY_FLAVOR}
GRANSY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zeep>=3<5:net/py-zeep@${PY_FLAVOR}
LOCALZONE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}localzone>=0.9.8<1:dns/py-localzone@${PY_FLAVOR}
ROUTE53_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1<2:www/py-boto3@${PY_FLAVOR}