aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-04-16 20:36:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-04-16 20:36:06 +0000
commit20ab4dcc976aa7bd3eeca20dc9ac91eff5be0744 (patch)
tree9e92df1d6a00c15333f4f0695e6ac32adf3fdae8 /dns
parentde56ca6e03df149ee1a0b9a13ed8bdee7b7b472e (diff)
downloadports-20ab4dcc976aa7bd3eeca20dc9ac91eff5be0744.tar.gz
ports-20ab4dcc976aa7bd3eeca20dc9ac91eff5be0744.zip
Add an option for installing python bindings.
PR: 156419 Approved by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=272816
Diffstat (limited to 'dns')
-rw-r--r--dns/ldns/Makefile17
-rw-r--r--dns/ldns/pkg-plist6
2 files changed, 21 insertions, 2 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index e9d518b89b6e..5b7b6dbac1fa 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -8,7 +8,8 @@
PORTNAME= ldns
PORTVERSION= 1.6.9
CATEGORIES= dns
-MASTER_SITES= http://www.nlnetlabs.nl/downloads/ldns/
+MASTER_SITES= http://www.nlnetlabs.nl/downloads/ldns/ \
+ CRITICAL
MAINTAINER= jaap@NLnetLabs.nl
COMMENT= A library for programs conforming to DNS RFCs and drafts
@@ -24,7 +25,8 @@ OPTIONS= DOCS "With documentation" Off \
EXAMPLES "With example programs" Off \
DRILL "With drill program" Off \
GOST "GOST signatures enabled (requires openssl >= 1.0.0)" Off \
- ECDSA "With highly experimental ECDSA support" Off
+ ECDSA "With highly experimental ECDSA support" Off \
+ PYLDNS "Build python bindings" Off
.include <bsd.port.pre.mk>
@@ -255,6 +257,17 @@ PLIST_SUB+= EXAMPLES="@comment "
CONFIGURE_ARGS+= --enable-ecdsa
.endif
+.if defined(WITH_PYLDNS)
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+CONFIGURE_ARGS+= --with-pyldns
+BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+INSTALL_TARGET+= install-pyldns
+PLIST_SUB+= PYLDNS=""
+.else
+PLIST_SUB+= PYLDNS="@comment "
+.endif
+
.if ${OSVERSION} < 700000
NO_SHA2= --disable-sha2
CONFIGURE_ARGS+= ${NO_SHA2}
diff --git a/dns/ldns/pkg-plist b/dns/ldns/pkg-plist
index c6fb32565584..54577cb9b2c6 100644
--- a/dns/ldns/pkg-plist
+++ b/dns/ldns/pkg-plist
@@ -55,4 +55,10 @@ lib/libldns.a
lib/libldns.la
lib/libldns.so
lib/libldns.so.1
+%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so.1
+%%PYLDNS%%%%PYTHON_SITELIBDIR%%/ldns.py
+%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so
+%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.la
+%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.a
+%%PYLDNS%%@dirrm %%PYTHON_SITELIBDIR%%/ldns
@dirrm include/ldns