aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-03-27 12:40:51 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-03-27 12:40:51 +0000
commit3ae1341fc62eec69a7054e91d71fe437e8d023e0 (patch)
tree90fe885c614b7d66a92837cda9d506571bcdc47a /dns
parent0b21f9fe9e827d972b87ca39af8beda1ffb35460 (diff)
downloadports-3ae1341fc62eec69a7054e91d71fe437e8d023e0.tar.gz
ports-3ae1341fc62eec69a7054e91d71fe437e8d023e0.zip
dns/dnsmasq-devel: update to v2.85rc2
* ea28d0e 2021-03-26 | Scale the DNS random scket pool on the value of dns-forward-max. (HEAD -> master, tag: v2.85rc2, origin/master, origin/HEAD) [Simon Kelley] * 4a8c098 2021-03-26 | Change the method of allocation of random source ports for DNS. [Simon Kelley] * ffa4628 2021-03-22 | Fix thinko in 51f7bc924cbcdeb09cbb83249b70c121d1ffa31e [黎醒聪] * e10a923 2021-03-15 | Move repeated test pattern to server_test_type [Petr Menšík] * 51f7bc9 2021-03-18 | Create common function for forward dump, log and send [Petr Menšík] * 6c0bf79 2021-03-18 | Reduce few repetitions in forward code [Petr Menšík] * 4b03170 2021-03-20 | Update German translation for 2.85rc1. [Matthias Andree] * 1de6bbc 2021-03-19 | Fix FTBS on FreeBSD due to Linux-specific optimisation of if_nametoindex() [Simon Kelley]
Notes
Notes: svn path=/head/; revision=569327
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq-devel/Makefile6
-rw-r--r--dns/dnsmasq-devel/distinfo6
-rw-r--r--dns/dnsmasq-devel/files/patch-src_network.c34
3 files changed, 6 insertions, 40 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index 9b51f589fce7..2c08176716f7 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.85rc1
+DISTVERSION= 2.85rc2
# Leave the PORTREVISION in even if 0 to avoid accidental PORTEPOCH bumps:
-PORTREVISION= 1
+PORTREVISION= 0
PORTEPOCH= 3 # attn - different between -devel and dnsmasq ports!
CATEGORIES= dns
MASTER_SITES= https://www.thekelleys.org.uk/dnsmasq/release-candidates/ \
@@ -17,7 +17,7 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
DEPRECATED= short-lived development branch, to be removed once 2.85 is released
-EXPIRATION_DATE=2021-03-31 # this is to keep dnsmasq-devel outside the quarterly branches
+EXPIRATION_DATE=2021-04-10
USES= cpe shebangfix tar:xz
CPE_VENDOR= thekelleys
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index 925def555089..c2a7e8fa1327 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616024487
-SHA256 (dnsmasq-2.85rc1.tar.xz) = 97bf5b606f0a5a9e439b464ac5d2296f64b0b19723985e5bc330beda6407a09a
-SIZE (dnsmasq-2.85rc1.tar.xz) = 537632
+TIMESTAMP = 1616842199
+SHA256 (dnsmasq-2.85rc2.tar.xz) = d5f359e993b6f3f690faa829178a556550e6d309289359a7bee2bf24f516af43
+SIZE (dnsmasq-2.85rc2.tar.xz) = 538376
diff --git a/dns/dnsmasq-devel/files/patch-src_network.c b/dns/dnsmasq-devel/files/patch-src_network.c
deleted file mode 100644
index 4518853d70eb..000000000000
--- a/dns/dnsmasq-devel/files/patch-src_network.c
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 1de6bbc10872b67f9f54a2511e6750a6071f5544
-Author: Simon Kelley <simon@thekelleys.org.uk>
-Date: Fri Mar 19 22:24:08 2021 +0000
-
- Fix FTBS on FreeBSD due to Linux-specific optimisation of if_nametoindex()
-
-diff --git a/src/network.c b/src/network.c
-index cca6ff2..b4a8d7d 100644
---- a/src/network.c
-+++ b/src/network.c
-@@ -720,13 +720,17 @@ int enumerate_interfaces(int reset)
- to a server is specified by an interface, so cache them.
- Update the cache here. */
- for (serv = daemon->servers; serv; serv = serv->next)
-- if (strlen(serv->interface) != 0)
-+ if (serv->interface[0] != 0)
- {
-- struct ifreq ifr;
--
-- safe_strncpy(ifr.ifr_name, serv->interface, IF_NAMESIZE);
-- if (ioctl(param.fd, SIOCGIFINDEX, &ifr) != -1)
-- serv->ifindex = ifr.ifr_ifindex;
-+#ifdef HAVE_LINUX_NETWORK
-+ struct ifreq ifr;
-+
-+ safe_strncpy(ifr.ifr_name, serv->interface, IF_NAMESIZE);
-+ if (ioctl(param.fd, SIOCGIFINDEX, &ifr) != -1)
-+ serv->ifindex = ifr.ifr_ifindex;
-+#else
-+ serv->ifindex = if_nametoindex(serv->interface);
-+#endif
- }
-
- again: