aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-12-10 13:39:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-12-10 13:39:55 +0000
commit4dc8511880bce0d96818d93e971a0c2b457b3520 (patch)
tree0d927d23c2d537aafe0d129eb3b0117bd1f91ffa /dns
parentd58529243647616349393995b5e57c8e5e709c41 (diff)
Update to latest commit.
The filter-aaaa feature is now a pluggable module. While there, ipv6 is not optional any more.
Notes
Notes: svn path=/head/; revision=487163
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile8
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist3
5 files changed, 21 insertions, 20 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 3c0b675e2387..c601e9061024 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -38,13 +38,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.4a0.2018.12.04
+ISCVERSION= 9.13.4a0.2018.12.10
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025
+GL_COMMIT= e5da71f746f11cc8df458d41d97d9f9c4a9a318d
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -81,7 +81,7 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFAULT= SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
- FIXED_RRSET SIGCHASE IPV6
+ FIXED_RRSET SIGCHASE
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= NATIVE_PKCS11
@@ -173,8 +173,6 @@ IDN_CONFIGURE_ON= --with-libidn2=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
IDN_USES= iconv
-IPV6_CONFIGURE_ENABLE= ipv6
-
JSON_CONFIGURE_WITH= libjson=${LOCALBASE}
JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 68ba43089244..18ef2674ad30 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543933450
-SHA256 (isc-projects-bind9-8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025_GL0.tar.gz) = 32d034e17714a286860e53c5b93d7f50032423a87608d6ea7ee3b98187953934
-SIZE (isc-projects-bind9-8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025_GL0.tar.gz) = 6309946
+TIMESTAMP = 1544431759
+SHA256 (isc-projects-bind9-e5da71f746f11cc8df458d41d97d9f9c4a9a318d_GL0.tar.gz) = 5b89328fdf4b37e10f8d649818d0eb1524cfc931a2679d77a49efe58be11b088
+SIZE (isc-projects-bind9-e5da71f746f11cc8df458d41d97d9f9c4a9a318d_GL0.tar.gz) = 6344168
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index d1f84cd708c9..5553edc32ab0 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2018-12-04 09:57:38 UTC
+--- bin/named/config.c.orig 2018-12-10 05:51:06 UTC
+++ bin/named/config.c
-@@ -182,6 +182,7 @@ options {\n\
+@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-12-04 09:57:38 UTC
+--- bin/named/server.c.orig 2018-12-10 05:51:06 UTC
+++ bin/named/server.c
-@@ -4124,6 +4124,11 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4154,6 +4154,11 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-12-04 09:57:38 UTC
+--- lib/dns/include/dns/view.h.orig 2018-12-10 05:51:06 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2018-12-04 09:57:38 UTC
+--- lib/dns/resolver.c.orig 2018-12-10 05:51:06 UTC
+++ lib/dns/resolver.c
@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -47,9 +47,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-12-04 09:57:38 UTC
+--- lib/isccfg/namedconf.c.orig 2018-12-10 05:51:06 UTC
+++ lib/isccfg/namedconf.c
-@@ -1921,6 +1921,7 @@ view_clauses[] = {
+@@ -1900,6 +1900,7 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index dc6855bd683b..f862cbbc7d23 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-12-04 09:57:38 UTC
+--- configure.orig 2018-12-10 05:51:06 UTC
+++ configure
-@@ -16308,27 +16308,9 @@ done
+@@ -16296,27 +16296,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16371,47 +16353,7 @@ $as_echo "no" >&6; } ;;
+@@ -16359,47 +16341,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20931,7 +20873,7 @@ $as_echo "" >&6; }
+@@ -20933,7 +20875,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 863c95b0f5b1..580cc0cf5959 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -250,6 +250,7 @@ include/isccfg/log.h
include/isccfg/namedconf.h
include/isccfg/version.h
include/ns/client.h
+include/ns/hooks.h
include/ns/interfacemgr.h
include/ns/lib.h
include/ns/listenlist.h
@@ -273,6 +274,7 @@ include/pkcs11/eddsa.h
include/pkcs11/pkcs11.h
include/pkcs11/pkcs11f.h
include/pkcs11/pkcs11t.h
+lib/filter-aaaa.so
lib/libbind9.a
lib/libdns.a
lib/libirs.a
@@ -306,6 +308,7 @@ man/man8/dnssec-revoke.8.gz
man/man8/dnssec-settime.8.gz
man/man8/dnssec-signzone.8.gz
man/man8/dnssec-verify.8.gz
+man/man8/filter-aaaa.8.gz
man/man8/named-checkconf.8.gz
man/man8/named-checkzone.8.gz
man/man8/named-compilezone.8.gz