aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-09-22 10:15:34 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-09-22 10:15:34 +0000
commit7544503abf14837089d3d6f11436d0e24ddc3f00 (patch)
tree6293bb83e724928286eaa02429dc7c4221ca848f /dns
parent192e596603472a5974f6d77c336074d1f6918c94 (diff)
downloadports-7544503abf14837089d3d6f11436d0e24ddc3f00.tar.gz
ports-7544503abf14837089d3d6f11436d0e24ddc3f00.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile3
-rw-r--r--dns/powerdns-recursor/distinfo6
-rw-r--r--dns/powerdns-recursor/files/patch-libressl31
-rw-r--r--dns/powerdns-recursor/files/patch-lua-recursor4.cc26
4 files changed, 31 insertions, 35 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 34d3fd8836ae..b84f782cda33 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= recursor
-PORTVERSION= 4.0.1
+PORTVERSION= 4.0.3
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
@@ -14,6 +14,7 @@ COMMENT= Advanced DNS recursor
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libboost_context.so:devel/boost-libs
BROKEN_sparc64= Does not compile on sparc64
BROKEN_FreeBSD_9= linker error
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index 3635c9139d1a..e5a5c7f9c220 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470038617
-SHA256 (pdns-recursor-4.0.1.tar.bz2) = 472db541307c8ca83a846d260ecfc854fd8e879c1bb2ce5683a8df5d21e860b0
-SIZE (pdns-recursor-4.0.1.tar.bz2) = 1035584
+TIMESTAMP = 1473284590
+SHA256 (pdns-recursor-4.0.3.tar.bz2) = ae9813a64d13d9ebe4b44e89e8e4e44fc438693b6ce4c3a98e4cab1af22d9627
+SIZE (pdns-recursor-4.0.3.tar.bz2) = 1045041
diff --git a/dns/powerdns-recursor/files/patch-libressl b/dns/powerdns-recursor/files/patch-libressl
deleted file mode 100644
index 37b1994ed150..000000000000
--- a/dns/powerdns-recursor/files/patch-libressl
+++ /dev/null
@@ -1,31 +0,0 @@
---- dns_random.cc.orig 2016-07-29 14:32:32 UTC
-+++ dns_random.cc
-@@ -2,7 +2,7 @@
- #include "config.h"
- #endif
- #include <openssl/aes.h>
--#if OPENSSL_VERSION_NUMBER > 0x1000100fL
-+#if OPENSSL_VERSION_NUMBER > 0x1000100fL && !defined LIBRESSL_VERSION_NUMBER
- // Older OpenSSL does not have CRYPTO_ctr128_encrypt. Before 1.1.0 the header
- // file did not have the necessary extern "C" wrapper. In 1.1.0, AES_ctr128_encrypt
- // was removed.
-@@ -53,7 +53,7 @@ unsigned int dns_random(unsigned int n)
- if(!g_initialized)
- abort();
- uint32_t out;
--#if OPENSSL_VERSION_NUMBER > 0x1000100fL
-+#if OPENSSL_VERSION_NUMBER > 0x1000100fL && !defined LIBRESSL_VERSION_NUMBER
- CRYPTO_ctr128_encrypt((const unsigned char*)&g_in, (unsigned char*) &out, sizeof(g_in), &aes_key, g_counter, g_stream, &g_offset, (block128_f) AES_encrypt);
- #else
- AES_ctr128_encrypt((const unsigned char*)&g_in, (unsigned char*) &out, sizeof(g_in), &aes_key, g_counter, g_stream, &g_offset);
---- opensslsigners.cc.orig 2016-07-29 14:32:32 UTC
-+++ opensslsigners.cc
-@@ -12,7 +12,7 @@
- #include "opensslsigners.hh"
- #include "dnssecinfra.hh"
-
--#if OPENSSL_VERSION_NUMBER < 0x1010000fL
-+#if (OPENSSL_VERSION_NUMBER < 0x1010000fL || defined LIBRESSL_VERSION_NUMBER)
- /* OpenSSL < 1.1.0 needs support for threading/locking in the calling application. */
- static pthread_mutex_t *openssllocks;
-
diff --git a/dns/powerdns-recursor/files/patch-lua-recursor4.cc b/dns/powerdns-recursor/files/patch-lua-recursor4.cc
new file mode 100644
index 000000000000..5a6483105e0e
--- /dev/null
+++ b/dns/powerdns-recursor/files/patch-lua-recursor4.cc
@@ -0,0 +1,26 @@
+--- lua-recursor4.cc.orig 2016-09-06 12:50:29 UTC
++++ lua-recursor4.cc
+@@ -263,8 +263,8 @@ RecursorLua4::RecursorLua4(const std::st
+ return DNSName(boost::get<const DNSName>(dom));
+ });
+ d_lw->registerFunction("isPartOf", &DNSName::isPartOf);
+- d_lw->registerFunction("countLabels", &DNSName::countLabels);
+- d_lw->registerFunction("wirelength", &DNSName::wirelength);
++ d_lw->registerFunction<unsigned int(DNSName::*)()>("countLabels", [](const DNSName& name) { return name.countLabels(); });
++ d_lw->registerFunction<size_t(DNSName::*)()>("wirelength", [](const DNSName& name) { return name.wirelength(); });
+ d_lw->registerFunction<bool(DNSName::*)(const std::string&)>(
+ "equal",
+ [](const DNSName& lhs, const std::string& rhs) {
+@@ -285,9 +285,9 @@ RecursorLua4::RecursorLua4(const std::st
+ } );
+ d_lw->registerFunction<bool(ComboAddress::*)()>("isIPv4", [](const ComboAddress& ca) { return ca.sin4.sin_family == AF_INET; });
+ d_lw->registerFunction<bool(ComboAddress::*)()>("isIPv6", [](const ComboAddress& ca) { return ca.sin4.sin_family == AF_INET6; });
+- d_lw->registerFunction("isMappedIPv4", &ComboAddress::isMappedIPv4);
+- d_lw->registerFunction("mapToIPv4", &ComboAddress::mapToIPv4);
+- d_lw->registerFunction("truncate", &ComboAddress::truncate);
++ d_lw->registerFunction<bool(ComboAddress::*)()>("isMappedIPv4", [](const ComboAddress& ca) { return ca.isMappedIPv4(); });
++ d_lw->registerFunction<ComboAddress(ComboAddress::*)()>("mapToIPv4", [](const ComboAddress& ca) { return ca.mapToIPv4(); });
++ d_lw->registerFunction<void(ComboAddress::*)(unsigned int)>("truncate", [](ComboAddress& ca, unsigned int bits) { ca.truncate(bits); });
+
+ d_lw->writeFunction("newCA", [](const std::string& a) { return ComboAddress(a); });
+ typedef std::unordered_set<ComboAddress,ComboAddress::addressOnlyHash,ComboAddress::addressOnlyEqual> cas_t;