aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-02-11 14:14:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-02-11 14:14:54 +0000
commit8f17b20df81a3f049a401a5ee90d707cd5949808 (patch)
tree3cfdeba7994740dcb293c86d00aa6ff01219f501 /dns
parent92860e7ab79786fd72782481da5c1fff6f706194 (diff)
downloadports-8f17b20df81a3f049a401a5ee90d707cd5949808.tar.gz
ports-8f17b20df81a3f049a401a5ee90d707cd5949808.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile96
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 62 insertions, 60 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 7e902e905167..f8fb8916e418 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -33,22 +33,22 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-LIB_DEPENDS= libxml2.so:textproc/libxml2 \
- libuv.so:devel/libuv
+LIB_DEPENDS= libuv.so:devel/libuv \
+ libxml2.so:textproc/libxml2
.if !defined(BIND_TOOLS_SLAVE)
RUN_DEPENDS= bind-tools>0:dns/bind-tools
.endif
# XXX: remove tar:bz2
-USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
+USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.8a0.2020.02.03
+ISCVERSION= 9.15.8a0.2020.02.11
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 9f6e0dc94511421b16ede0baaf04598d0fc62282
+GL_COMMIT= d3843161ab45a87ded170c7a4cdc1319b3d21e33
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -57,21 +57,22 @@ CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --with-libxml2 \
- --with-readline="-L${LOCALBASE}/lib -ledit" \
+CONFIGURE_ARGS= --disable-linux-caps \
+ --localstatedir=/var \
+ --sysconfdir=${ETCDIR} \
--with-dlopen=yes \
+ --with-libxml2 \
--with-openssl=${OPENSSLBASE} \
- --sysconfdir=${ETCDIR}
+ --with-readline="-L${LOCALBASE}/lib -ledit"
ETCDIR= ${PREFIX}/etc/namedb
.if defined(BIND_TOOLS_SLAVE)
CONFIGURE_ARGS+= --disable-shared
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-bind-tools
+EXTRA_PATCHES= ${PATCHDIR}/extrapatch-bind-tools
.else
-USE_RC_SUBR= named
-SUB_FILES= pkg-message named.conf
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-no-bind-tools
+USE_RC_SUBR= named
+SUB_FILES= named.conf pkg-message
+EXTRA_PATCHES= ${PATCHDIR}/extrapatch-no-bind-tools
PORTDOCS= *
@@ -81,26 +82,26 @@ CONFLICTS= bind911 bind912 bind913 bind914
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFAULT= DLZ_FILESYSTEM GSSAPI_NONE IDN JSON \
- LMDB PYTHON SIGCHASE TCP_FASTOPEN
-OPTIONS_DEFINE= DNSTAP DOCS FIXED_RRSET IDN JSON LARGE_FILE \
- LMDB OVERRIDECACHE PORTREVISION PYTHON QUERYTRACE \
- SIGCHASE START_LATE TCP_FASTOPEN TUNING_LARGE GEOIP
+OPTIONS_DEFAULT= DLZ_FILESYSTEM GSSAPI_NONE IDN JSON LMDB PYTHON \
+ SIGCHASE TCP_FASTOPEN
+OPTIONS_DEFINE= DNSTAP DOCS FIXED_RRSET GEOIP IDN JSON LARGE_FILE LMDB \
+ OVERRIDECACHE PORTREVISION PYTHON QUERYTRACE SIGCHASE \
+ START_LATE TCP_FASTOPEN TUNING_LARGE
-OPTIONS_RADIO= CRYPTO
+OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= NATIVE_PKCS11
OPTIONS_GROUP= DLZ
-OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
- DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
+OPTIONS_GROUP_DLZ= DLZ_BDB DLZ_FILESYSTEM DLZ_LDAP DLZ_MYSQL \
+ DLZ_POSTGRESQL DLZ_STUB
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
.if defined(BIND_TOOLS_SLAVE)
-OPTIONS_EXCLUDE= DOCS ${OPTIONS_GROUP_DLZ} \
- OVERRIDECACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
- START_LATE TUNING_LARGE TCP_FASTOPEN GEOIP
+OPTIONS_EXCLUDE= ${OPTIONS_GROUP_DLZ} DNSTAP DOCS GEOIP LMDB \
+ OVERRIDECACHE PORTREVISION QUERYTRACE START_LATE \
+ TCP_FASTOPEN TUNING_LARGE
.else
OPTIONS_EXCLUDE= PYTHON
.endif # BIND_TOOLS_SLAVE
@@ -139,7 +140,7 @@ DLZ_BDB_USES= bdb
DLZ_FILESYSTEM_CONFIGURE_ON= --with-dlz-filesystem=yes
DLZ_LDAP_CONFIGURE_ON= --with-dlz-ldap=yes
-DLZ_LDAP_USE= openldap=yes
+DLZ_LDAP_USE= OPENLDAP=yes
DLZ_MYSQL_CONFIGURE_ON= --with-dlz-mysql=yes
DLZ_MYSQL_USES= mysql
@@ -150,8 +151,8 @@ DLZ_POSTGRESQL_USES= pgsql
DLZ_STUB_CONFIGURE_ON= --with-dlz-stub=yes
DNSTAP_CONFIGURE_ENABLE= dnstap
-DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
- libprotobuf-c.so:devel/protobuf-c
+DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
+ libprotobuf-c.so:devel/protobuf-c
FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
@@ -159,22 +160,23 @@ GEOIP_CONFIGURE_ENABLE= geoip
GEOIP_CONFIGURE_WITH= maxminddb
GEOIP_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
-GSSAPI_BASE_CONFIGURE_ON=\
- --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
-GSSAPI_BASE_USES= gssapi
+GSSAPI_BASE_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} \
+ KRB5CONFIG="${KRB5CONFIG}"
+GSSAPI_BASE_USES= gssapi
-GSSAPI_HEIMDAL_CONFIGURE_ON=\
- --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
-GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} \
+ KRB5CONFIG="${KRB5CONFIG}"
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_MIT_CONFIGURE_ON=\
- --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
-GSSAPI_MIT_USES= gssapi:mit
+GSSAPI_MIT_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} \
+ KRB5CONFIG="${KRB5CONFIG}"
+GSSAPI_MIT_USES= gssapi:mit
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
IDN_CONFIGURE_OFF= --without-libidn2
-IDN_CONFIGURE_ON= --with-libidn2=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
+IDN_CONFIGURE_ON= ${ICONV_CONFIGURE_BASE} \
+ --with-libidn2=${LOCALBASE}
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
IDN_USES= iconv
@@ -194,16 +196,16 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
PYTHON_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR}
PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR}
-PYTHON_USES= python
+PYTHON_USES= python
QUERYTRACE_CONFIGURE_ENABLE= querytrace
SIGCHASE_CONFIGURE_ON= STD_CDEFINES="-DDIG_SIGCHASE=1"
-START_LATE_SUB_LIST= NAMED_REQUIRE="SERVERS cleanvar" \
- NAMED_BEFORE="LOGIN"
-START_LATE_SUB_LIST_OFF=NAMED_REQUIRE="NETWORKING ldconfig syslogd" \
- NAMED_BEFORE="SERVERS"
+START_LATE_SUB_LIST= NAMED_BEFORE="LOGIN" \
+ NAMED_REQUIRE="SERVERS cleanvar"
+START_LATE_SUB_LIST_OFF= NAMED_BEFORE="SERVERS" \
+ NAMED_REQUIRE="NETWORKING ldconfig syslogd"
TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
@@ -213,11 +215,11 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable \
- --enable-developer
-USES+= perl5
-USE_PERL5= build
-BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
+CONFIGURE_ARGS+= --enable-developer \
+ --enable-symtable
+USES+= perl5
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 2451ca5f6b75..8aca966d3d4b 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580734578
-SHA256 (isc-projects-bind9-9f6e0dc94511421b16ede0baaf04598d0fc62282_GL0.tar.gz) = c5e0a40cebe1ea1d7d297da128b6be5b22146841401c6fb81834eef5a1356285
-SIZE (isc-projects-bind9-9f6e0dc94511421b16ede0baaf04598d0fc62282_GL0.tar.gz) = 6346668
+TIMESTAMP = 1581426685
+SHA256 (isc-projects-bind9-d3843161ab45a87ded170c7a4cdc1319b3d21e33_GL0.tar.gz) = e381ea3c123b444c78c0afc82ebc8913a0ac291e5eb0fc618151cff16659d734
+SIZE (isc-projects-bind9-d3843161ab45a87ded170c7a4cdc1319b3d21e33_GL0.tar.gz) = 6353739
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index e7abd53b1d69..2f95f8d3a5a9 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-01-16 07:41:10 UTC
+--- bin/named/config.c.orig 2020-02-11 10:42:52 UTC
+++ bin/named/config.c
@@ -178,6 +178,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-01-16 07:41:10 UTC
+--- bin/named/server.c.orig 2020-02-11 10:42:52 UTC
+++ bin/named/server.c
@@ -4303,6 +4303,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-01-16 07:41:10 UTC
+--- lib/dns/include/dns/view.h.orig 2020-02-11 10:42:52 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-01-16 07:41:10 UTC
+--- lib/dns/resolver.c.orig 2020-02-11 10:42:52 UTC
+++ lib/dns/resolver.c
@@ -6032,6 +6032,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-01-16 07:41:10 UTC
+--- lib/isccfg/namedconf.c.orig 2020-02-11 10:42:52 UTC
+++ lib/isccfg/namedconf.c
-@@ -1980,6 +1980,7 @@ view_clauses[] = {
+@@ -2003,6 +2003,7 @@ view_clauses[] = {
#endif
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 5dcccac9eeb4..2d652d3d20d6 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-01-16 07:41:10 UTC
+--- configure.orig 2020-02-11 10:42:52 UTC
+++ configure
-@@ -17440,27 +17440,9 @@ done
+@@ -17448,27 +17448,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17503,47 +17485,7 @@ $as_echo "no" >&6; } ;;
+@@ -17511,47 +17493,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23055,7 +22997,7 @@ $as_echo "" >&6; }
+@@ -23058,7 +23000,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).