aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-19 15:43:33 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-19 15:43:33 +0000
commit91e4e8a4e39fb58b7f561b303947252390d62e3d (patch)
tree007c8519a6455a0a0c70a67ca551339c6c99673c /dns
parentb325ed20621b89892e9303249333c4deda2e4f15 (diff)
downloadports-91e4e8a4e39fb58b7f561b303947252390d62e3d.tar.gz
ports-91e4e8a4e39fb58b7f561b303947252390d62e3d.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/ipcheck/Makefile2
-rw-r--r--dns/ldns/Makefile2
-rw-r--r--dns/py-adns/Makefile5
-rw-r--r--dns/py-bonjour/Makefile5
-rw-r--r--dns/py-dns/Makefile5
-rw-r--r--dns/py-dnspython/Makefile5
-rw-r--r--dns/py-easyzone/Makefile5
-rw-r--r--dns/py-idnkit2/Makefile6
-rw-r--r--dns/py-namebench/Makefile6
-rw-r--r--dns/py-publicsuffix/Makefile5
-rw-r--r--dns/py-twistedNames/Makefile6
-rw-r--r--dns/sshfp/Makefile2
-rw-r--r--dns/unbound/Makefile2
13 files changed, 23 insertions, 33 deletions
diff --git a/dns/ipcheck/Makefile b/dns/ipcheck/Makefile
index 9629ba81e9cc..094adfed42ad 100644
--- a/dns/ipcheck/Makefile
+++ b/dns/ipcheck/Makefile
@@ -16,7 +16,7 @@ COMMENT= Fully compliant DynDNS.org client for UNIX (supports NIC v2.0)
LICENSE= GPLv2
-USE_PYTHON= yes
+USES= python
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 4c1936927359..5375b7cd4e8c 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -41,7 +41,7 @@ OPTIONS_SUB= yes
.include <bsd.port.options.mk>
.if defined(BUILD_PYLDNS)
-USE_PYTHON= yes
+USES+= python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
ALL_TARGET= pyldns
INSTALL_TARGET= install-pyldns
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 6ac1323462e5..b5d7ce162019 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -15,9 +15,8 @@ COMMENT= Python Interface to adns, the asynchronous DNS library
LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns
PROJECTHOST= adns-python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
post-patch:
@${REINPLACE_CMD} -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
diff --git a/dns/py-bonjour/Makefile b/dns/py-bonjour/Makefile
index 61fc2832a821..b0f7e33938fd 100644
--- a/dns/py-bonjour/Makefile
+++ b/dns/py-bonjour/Makefile
@@ -11,9 +11,8 @@ COMMENT= Python interface to bonjour
LICENSE= MIT
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONS_SINGLE= ZEROCONF
OPTIONS_SINGLE_ZEROCONF= AVAHI MDNSRESPONDER
diff --git a/dns/py-dns/Makefile b/dns/py-dns/Makefile
index 42447d8c79ff..0b62a8745ee0 100644
--- a/dns/py-dns/Makefile
+++ b/dns/py-dns/Makefile
@@ -17,9 +17,8 @@ LICENSE_NAME= CNRI LICENSE AGREEMENT
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
PORTDOCS= README.txt README-guido.txt
DOCSDIR= ${PREFIX}/share/doc/py-dns
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index 3f21e98b5bd2..fbe8152a0957 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -12,9 +12,8 @@ DISTNAME= ${PORTNAME}${PORTVERSIONSUFFIX}-${PORTVERSION}
MAINTAINER= rm@FreeBSD.org
COMMENT= DNS toolkit for Python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
OPTIONS_DEFINE= DOCS EXAMPLES PYCRYPTO
diff --git a/dns/py-easyzone/Makefile b/dns/py-easyzone/Makefile
index 6648247c0876..d5065db18d5b 100644
--- a/dns/py-easyzone/Makefile
+++ b/dns/py-easyzone/Makefile
@@ -16,8 +16,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.9.4:${PORTSDIR}/dns/py-dnspython
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/dns/py-idnkit2/Makefile b/dns/py-idnkit2/Makefile
index f3a3509cd239..7372eb7bcafe 100644
--- a/dns/py-idnkit2/Makefile
+++ b/dns/py-idnkit2/Makefile
@@ -12,10 +12,8 @@ COMMENT= Python bindings for Internationalized Domain Name toolkit 2
LIB_DEPENDS= libidnkitlite.so:${PORTSDIR}/dns/idnkit2
-USES= tar:bzip2
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2 tar:bzip2
+USE_PYTHON= distutils autoplist
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/dns/py-namebench/Makefile b/dns/py-namebench/Makefile
index 36ff86773d83..ff7dac65c623 100644
--- a/dns/py-namebench/Makefile
+++ b/dns/py-namebench/Makefile
@@ -32,10 +32,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README.txt
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
PYDISTUTILS_INSTALLARGS+= --install-data=${PREFIX}/share
-PYDISTUTILS_AUTOPLIST= yes
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
diff --git a/dns/py-publicsuffix/Makefile b/dns/py-publicsuffix/Makefile
index bb603b3e63e9..c36544efc7ca 100644
--- a/dns/py-publicsuffix/Makefile
+++ b/dns/py-publicsuffix/Makefile
@@ -12,8 +12,7 @@ COMMENT= Get public suffix of domain name from Public Suffix List
LICENSE= MIT
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/dns/py-twistedNames/Makefile b/dns/py-twistedNames/Makefile
index 68f776c639e3..8cc9a8b25166 100644
--- a/dns/py-twistedNames/Makefile
+++ b/dns/py-twistedNames/Makefile
@@ -14,9 +14,7 @@ COMMENT= DNS protocol implementation with client and server
LICENSE= MIT
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= tar:bzip2 twisted
+USE_PYTHON= distutils autoplist
+USES= python:2 tar:bzip2 twisted
.include <bsd.port.mk>
diff --git a/dns/sshfp/Makefile b/dns/sshfp/Makefile
index cf080c68af31..ffb10f057e18 100644
--- a/dns/sshfp/Makefile
+++ b/dns/sshfp/Makefile
@@ -15,8 +15,8 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
${PYTHON_PKGNAMEPREFIX}ipcalc>=0.6:${PORTSDIR}/net-mgmt/py-ipcalc \
${PYTHON_SITELIBDIR}/ldns.py:${PORTSDIR}/dns/py-ldns
+USES= python
NO_BUILD= yes
-USE_PYTHON= yes
USE_GITHUB= yes
GH_ACCOUNT= xelerance
GH_TAGNAME= ${PORTVERSION}
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 05532d4f5ddf..f0714e32852d 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -46,7 +46,7 @@ STRIP_FILES= .libs/libunbound.so unbound-checkconf unbound \
unbound-control .libs/unbound-host .libs/unbound-anchor
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
CONFIGURE_ARGS+=--with-pyunbound=yes --with-pythonmodule=yes
BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
PYTHON=