aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
commit927c9c2190303cbf488da40b21aa8f687198bb23 (patch)
treeb50875b389c063d1bcadc768e710973b1992efd2 /dns
parent2a6d3bd8e2df3f99bd5bc37be426951c272419b9 (diff)
downloadports-927c9c2190303cbf488da40b21aa8f687198bb23.tar.gz
ports-927c9c2190303cbf488da40b21aa8f687198bb23.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index d2de181426c6..55393d6f0395 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -19,16 +19,22 @@ COMMENT= DNSSEC extensions to Net::DNS
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/DSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
Net::DNS::RR::NXT.3 Net::DNS::RR::SIG.3 \
Net::DNS::RR::SIG::Private.3 Net::DNS::SEC.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>