aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-12-24 12:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-12-24 12:49:36 +0000
commita0a51888df05e0c66f4ac282a238281e8b405a5d (patch)
tree73f915a055b6c0f2641c29c7f9b47b7461e00691 /dns
parentb4e8e5bf418f32a3af2dec58c5aea64f77e588f9 (diff)
Update to latest commit.
Notes
Notes: svn path=/head/; revision=488270
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-bin_named_include_named_globals.h4
-rw-r--r--dns/bind9-devel/files/patch-configure8
5 files changed, 18 insertions, 18 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 088de14f95be..3a9f552d8a75 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -38,13 +38,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.4a0.2018.12.14
+ISCVERSION= 9.13.4a0.2018.12.20
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 4af9f9718989212480f2a5243a79886b8e7934c2
+GL_COMMIT= 1b95cb79bbb53e0cbec8618678c99b35985d22be
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index fdab8adf47e6..d78cc1adf865 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545045986
-SHA256 (isc-projects-bind9-4af9f9718989212480f2a5243a79886b8e7934c2_GL0.tar.gz) = 9a400af41968ade21df0f72d8b197b2f7bb43400fe2d5332a1549b2c7b73a1bb
-SIZE (isc-projects-bind9-4af9f9718989212480f2a5243a79886b8e7934c2_GL0.tar.gz) = 6341661
+TIMESTAMP = 1545648454
+SHA256 (isc-projects-bind9-1b95cb79bbb53e0cbec8618678c99b35985d22be_GL0.tar.gz) = 569e9fea081f7c6daa0f3c7089a096bd3b546b098972f569e9f77bb011143cdf
+SIZE (isc-projects-bind9-1b95cb79bbb53e0cbec8618678c99b35985d22be_GL0.tar.gz) = 6344732
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 3e1e7c5e5f93..01eda3492698 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-12-15 02:47:23 UTC
+--- bin/named/config.c.orig 2018-12-20 23:38:02 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-12-15 02:47:23 UTC
+--- bin/named/server.c.orig 2018-12-20 23:38:02 UTC
+++ bin/named/server.c
-@@ -4153,6 +4153,11 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4153,6 +4153,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-12-15 02:47:23 UTC
+--- lib/dns/include/dns/view.h.orig 2018-12-20 23:38:02 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
@@ -32,9 +32,9 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2018-12-15 02:47:23 UTC
+--- lib/dns/resolver.c.orig 2018-12-20 23:38:02 UTC
+++ lib/dns/resolver.c
-@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-12-15 02:47:23 UTC
+--- lib/isccfg/namedconf.c.orig 2018-12-20 23:38:02 UTC
+++ lib/isccfg/namedconf.c
@@ -1900,6 +1900,7 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-bin_named_include_named_globals.h b/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
index 41fdeefeadbd..f2ac8e9e6587 100644
--- a/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
+++ b/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
@@ -1,8 +1,8 @@
We reference the pid file as being run/named/pid everywere else.
---- bin/named/include/named/globals.h.orig 2018-08-13 11:22:25 UTC
+--- bin/named/include/named/globals.h.orig 2018-12-20 23:38:02 UTC
+++ bin/named/include/named/globals.h
-@@ -128,7 +128,7 @@ EXTERN bool named_g_forcelock INIT(fals
+@@ -128,7 +128,7 @@ EXTERN bool named_g_forcelock INIT(false);
#if NAMED_RUN_PID_DIR
EXTERN const char * named_g_defaultpidfile INIT(NAMED_LOCALSTATEDIR
"/run/named/"
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index f862cbbc7d23..a16e437bf6f7 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-12-10 05:51:06 UTC
+--- configure.orig 2018-12-20 23:38:02 UTC
+++ configure
-@@ -16296,27 +16296,9 @@ done
+@@ -16302,27 +16302,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16359,47 +16341,7 @@ $as_echo "no" >&6; } ;;
+@@ -16365,47 +16347,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20933,7 +20875,7 @@ $as_echo "" >&6; }
+@@ -20939,7 +20881,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).