aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-03-08 01:48:33 +0000
committerWen Heping <wen@FreeBSD.org>2017-03-08 01:48:33 +0000
commita300cdae9c191e3fa57424d469b1caf539e7c70c (patch)
treeb5a914dc25a7f0f6cc5d423e4929bff4e519ff84 /dns
parentf4bad9644763989ce1d131ab2e111cf17721a7e9 (diff)
downloadports-a300cdae9c191e3fa57424d469b1caf539e7c70c.tar.gz
ports-a300cdae9c191e3fa57424d469b1caf539e7c70c.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile7
-rw-r--r--dns/unbound/distinfo6
-rw-r--r--dns/unbound/files/unbound.in14
-rw-r--r--dns/unbound/pkg-plist2
4 files changed, 13 insertions, 16 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 3ff889034a73..9dadd17b0221 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unbound
-PORTVERSION= 1.6.0
-PORTREVISION= 3
+PORTVERSION= 1.6.1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -16,8 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libldns.so:dns/ldns
-BROKEN_aarch64= Fails to link: missing sbrk
-
USES= autoreconf cpe libtool ssl
CPE_VENDOR= nlnetlabs
GNU_CONFIGURE= yes
@@ -61,7 +58,7 @@ LIBEVENT_LIB_DEPENDS= libevent.so:devel/libevent
LIBEVENT_LDFLAGS+= $$(pkg-config libevent --libs-only-L)
LIBEVENT_USES= pkgconfig
MUNIN_PLUGIN_SUB_FILES= pkg-message
-PYTHON_BUILD_DEPENDS= swig:devel/swig13
+PYTHON_BUILD_DEPENDS= swig:devel/swig30
PYTHON_CONFIGURE_ON= --with-pyunbound=yes --with-pythonmodule=yes LDFLAGS="-L${LOCALBASE}/lib"
PYTHON_USES= python:2
PYTHON_VARS= STRIP_FILES+=.libs/_unbound.so
diff --git a/dns/unbound/distinfo b/dns/unbound/distinfo
index b4ae370caee4..b3342a022980 100644
--- a/dns/unbound/distinfo
+++ b/dns/unbound/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481819504
-SHA256 (unbound-1.6.0.tar.gz) = 6b7db874e6debda742fee8869d722e5a17faf1086e93c911b8564532aeeffab7
-SIZE (unbound-1.6.0.tar.gz) = 5063253
+TIMESTAMP = 1487712193
+SHA256 (unbound-1.6.1.tar.gz) = 42df63f743c0fe8424aeafcf003ad4b880b46c14149d696057313f5c1ef51400
+SIZE (unbound-1.6.1.tar.gz) = 5074713
diff --git a/dns/unbound/files/unbound.in b/dns/unbound/files/unbound.in
index b587b1580eea..932ceee95ec6 100644
--- a/dns/unbound/files/unbound.in
+++ b/dns/unbound/files/unbound.in
@@ -33,15 +33,15 @@ unbound_anchorflags=${unbound_anchorflags:-""}
start_precmd()
{
- %%PREFIX%%/sbin/unbound-checkconf > /dev/null && \
- echo -n "Obtaining a trust anchor:" && \
- if [ "${unbound_anchorflags}T" = "T" ]; then \
- su -m unbound -c %%PREFIX%%/sbin/unbound-anchor; \
+ echo -n "Obtaining a trust anchor:"
+ if [ "${unbound_anchorflags}T" = "T" ]; then
+ su -m unbound -c %%PREFIX%%/sbin/unbound-anchor
else
- su -m unbound -c "%%PREFIX%%/sbin/unbound-anchor ${unbound_anchorflags}"; \
- fi &&
+ su -m unbound -c "%%PREFIX%%/sbin/unbound-anchor ${unbound_anchorflags}"
+ fi
echo .
- return 0
+ %%PREFIX%%/sbin/unbound-checkconf > /dev/null
+ return $?
}
run_rc_command "$1"
diff --git a/dns/unbound/pkg-plist b/dns/unbound/pkg-plist
index 70f477a6df4b..1ca9b6288ca9 100644
--- a/dns/unbound/pkg-plist
+++ b/dns/unbound/pkg-plist
@@ -3,7 +3,7 @@ include/unbound.h
lib/libunbound.a
lib/libunbound.so
lib/libunbound.so.2
-lib/libunbound.so.2.4.3
+lib/libunbound.so.2.4.4
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unbound.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unboundmodule.py