aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-03-19 08:38:43 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-03-19 08:38:43 +0000
commitc2ef5a47f023a8eea0fa00dc6981f287cbc26437 (patch)
treea4721dbe29a9643dc064f7e30db8a8f8d1b33902 /dns
parentf2290c763e5a90032727eeda2aecc1d0f0036acd (diff)
downloadports-c2ef5a47f023a8eea0fa00dc6981f287cbc26437.tar.gz
ports-c2ef5a47f023a8eea0fa00dc6981f287cbc26437.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile10
-rw-r--r--dns/bind911/Makefile15
-rw-r--r--dns/bind912/Makefile15
-rw-r--r--dns/bind913/Makefile10
-rw-r--r--dns/bind914/Makefile10
5 files changed, 50 insertions, 10 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 02a7040c088d..c70ef7f1764b 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -197,14 +197,20 @@ TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
TUNING_LARGE_CONFIGURE_ON= --with-tuning=large
TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable
+CONFIGURE_ARGS+= --enable-symtable \
+ --enable-developer
+USES+= perl5 pkgconfig
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
+.include <bsd.port.pre.mk>
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index b74901213c1f..008341b83733 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -185,14 +185,25 @@ TUNING_LARGE_IMPLIES= THREADS
TUNING_LARGE_CONFIGURE_ON= --with-tuning=large
TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable
+CONFIGURE_ARGS+= --enable-symtable \
+ --enable-developer
+USES+= perl5 pkgconfig
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
+# Developer mode needs ssl, always
+.if !${PORT_OPTIONS:MSSL}
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+USES+= ssl
+.endif
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
+.include <bsd.port.pre.mk>
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index d7b1fd1bb98a..4a411cf44453 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -203,14 +203,25 @@ TUNING_LARGE_IMPLIES= THREADS
TUNING_LARGE_CONFIGURE_ON= --with-tuning=large
TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable
+CONFIGURE_ARGS+= --enable-symtable \
+ --enable-developer
+USES+= perl5 pkgconfig
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
+# Developer mode needs ssl, always
+.if !${PORT_OPTIONS:MSSL}
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+USES+= ssl
+.endif
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
+.include <bsd.port.pre.mk>
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else
diff --git a/dns/bind913/Makefile b/dns/bind913/Makefile
index 83322ab02d02..d9ec8299025f 100644
--- a/dns/bind913/Makefile
+++ b/dns/bind913/Makefile
@@ -184,14 +184,20 @@ TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
TUNING_LARGE_CONFIGURE_ON= --with-tuning=large
TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable
+CONFIGURE_ARGS+= --enable-symtable \
+ --enable-developer
+USES+= perl5 pkgconfig
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
+.include <bsd.port.pre.mk>
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else
diff --git a/dns/bind914/Makefile b/dns/bind914/Makefile
index d9ed1221ac1b..81e8b31ac213 100644
--- a/dns/bind914/Makefile
+++ b/dns/bind914/Makefile
@@ -184,14 +184,20 @@ TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
TUNING_LARGE_CONFIGURE_ON= --with-tuning=large
TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-symtable
+CONFIGURE_ARGS+= --enable-symtable \
+ --enable-developer
+USES+= perl5 pkgconfig
+USE_PERL5= build
+BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
.else
CONFIGURE_ARGS+= --disable-symtable
.endif
+.include <bsd.port.pre.mk>
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else