aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-11-12 17:28:04 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-11-12 17:28:04 +0000
commitd664f7accefdc221c09eae4ff72bfcd003be7c34 (patch)
tree509a83241f0eedb615897bd764ae1946a19fc7be /dns
parent0d9669ae7403e9f27c23bfca602c34e0758983b9 (diff)
downloadports-d664f7accefdc221c09eae4ff72bfcd003be7c34.tar.gz
ports-d664f7accefdc221c09eae4ff72bfcd003be7c34.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 16 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 69528f87e28c..ee45bd065fd3 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.1a0.2018.11.02
+ISCVERSION= 9.13.1a0.2018.11.12
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= d88efa7e40cbf244ca7886d8ddf0f0361ce8a518
+GL_COMMIT= 62a92b7784a6fb5a1b29bce398d18e892a62846b
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 5e1673496a10..55090375db1b 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541405974
-SHA256 (isc-projects-bind9-d88efa7e40cbf244ca7886d8ddf0f0361ce8a518_GL0.tar.gz) = b8794031fcf4552f7cd305c2787bc4c6389e8ce35915c6a01212dc8877f04bdd
-SIZE (isc-projects-bind9-d88efa7e40cbf244ca7886d8ddf0f0361ce8a518_GL0.tar.gz) = 7266983
+TIMESTAMP = 1542017471
+SHA256 (isc-projects-bind9-62a92b7784a6fb5a1b29bce398d18e892a62846b_GL0.tar.gz) = 9d15143db25acb78d332574251bd92932b8c2e72610483f2d2c85882840ea616
+SIZE (isc-projects-bind9-62a92b7784a6fb5a1b29bce398d18e892a62846b_GL0.tar.gz) = 7273651
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 13433158014c..da4f49888a6b 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-10-31 13:26:42 UTC
+--- bin/named/config.c.orig 2018-11-12 07:12:04 UTC
+++ bin/named/config.c
@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-10-31 13:26:42 UTC
+--- bin/named/server.c.orig 2018-11-12 07:12:04 UTC
+++ bin/named/server.c
-@@ -4101,6 +4101,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4109,6 +4109,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-10-31 13:26:42 UTC
+--- lib/dns/include/dns/view.h.orig 2018-11-12 07:12:04 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,8 @@ struct dns_view {
bool requestnsid;
@@ -45,9 +45,9 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-10-31 13:26:42 UTC
+--- lib/dns/resolver.c.orig 2018-11-12 07:12:04 UTC
+++ lib/dns/resolver.c
-@@ -5926,6 +5926,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5952,6 +5952,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -66,7 +66,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-10-31 13:26:42 UTC
+--- lib/isccfg/namedconf.c.orig 2018-11-12 07:12:04 UTC
+++ lib/isccfg/namedconf.c
@@ -1921,6 +1921,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index c755393270a1..08a1f5b33671 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-10-31 13:26:42 UTC
+--- configure.orig 2018-11-12 07:12:04 UTC
+++ configure
-@@ -16328,27 +16328,9 @@ done
+@@ -16389,27 +16389,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16391,47 +16373,7 @@ $as_echo "no" >&6; } ;;
+@@ -16452,47 +16434,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20980,7 +20922,7 @@ $as_echo "" >&6; }
+@@ -21032,7 +20974,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).