aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-05-25 16:50:39 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-05-25 16:50:39 +0000
commite3fa3ab157e8d6ea1f74fcf4fff53c4218da26a0 (patch)
treebc81a5e83c2dbce79727eaab5f2c5ed2fa2e22fc /dns
parentad2a4bf0d67d60b731ff4e623c09958dc6961c4a (diff)
downloadports-e3fa3ab157e8d6ea1f74fcf4fff53c4218da26a0.tar.gz
ports-e3fa3ab157e8d6ea1f74fcf4fff53c4218da26a0.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/pkg-plist1
4 files changed, 13 insertions, 12 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index a4d9d0c67b74..1b966bc7d722 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -48,13 +48,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.0a0.2020.05.10
+ISCVERSION= 9.17.0a0.2020.05.25
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 7b4d07c31dab70e9c168dd134a61b121b2587718
+GL_COMMIT= 8422b23c921176329c07e57aa26dfa32ed63cd4f
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 3527f9bf3d20..eeabe99bd455 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589189924
-SHA256 (isc-projects-bind9-7b4d07c31dab70e9c168dd134a61b121b2587718_GL0.tar.gz) = 71218dbb3e33916a138e92562ee2f36471fc79aae8ebdbf10e976633e5730290
-SIZE (isc-projects-bind9-7b4d07c31dab70e9c168dd134a61b121b2587718_GL0.tar.gz) = 4462883
+TIMESTAMP = 1590418666
+SHA256 (isc-projects-bind9-8422b23c921176329c07e57aa26dfa32ed63cd4f_GL0.tar.gz) = 179f61e59e119993196f52c262f57fa792dbe9d788811c713cbfb4d1108429fe
+SIZE (isc-projects-bind9-8422b23c921176329c07e57aa26dfa32ed63cd4f_GL0.tar.gz) = 4473365
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 4ef36c65ea90..6ef48704f746 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-05-10 23:44:14 UTC
+--- bin/named/config.c.orig 2020-05-25 12:38:28 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-05-10 23:44:14 UTC
+--- bin/named/server.c.orig 2020-05-25 12:38:28 UTC
+++ bin/named/server.c
@@ -4331,6 +4331,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -18,13 +18,13 @@ Add the override-cache-ttl feature.
obj = NULL;
+ result = named_config_get(maps, "override-cache-ttl", &obj);
+ INSIST(result == ISC_R_SUCCESS);
-+ view->overridecachettl = cfg_obj_asuint32(obj);
++ view->overridecachettl = cfg_obj_asduration(obj);
+
+ obj = NULL;
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-05-10 23:44:14 UTC
+--- lib/dns/include/dns/view.h.orig 2020-05-25 12:38:28 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-05-10 23:44:14 UTC
+--- lib/dns/resolver.c.orig 2020-05-25 12:38:28 UTC
+++ lib/dns/resolver.c
-@@ -6233,6 +6233,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6236,6 +6236,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-05-10 23:44:14 UTC
+--- lib/isccfg/namedconf.c.orig 2020-05-25 12:38:28 UTC
+++ lib/isccfg/namedconf.c
@@ -1992,6 +1992,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 80dc6c375582..de3f7f5436e4 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -212,6 +212,7 @@ include/isc/time.h
include/isc/timer.h
include/isc/tm.h
include/isc/types.h
+include/isc/utf8.h
include/isc/util.h
include/isccc/alist.h
include/isccc/base64.h