aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-02-06 02:06:28 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-02-06 02:06:28 +0000
commitf902de4b9486f20c1979e70af0b013416832f4f9 (patch)
tree74b651de598798d263a570df917ef341a143856b /dns
parent39558e45538a0869dbd7e8557abd22b0728f1048 (diff)
downloadports-f902de4b9486f20c1979e70af0b013416832f4f9.tar.gz
ports-f902de4b9486f20c1979e70af0b013416832f4f9.zip
dns/powerdns: unbreak build with lua54
Switch to autoreconf to avoid heavy multiline patching of configure script PR: 253077 Submitted by: fluffy Approved by: maintainer MFH: 2021Q1
Notes
Notes: svn path=/head/; revision=564175
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns/Makefile4
-rw-r--r--dns/powerdns/files/patch-m4_pdns__check__libcrypto.m4 (renamed from dns/powerdns/files/patch-configure)12
-rw-r--r--dns/powerdns/files/patch-m4_pdns__with__lua.m411
3 files changed, 19 insertions, 8 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 1ca2d45d97bd..ecb24aef2085 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libcurl.so:ftp/curl \
libprotobuf.so:devel/protobuf
-USES= compiler:c++11-lib cpe gmake libtool localbase:ldflags pathfix \
- pkgconfig ssl tar:bzip2
+USES= autoreconf compiler:c++11-lib cpe gmake libtool localbase:ldflags \
+ pathfix pkgconfig ssl tar:bzip2
USE_LDCONFIG= YES
USE_RC_SUBR= pdns
diff --git a/dns/powerdns/files/patch-configure b/dns/powerdns/files/patch-m4_pdns__check__libcrypto.m4
index efd0f66abb0f..7d4a832a79e6 100644
--- a/dns/powerdns/files/patch-configure
+++ b/dns/powerdns/files/patch-m4_pdns__check__libcrypto.m4
@@ -1,8 +1,8 @@
---- configure.orig 2020-04-06 12:51:03 UTC
-+++ configure
-@@ -19774,8 +19774,10 @@ fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for openssl/crypto.h in $ssldir" >&5
- $as_echo_n "checking for openssl/crypto.h in $ssldir... " >&6; }
+--- m4/pdns_check_libcrypto.m4.orig 2020-11-16 16:30:04 UTC
++++ m4/pdns_check_libcrypto.m4
+@@ -75,8 +75,10 @@ AC_DEFUN([PDNS_CHECK_LIBCRYPTO], [
+ for ssldir in $ssldirs; do
+ AC_MSG_CHECKING([for openssl/crypto.h in $ssldir])
if test -f "$ssldir/include/openssl/crypto.h"; then
- LIBCRYPTO_INCLUDES="-I$ssldir/include"
- LIBCRYPTO_LDFLAGS="-L$ssldir/lib"
@@ -12,4 +12,4 @@
+ fi
LIBCRYPTO_LIBS="-lcrypto"
found=true
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ AC_MSG_RESULT([yes])
diff --git a/dns/powerdns/files/patch-m4_pdns__with__lua.m4 b/dns/powerdns/files/patch-m4_pdns__with__lua.m4
new file mode 100644
index 000000000000..ca71a8619a53
--- /dev/null
+++ b/dns/powerdns/files/patch-m4_pdns__with__lua.m4
@@ -0,0 +1,11 @@
+--- m4/pdns_with_lua.m4.orig 2020-09-30 10:42:53 UTC
++++ m4/pdns_with_lua.m4
+@@ -41,7 +41,7 @@ AC_DEFUN([PDNS_WITH_LUA],[
+ ], [ : ])
+ AS_IF([test -z "$LUAPC"], [
+ found_lua=n
+- m4_foreach_w([luapc], [lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua], [
++ m4_foreach_w([luapc], [lua5.4 lua-5.4 lua54 lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua], [
+ AS_IF([test "$found_lua" != "y"], [
+ PKG_CHECK_MODULES([LUA], [luapc >= ${lua_min_version}], [
+ AC_DEFINE([HAVE_LUA], [1], [Define to 1 if you have lua])