aboutsummaryrefslogtreecommitdiff
path: root/editors/2bsd-vi
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2010-11-17 22:45:46 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2010-11-17 22:45:46 +0000
commite5250a92c50b78d0d53e9d22767e327259f99dff (patch)
treee98b123d9afa420fc446238ec1c60c050e541479 /editors/2bsd-vi
parente3add50be181c2317bc1fe512aacef1c95a6b416 (diff)
downloadports-e5250a92c50b78d0d53e9d22767e327259f99dff.tar.gz
ports-e5250a92c50b78d0d53e9d22767e327259f99dff.zip
- remove heirloom sources: libuxre[*] (LGPLv2+) and regexp.h (BSD)
- switch to using regex from libc - mark as having BSD-style license (4 clauses) - remove unused patch for 4.x - don't compile termlib [*] also makes binary 30Kb less in size PR: 151994 Submitted by: Anonymous <swell.k _at_ gmail.com> Approved by: David E. Thiel <lx _at_ redundancy.redundancy.org> (maintainer)
Notes
Notes: svn path=/head/; revision=264721
Diffstat (limited to 'editors/2bsd-vi')
-rw-r--r--editors/2bsd-vi/Makefile7
-rw-r--r--editors/2bsd-vi/distinfo1
-rw-r--r--editors/2bsd-vi/files/patch-Makefile19
-rw-r--r--editors/2bsd-vi/files/stable-Makefile.patch15
4 files changed, 26 insertions, 16 deletions
diff --git a/editors/2bsd-vi/Makefile b/editors/2bsd-vi/Makefile
index 9a972337ca12..866ff7d6e8d4 100644
--- a/editors/2bsd-vi/Makefile
+++ b/editors/2bsd-vi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vi
PORTVERSION= 050325
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= SF/ex-${PORTNAME}/ex-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= 2bsd-
@@ -15,6 +16,9 @@ DISTNAME= ex-${PORTVERSION}
MAINTAINER= lx@redundancy.redundancy.org
COMMENT= The original vi editor, updated to run on modern OSes
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USE_BZIP2= yes
PRESERVEDIR= /var/preserve/${UNIQUENAME}
@@ -23,6 +27,9 @@ PLIST_SUB= PRESERVEDIR="${PRESERVEDIR}"
MAN1= ex.1 vi.1
MLINKS= ex.1 edit.1 vi.1 vedit.1 vi.1 view.1
+post-extract: .SILENT
+ ${RM} -fr ${WRKSRC}/libuxre ${WRKSRC}/regexp.h
+
post-patch:
.for f in Makefile ex.1 expreserve.c exrecover.c vi.1
@${REINPLACE_CMD} -e 's|/var/preserve|${PRESERVEDIR}|' ${WRKSRC}/${f}
diff --git a/editors/2bsd-vi/distinfo b/editors/2bsd-vi/distinfo
index cfd9b9e69dc7..cfe8b82c6895 100644
--- a/editors/2bsd-vi/distinfo
+++ b/editors/2bsd-vi/distinfo
@@ -1,3 +1,2 @@
-MD5 (ex-050325.tar.bz2) = e668595254233e4d96811083a3e4e2f3
SHA256 (ex-050325.tar.bz2) = da4be7cf67e94572463b19e56850aa36dc4e39eb0d933d3688fe8574bb632409
SIZE (ex-050325.tar.bz2) = 215411
diff --git a/editors/2bsd-vi/files/patch-Makefile b/editors/2bsd-vi/files/patch-Makefile
index 9fe5ef2fbc92..8561e7d00db9 100644
--- a/editors/2bsd-vi/files/patch-Makefile
+++ b/editors/2bsd-vi/files/patch-Makefile
@@ -21,6 +21,17 @@
#
# Compiler and linker flags.
+@@ -161,9 +161,7 @@ FEATURES = -DLISPCODE -DCHDIR -DFASTTAG
+ # (wchar.h, wctype.h, btowc() etc.) which is not provided by older
+ # compilation environments.
+ #
+-REINC = -I./libuxre -DUXRE
+-RELIB = -L./libuxre -luxre
+-RETGT = uxre
++REINC = -DUXRE -DREG_ANGLES=0 -DNO_BE_BACKSLASH
+
+ #
+ # VMUNIX should be correct for any modern Unix.
@@ -205,13 +204,13 @@ OSTYPE = -DVMUNIX
#
# You may also get terminfo access by using the ncurses library.
@@ -37,6 +48,14 @@
#
# Since ex uses sbrk() internally, a conflict with the libc's version of
+@@ -240,7 +237,6 @@ RECOVER = -DEXRECOVER=\"$(LIBEXECDIR)/ex
+ -DEXPRESERVE=\"$(LIBEXECDIR)/expreserve\"
+ CCFLAGS = $(CFLAGS) $(WARN) $(CPPFLAGS) $(FEATURES) $(CHARSET) $(OSTYPE) \
+ $(LARGEF) $(RECOVER) $(LANGMSG) $(REINC) $(RPMCFLAGS)
+-TLIB = libterm/libtermlib.a
+ INCLUDE = /usr/include
+ OBJS = ex.o ex_addr.o ex_cmds.o ex_cmds2.o ex_cmdsub.o \
+ ex_data.o ex_extern.o ex_get.o ex_io.o ex_put.o ex_re.o \
@@ -292,13 +291,6 @@
# install in standard place
diff --git a/editors/2bsd-vi/files/stable-Makefile.patch b/editors/2bsd-vi/files/stable-Makefile.patch
deleted file mode 100644
index f333e21c5829..000000000000
--- a/editors/2bsd-vi/files/stable-Makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- /tmp/Makefile Mon Jul 12 16:26:36 2004
-+++ Makefile Mon Jul 12 16:26:48 2004
-@@ -144,9 +144,9 @@
- # advanced multibyte character support etc. which might not be present
- # on your system.
- #
--REINC = -I./libuxre -DUXRE
--RELIB = -L./libuxre -luxre
--RETGT = uxre
-+#REINC = -I./libuxre -DUXRE
-+#RELIB = -L./libuxre -luxre
-+#RETGT = uxre
-
- #
- # These settings should be correct for any modern Unix.