aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-12-10 17:38:22 +0000
committerCy Schubert <cy@FreeBSD.org>2020-12-10 17:38:22 +0000
commitf7a590981cf04c3320080040300293d037cb961c (patch)
treea6330630468a2896ce840796012daf323caa6c83 /editors/abiword
parent31fcd17206c4d3c2914402dedf873bc41c60b9bb (diff)
downloadports-f7a590981cf04c3320080040300293d037cb961c.tar.gz
ports-f7a590981cf04c3320080040300293d037cb961c.zip
Update abiword 3.0.1 --> 3.0.4. This resolves 13-CURRENT build
failures.
Notes
Notes: svn path=/head/; revision=557447
Diffstat (limited to 'editors/abiword')
-rw-r--r--editors/abiword/Makefile3
-rw-r--r--editors/abiword/distinfo5
-rw-r--r--editors/abiword/files/patch-c++1168
-rw-r--r--editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp24
-rw-r--r--editors/abiword/files/patch-plugins_collab_backends_sipsimple_xp_SIPSimpleBuddy.h15
-rw-r--r--editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.cpp26
-rw-r--r--editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.h10
-rw-r--r--editors/abiword/pkg-plist1
8 files changed, 5 insertions, 147 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index a9b11a67cdfc..8aa8dfd0f91e 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= abiword
-PORTVERSION= 3.0.1
-PORTREVISION= 17
+PORTVERSION= 3.0.4
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/abiword/${PORTVERSION}/source/
DIST_SUBDIR= AbiWord
diff --git a/editors/abiword/distinfo b/editors/abiword/distinfo
index 7c88f77c3c3f..65da0807ad60 100644
--- a/editors/abiword/distinfo
+++ b/editors/abiword/distinfo
@@ -1,2 +1,3 @@
-SHA256 (AbiWord/abiword-3.0.1.tar.gz) = e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6
-SIZE (AbiWord/abiword-3.0.1.tar.gz) = 11144990
+TIMESTAMP = 1607614164
+SHA256 (AbiWord/abiword-3.0.4.tar.gz) = e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7
+SIZE (AbiWord/abiword-3.0.4.tar.gz) = 11064305
diff --git a/editors/abiword/files/patch-c++11 b/editors/abiword/files/patch-c++11
index ab4d7108ad96..316ba9a4b97e 100644
--- a/editors/abiword/files/patch-c++11
+++ b/editors/abiword/files/patch-c++11
@@ -4,78 +4,10 @@ xap_Dialog.cpp:270:17: error: cast from pointer to smaller type 'char' loses inf
ap_UnixApp.cpp:866:29: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
if(0 == strcmp (suffix, "."G_MODULE_SUFFIX))
^
-ie_exp_XSL-FO.cpp:1454:13: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
- buf += " "x"=\""; \
- ^
-ie_exp_LaTeX.cpp:1332:43: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
-#define SUB(a,who) case a: subst = "\\(\\"who"\\)"; return true;
- ^
-RealmProtocol.cpp:16:2: error: constant expression evaluates to -1 which cannot be narrowed to type 'uint32_t' (aka 'unsigned int') [-Wc++11-narrowing]
- RPV1_PACKET_VARIABLE, /* user joined */
- ^~~~~~~~~~~~~~~~~~~~
-RealmProtocol.cpp:10:30: note: expanded from macro 'RPV1_PACKET_VARIABLE'
-#define RPV1_PACKET_VARIABLE -1
- ^~
-RealmProtocol.cpp:16:2: note: insert an explicit cast to silence this issue
- RPV1_PACKET_VARIABLE, /* user joined */
- ^~~~~~~~~~~~~~~~~~~~
- static_cast<uint32_t>( )
-RealmProtocol.cpp:10:30: note: expanded from macro 'RPV1_PACKET_VARIABLE'
-#define RPV1_PACKET_VARIABLE -1
- ^~
-soa_soup.cpp:166:11: error: no viable conversion from returned value of type 'soa::GenericPtr' (aka 'shared_ptr<soa::Generic>') to function return type 'bool'
- return soa::GenericPtr();
- ^~~~~~~~~~~~~~~~~
https://github.com/AbiWord/abiword/commit/a83e6f50dbd5
https://github.com/AbiWord/abiword/commit/5623a94c756c
---- plugins/collab/backends/service/xp/RealmProtocol.cpp.orig 2009-05-27 05:41:59 UTC
-+++ plugins/collab/backends/service/xp/RealmProtocol.cpp
-@@ -6,8 +6,8 @@ namespace protocolv1 {
-
- #define MAX_PACKET_DATA_SIZE 64*1024*1024
-
--#define RPV1_PACKET_NONEXISTENT -2
--#define RPV1_PACKET_VARIABLE -1
-+#define RPV1_PACKET_NONEXISTENT uint32_t(-2)
-+#define RPV1_PACKET_VARIABLE uint32_t(-1)
-
- static uint32_t body_size[6] = {
- RPV1_PACKET_NONEXISTENT, /* 0: reserved */
---- plugins/collab/backends/service/xp/soa_soup.cpp.orig 2009-09-29 13:58:11 UTC
-+++ plugins/collab/backends/service/xp/soa_soup.cpp
-@@ -163,7 +163,7 @@ namespace soup_soa {
-
- static bool _invoke(const std::string& /*url*/, const soa::method_invocation& /*mi*/, SoaSoupSession& sess, std::string& result) {
- if (!sess.m_session || !sess.m_msg )
-- return soa::GenericPtr();
-+ return false;
-
- guint status = soup_session_send_message (sess.m_session, sess.m_msg);
- if (!(SOUP_STATUS_IS_SUCCESSFUL (status) ||
---- plugins/latex/xp/ie_exp_LaTeX.cpp.orig 2013-04-07 13:53:03 UTC
-+++ plugins/latex/xp/ie_exp_LaTeX.cpp
-@@ -1329,7 +1329,7 @@ void s_LaTeX_Listener::_outputData(const UT_UCSChar *
- m_pie->write(sBuf.c_str(),sBuf.size());
- }
-
--#define SUB(a,who) case a: subst = "\\(\\"who"\\)"; return true;
-+#define SUB(a,who) case a: subst = "\\(\\" who"\\)"; return true;
- #define SUBd(a,who) case a: subst = who; return true;
- static bool _convertLettersToSymbols(char c, const char *& subst)
- {
---- plugins/xslfo/xp/ie_exp_XSL-FO.cpp.orig 2013-04-07 13:53:03 UTC
-+++ plugins/xslfo/xp/ie_exp_XSL-FO.cpp
-@@ -1451,7 +1451,7 @@ void s_XSL_FO_Listener::_openSection(PT_AttrPropIndex
- { \
- UT_UTF8String esc = szValue; \
- esc.escapeXML(); \
-- buf += " "x"=\""; \
-+ buf += " " x"=\""; \
- buf += esc.utf8_str(); \
- buf += "\""; \
- }
--- src/af/xap/xp/xap_Dialog.cpp.orig 2013-04-07 13:53:03 UTC
+++ src/af/xap/xp/xap_Dialog.cpp
@@ -267,7 +267,7 @@ XAP_Dialog_Modeless::BuildWindowName(char * pWindowNam
diff --git a/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp b/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp
deleted file mode 100644
index 4854e1dfd745..000000000000
--- a/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- plugins/collab/backends/service/xp/tls_tunnel.cpp.orig 2014-11-04 01:12:14 UTC
-+++ plugins/collab/backends/service/xp/tls_tunnel.cpp
-@@ -306,8 +306,6 @@ void Proxy::tunnel_(transport_ptr_t tran
- disconnect_(transport_ptr, session_ptr, local_socket_ptr, remote_socket_ptr);
- }
-
--static const int PRIORITIES[] = { GNUTLS_KX_ANON_DH, GNUTLS_KX_RSA, GNUTLS_KX_DHE_DSS, GNUTLS_KX_DHE_RSA, 0 };
--static const int CIPHERS[] = { GNUTLS_CIPHER_AES_256_CBC, GNUTLS_CIPHER_AES_128_CBC, GNUTLS_CIPHER_3DES_CBC, GNUTLS_CIPHER_ARCFOUR_128, 0 };
-
- // FIXME: this clientproxy can only handle 1 SSL connection at the same time
- ClientProxy::ClientProxy(const std::string& connect_address, unsigned short connect_port,
-@@ -399,9 +397,9 @@ session_ptr_t ClientProxy::setup_tls_ses
-
- // setup session
- return_val_if_neg(gnutls_init(session_ptr.get(), GNUTLS_CLIENT), session_ptr_t());
-- return_val_if_neg(gnutls_set_default_priority(*session_ptr), session_ptr_t());
-- return_val_if_neg(gnutls_kx_set_priority(*session_ptr,PRIORITIES), session_ptr_t());
-- return_val_if_neg(gnutls_cipher_set_priority(*session_ptr,CIPHERS), session_ptr_t());
-+ return_val_if_neg(gnutls_priority_set_direct(*session_ptr,"NORMAL"
-+ ":-CIPHER-ALL:+AES-256-CBC:+AES-128-CBC:+3DES-CBC:+ARCFOUR-128"
-+ ":-KX-ALL:+ANON-DH:+RSA:+DHE-DSS:+DHE-RSA",NULL), session_ptr_t());
- return_val_if_neg(gnutls_credentials_set(*session_ptr, GNUTLS_CRD_CERTIFICATE, x509cred), session_ptr_t());
-
- // setup transport
diff --git a/editors/abiword/files/patch-plugins_collab_backends_sipsimple_xp_SIPSimpleBuddy.h b/editors/abiword/files/patch-plugins_collab_backends_sipsimple_xp_SIPSimpleBuddy.h
deleted file mode 100644
index 3ef132d0a6a4..000000000000
--- a/editors/abiword/files/patch-plugins_collab_backends_sipsimple_xp_SIPSimpleBuddy.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- plugins/collab/backends/sipsimple/xp/SIPSimpleBuddy.h.orig 2015-04-04 04:57:15 UTC
-+++ plugins/collab/backends/sipsimple/xp/SIPSimpleBuddy.h
-@@ -52,10 +52,10 @@ public:
-
- virtual const DocTreeItem* getDocTreeItems() const
- {
-- const vector<DocHandle*>& docHandles = getDocHandles();
-+ const std::vector<DocHandle*>& docHandles = getDocHandles();
- DocTreeItem* first = 0;
- DocTreeItem* prev = 0;
-- for (vector<DocHandle*>::const_iterator pos = docHandles.begin(); pos != docHandles.end(); pos++)
-+ for (std::vector<DocHandle*>::const_iterator pos = docHandles.begin(); pos != docHandles.end(); pos++)
- {
- DocTreeItem* item = new DocTreeItem();
- item->m_type = DOCTREEITEM_TYPE_DOCUMENT;
diff --git a/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.cpp b/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.cpp
deleted file mode 100644
index de17f745645e..000000000000
--- a/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/text/ptbl/xp/pd_DocumentRDF.cpp.orig 2015-03-31 15:14:42 UTC
-+++ src/text/ptbl/xp/pd_DocumentRDF.cpp
-@@ -570,6 +570,11 @@ bool PD_URI::operator==(const std::strin
- return m_value == b;
- }
-
-+bool PD_URI::operator<(const PD_URI& b) const
-+{
-+ return m_value < b.m_value;
-+}
-+
- PD_URI
- PD_URI::prefixedToURI( PD_RDFModelHandle model ) const
- {
-@@ -611,11 +616,6 @@ bool PD_URI::write( std::ostream& ss ) c
- return true;
- }
-
--bool operator<( PD_URI a, PD_URI b)
--{
-- return a.toString() < b.toString();
--}
--
- bool operator<( std::pair< PD_URI, PD_URI > a, PD_URI b)
- {
- return a.first.toString() < b.toString();
diff --git a/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.h b/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.h
deleted file mode 100644
index b75b4a8c814d..000000000000
--- a/editors/abiword/files/patch-src_text_ptbl_xp_pd__DocumentRDF.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/text/ptbl/xp/pd_DocumentRDF.h.orig 2015-03-31 15:15:00 UTC
-+++ src/text/ptbl/xp/pd_DocumentRDF.h
-@@ -68,6 +68,7 @@ class ABI_EXPORT PD_URI
- bool isValid() const;
- bool operator==(const PD_URI& b) const;
- bool operator==(const std::string& b) const;
-+ bool operator<(const PD_URI& b) const;
-
- virtual bool read( std::istream& ss );
- virtual bool write( std::ostream& ss ) const;
diff --git a/editors/abiword/pkg-plist b/editors/abiword/pkg-plist
index c2be4a6e0407..6484749b783a 100644
--- a/editors/abiword/pkg-plist
+++ b/editors/abiword/pkg-plist
@@ -382,6 +382,7 @@ man/man1/abiword.1.gz
%%DATADIR%%-%%ABIVERSION%%/xsltml/scripts.xsl
%%DATADIR%%-%%ABIVERSION%%/xsltml/tables.xsl
%%DATADIR%%-%%ABIVERSION%%/xsltml/tokens.xsl
+share/appdata/abiword.appdata.xml
share/applications/abiword.desktop
%%COLTELEPATHY%%share/dbus-1/services/org.freedesktop.Telepathy.Client.AbiCollab.service
share/icons/hicolor/16x16/apps/abiword.png