aboutsummaryrefslogtreecommitdiff
path: root/editors/aee
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-25 04:55:50 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-25 04:55:50 +0000
commitcd83aa4256f5caffb4871e2eaf70f68ac5dd7cd9 (patch)
tree4604361358db54156db78f758938f56c8f54bffd /editors/aee
parenteebcea308e666d7575ab529923577a36397e1d1f (diff)
downloadports-cd83aa4256f5caffb4871e2eaf70f68ac5dd7cd9.tar.gz
ports-cd83aa4256f5caffb4871e2eaf70f68ac5dd7cd9.zip
An easy editor with both curses and X11 interfaces
PR: 13263 Submitted by: Kelly Yancey <kbyanc@posi.net>
Notes
Notes: svn path=/head/; revision=21934
Diffstat (limited to 'editors/aee')
-rw-r--r--editors/aee/Makefile43
-rw-r--r--editors/aee/distinfo1
-rw-r--r--editors/aee/pkg-comment1
-rw-r--r--editors/aee/pkg-descr12
-rw-r--r--editors/aee/pkg-plist4
-rw-r--r--editors/aee/pkg-plist.xae6
6 files changed, 67 insertions, 0 deletions
diff --git a/editors/aee/Makefile b/editors/aee/Makefile
new file mode 100644
index 000000000000..67d2e5b711d5
--- /dev/null
+++ b/editors/aee/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: aee
+# Version required: 2.2.1
+# Date created: 19 Aug 1999
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= aee-2.2.1
+CATEGORIES= editors
+MASTER_SITES= http://www.users.uswest.net/~hmahon/sources/ \
+ http://awwm.linuxberg.com/files/console/network/ \
+ http://powerlinux.linuxberg.com/files/console/network/
+
+MAINTAINER= kbyanc@posi.net
+
+.if !defined(BUILD_XAE)
+ALL_TARGET= main
+pre-fetch:
+ @${ECHO}
+ @${ECHO} "If you would like to also install the X11 version of aee (xae)"
+ @${ECHO} "use 'make install BUILD_XAE=yes'. However, the X11 interface looks"
+ @${ECHO} "almost exactly like the text-based curses version."
+ @${ECHO}
+.else
+USE_XLIB= yes
+ALL_TARGET= both
+PLIST= ${PKGDIR}/PLIST.xae
+.endif
+
+MAN1= aee.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/aee ${PREFIX}/bin
+ ${LN} ${PREFIX}/bin/aee ${PREFIX}/bin/rae
+ ${INSTALL_MAN} ${WRKSRC}/aee.1 ${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/help.ae ${PREFIX}/lib
+.if defined(BUILD_XAE)
+ ${INSTALL_PROGRAM} ${WRKSRC}/xae ${PREFIX}/bin
+ ${LN} ${PREFIX}/bin/xae ${PREFIX}/bin/rxae
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/aee/distinfo b/editors/aee/distinfo
new file mode 100644
index 000000000000..54bba86537c6
--- /dev/null
+++ b/editors/aee/distinfo
@@ -0,0 +1 @@
+MD5 (aee-2.2.1.tar.gz) = 53b68c3c8fb221b223cc58350cde0af9
diff --git a/editors/aee/pkg-comment b/editors/aee/pkg-comment
new file mode 100644
index 000000000000..50128e5e13df
--- /dev/null
+++ b/editors/aee/pkg-comment
@@ -0,0 +1 @@
+An easy editor with both curses and X11 interfaces
diff --git a/editors/aee/pkg-descr b/editors/aee/pkg-descr
new file mode 100644
index 000000000000..d606e14b001f
--- /dev/null
+++ b/editors/aee/pkg-descr
@@ -0,0 +1,12 @@
+"Another Easy Editor"
+An easy to use text editor intended to be usable with little or no
+instruction. Provides a full-screen text interface via curses (aee)
+as well as a graphical user interface under X windows (xae).
+Features include pop-up menus, cut-and-paste, journaling, and
+multiple edit buffers.
+
+aee is a superset of the "Easy Editor" (ee) that is part of the
+FreeBSD base system.
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/editors/aee/pkg-plist b/editors/aee/pkg-plist
new file mode 100644
index 000000000000..f63f888f84f8
--- /dev/null
+++ b/editors/aee/pkg-plist
@@ -0,0 +1,4 @@
+bin/aee
+bin/rae
+lib/help.ae
+
diff --git a/editors/aee/pkg-plist.xae b/editors/aee/pkg-plist.xae
new file mode 100644
index 000000000000..6ffc13df372c
--- /dev/null
+++ b/editors/aee/pkg-plist.xae
@@ -0,0 +1,6 @@
+bin/aee
+bin/rae
+bin/xae
+bin/rxae
+lib/help.ae
+