aboutsummaryrefslogtreecommitdiff
path: root/editors/beav
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-08-10 09:00:03 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-08-10 09:00:03 +0000
commita302a60193e38292f91ad6c7edba4012ffdb65e3 (patch)
tree1f8517749f1ffaa1960f316cb28ecc213a99355d /editors/beav
parentf275d1d987d8847c7bf0560755d9e4e04f4d9a3b (diff)
downloadports-a302a60193e38292f91ad6c7edba4012ffdb65e3.tar.gz
ports-a302a60193e38292f91ad6c7edba4012ffdb65e3.zip
$DISTNAME and the path changed. Minor cleanups while I'm here.
Notes
Notes: svn path=/head/; revision=12417
Diffstat (limited to 'editors/beav')
-rw-r--r--editors/beav/Makefile17
-rw-r--r--editors/beav/distinfo2
-rw-r--r--editors/beav/files/patch-a80
3 files changed, 43 insertions, 56 deletions
diff --git a/editors/beav/Makefile b/editors/beav/Makefile
index 42db7e6e363f..bd8e48190a27 100644
--- a/editors/beav/Makefile
+++ b/editors/beav/Makefile
@@ -1,19 +1,18 @@
# New ports collection makefile for: beav
-# Version required: 1.40-7 (debian)
+# Version required: 1.40-11 (debian)
# Date created: 01 July 1995
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.9 1997/08/11 09:32:30 tg Exp $
+# $Id: Makefile,v 1.10 1997/11/27 00:07:31 jseger Exp $
#
-DISTNAME= beav_140-7
-PKGNAME= beav-1.40.7
+DISTNAME= beav_1.40-11
+PKGNAME= beav-1.40.11
CATEGORIES= editors
-MASTER_SITES= ftp://ftp.debian.org/debian/bo/source/editors/
+MASTER_SITES= ftp://ftp.debian.org/debian/hamm/hamm/source/editors/
-MAINTAINER= tg@FreeBSD.org
+MAINTAINER= ports@FreeBSD.ORG
-WRKSRC= ${WRKDIR}/beav-140
-PATCH_STRIP= -p1
+WRKSRC= ${WRKDIR}/beav-1.40
.include <bsd.port.mk>
diff --git a/editors/beav/distinfo b/editors/beav/distinfo
index 8f8cf49f716e..56f6d2f3e283 100644
--- a/editors/beav/distinfo
+++ b/editors/beav/distinfo
@@ -1 +1 @@
-MD5 (beav_140-7.tar.gz) = 374a7dd0efea5dc0b4e3d9586427bcdb
+MD5 (beav_1.40-11.tar.gz) = 841a1d66124abd6d6357774b3bfb01fd
diff --git a/editors/beav/files/patch-a b/editors/beav/files/patch-a
index 7d822a83ac8c..0e5e5ab49f5f 100644
--- a/editors/beav/files/patch-a
+++ b/editors/beav/files/patch-a
@@ -1,46 +1,36 @@
-diff -c beav-140.orig/Makefile beav-140/Makefile
-*** beav-140.orig/Makefile Wed Nov 30 19:19:47 1994
---- beav-140/Makefile Sat Jul 1 18:07:14 1995
-***************
-*** 1,5 ****
- # This is the makefile for BSD UNIX
-! CFLAGS= -O2 -DUNIX -DNOPROTO
-
- OFILES= basic.o ebcdic.o fileio.o region.o text.o wangpc.o \
- buffer.o echo.o language.o main.o search.o tty.o window.o \
---- 1,5 ----
- # This is the makefile for BSD UNIX
-! CFLAGS+= -DUNIX -DNOPROTO -DBSD
-
- OFILES= basic.o ebcdic.o fileio.o region.o text.o wangpc.o \
- buffer.o echo.o language.o main.o search.o tty.o window.o \
-***************
-*** 14,20 ****
-
- HFILES= def.h
-
-! beav: $(OFILES)
- $(CC) $(CFLAGS) $(OFILES) -s -ltermcap -lc -o beav
-
-! (OFILES): $(HFILES)
---- 14,27 ----
-
- HFILES= def.h
-
-! all beav: $(OFILES)
- $(CC) $(CFLAGS) $(OFILES) -s -ltermcap -lc -o beav
-
-! install: beav
-! install -c -s -m 755 -g bin -o bin beav $(PREFIX)/bin
-! mkdir -p $(PREFIX)/share/doc/beav
-! install -c -m 644 -g bin -o bin beav140.txt $(PREFIX)/share/doc/beav/beav.txt
-! install -c -m 644 -g bin -o bin beav.1 $(PREFIX)/man/man1
-! gzip -9nf $(PREFIX)/man/man1/beav.1
-!
-! $(OFILES): $(HFILES)
-diff -c beav-140.orig/termio.c beav-140/termio.c
+--- Makefile.orig Sat Dec 13 09:34:59 1997
++++ Makefile Mon Aug 10 10:45:21 1998
+@@ -1,6 +1,6 @@
+ # This is the makefile for BSD UNIX
+ #CFLAGS= -g -DUNIX
+-CFLAGS= -O2 -DUNIX
++CFLAGS+= -DUNIX -DBSD
+ CC=gcc
+
+ OFILES= basic.o ebcdic.o fileio.o region.o text.o wangpc.o \
+@@ -16,10 +16,17 @@
+
+ HFILES= def.h prototyp.h
+
+-beav: $(OFILES)
+- $(CC) $(CFLAGS) $(OFILES) -lncurses -o beav
++all beav: $(OFILES)
++ $(CC) $(CFLAGS) $(OFILES) -ltermcap -o beav
++
++install: beav
++ install -c -s -m 755 -g bin -o bin beav $(PREFIX)/bin
++ mkdir -p $(PREFIX)/share/doc/beav
++ install -c -m 644 -g bin -o bin beav140.txt $(PREFIX)/share/doc/beav/beav.txt
++ install -c -m 644 -g bin -o bin beav.1 $(PREFIX)/man/man1
++ gzip -9nf $(PREFIX)/man/man1/beav.1
+
+ clean:
+ rm -f *.o beav
+
+-(OFILES): $(HFILES)
++$(OFILES): $(HFILES)
*** beav-140.orig/termio.c Wed Nov 30 18:43:35 1994
---- beav-140/termio.c Sat Jul 1 17:56:09 1995
+--- termio.c Sat Jul 1 17:56:09 1995
***************
*** 12,17 ****
--- 12,20 ----
@@ -53,9 +43,8 @@ diff -c beav-140.orig/termio.c beav-140/termio.c
#else
#ifdef OS2
#ifndef __EMX__
-diff -c beav-140.orig/tcap.c beav-140/tcap.c
*** beav-140.orig/tcap.c Sat Jul 1 18:32:02 1995
---- beav-140/tcap.c Sat Jul 1 18:24:29 1995
+--- tcap.c Sat Jul 1 18:24:29 1995
***************
*** 38,44 ****
@@ -73,9 +62,8 @@ diff -c beav-140.orig/tcap.c beav-140/tcap.c
#endif /* BSD */
#ifdef ULTRIX
struct winsize ttysize;
-diff -c beav-140.orig/beav.1 beav-140/beav.1
*** beav-140.orig/beav.1 Sun Mar 3 03:13:16 1996
---- beav-140/beav.1 Sun Mar 3 03:14:31 1996
+--- beav.1 Sun Mar 3 03:14:31 1996
***************
*** 59,63 ****
If there is any data that has not been saved you will be warned.