aboutsummaryrefslogtreecommitdiff
path: root/editors/biew/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-08 22:40:29 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-08 22:40:29 +0000
commit172b3771bd963ff8ddf0d24f11a9d20d7045db47 (patch)
tree106491e6a6c239e78337b7ce6a5bc53d698e009b /editors/biew/Makefile
parenta41dba26a21b089cf25fedf9eb974d27250e83c5 (diff)
downloadports-172b3771bd963ff8ddf0d24f11a9d20d7045db47.tar.gz
ports-172b3771bd963ff8ddf0d24f11a9d20d7045db47.zip
Notes
Diffstat (limited to 'editors/biew/Makefile')
-rw-r--r--editors/biew/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 9fb80c109687..8a31b48be1b9 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -6,26 +6,33 @@
#
PORTNAME= biew
-PORTVERSION= 5.6.0
+PORTVERSION= 5.6.2
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= ryan@sasknow.com
-
COMMENT= Binary vIEWer + editor for binary, hexadecimal and dis-asm modes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
+
USE_BZIP2= yes
USE_GMAKE= yes
PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
file_ini.ru licence.en licence.ru release.txt unix.txt
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/biew \
+ share/biew/assembly.skn \
+ share/biew/biew.hlp \
+ share/biew/golded.skn \
+ share/biew/insight.skn \
+ share/biew/standard.skn \
-HOST_CFLAGS= ${CFLAGS} -DPREFIX="\'\"${PREFIX}\"\'"
-MAKEFILE= makefile
+PLIST_DIRS= share/biew
+
+.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400010
LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -33,11 +40,14 @@ HOST_CFLAGS+= -D__FreeBSD_version=${OSVERSION} -I${LOCALBASE}/include
HOST_LD+= -L${LOCALBASE}/lib
.endif
+OST_CFLAGS= ${CFLAGS} -DPREFIX="\'\"${PREFIX}\"\'"
+MAKEFILE= makefile
+
MAKE_ARGS+= HOST_CFLAGS="${HOST_CFLAGS}" CC="${CC}" LD="${CC}" \
TARGET_OS=unix TARGET_SCREEN_LIB=curses \
USE_MOUSE=y
-.if ${MACHINE_ARCH} != "i386"
+.if ${ARCH} != "i386"
MAKE_ARGS+= TARGET_PLATFORM=generic
.endif