aboutsummaryrefslogtreecommitdiff
path: root/editors/biew
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-06-16 10:42:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-06-16 10:42:44 +0000
commit88bbe0427805cdc81fe175e4659c6f45121d7077 (patch)
tree3333a9f7e724eee7695ae5098850083b53020831 /editors/biew
parent189cabd9e0db9170d15bffe5e6fa154f9fa5acf5 (diff)
downloadports-88bbe0427805cdc81fe175e4659c6f45121d7077.tar.gz
ports-88bbe0427805cdc81fe175e4659c6f45121d7077.zip
- Update to version 5.6.4
- Install manual page - Clean up Makefile a bit more
Notes
Notes: svn path=/head/; revision=214945
Diffstat (limited to 'editors/biew')
-rw-r--r--editors/biew/Makefile50
-rw-r--r--editors/biew/distinfo6
-rw-r--r--editors/biew/files/patch-ac20
-rw-r--r--editors/biew/files/patch-ad14
-rw-r--r--editors/biew/files/patch-ae14
-rw-r--r--editors/biew/files/patch-af14
-rw-r--r--editors/biew/files/patch-biewlib-sysdep-ia16_cmn_ix86.c11
-rw-r--r--editors/biew/files/patch-biewlib-sysdep-ia32_aclib_template.c33
-rw-r--r--editors/biew/files/patch-biewlib_file_ini.c48
-rw-r--r--editors/biew/files/patch-biewlib_tw_clawss.c10
-rw-r--r--editors/biew/files/patch-biewlib_twin.c14
-rw-r--r--editors/biew/files/patch-configure141
-rw-r--r--editors/biew/files/patch-tools_biewhlp_makefile16
-rw-r--r--editors/biew/files/patch-tools_lzss_makefile16
14 files changed, 197 insertions, 210 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 8d6baaee15af..41d5bb42cf7f 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -6,57 +6,49 @@
#
PORTNAME= biew
-PORTVERSION= 5.6.2
+PORTVERSION= 5.6.4
CATEGORIES= editors
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Binary vIEWer + editor for binary, hexadecimal and dis-asm modes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
+COMMENT= Binary file viewer and editor
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --cc="${CC}" --ld="${CC}" --prefix="${PREFIX}"
USE_BZIP2= yes
USE_GMAKE= yes
-
-PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
- file_ini.ru licence.en licence.ru release.txt unix.txt
+MAKEFILE= makefile
PLIST_FILES= bin/biew \
share/biew/assembly.skn \
share/biew/biew.hlp \
share/biew/golded.skn \
share/biew/insight.skn \
- share/biew/standard.skn \
-
+ share/biew/standard.skn
PLIST_DIRS= share/biew
-.include <bsd.port.pre.mk>
-
-OST_CFLAGS= ${CFLAGS} -DPREFIX="\'\"${PREFIX}\"\'"
-MAKEFILE= makefile
-
-MAKE_ARGS+= HOST_CFLAGS="${HOST_CFLAGS}" CC="${CC}" LD="${CC}" \
- TARGET_OS=unix TARGET_SCREEN_LIB=curses \
- USE_MOUSE=y
+MAN1= biew.1
+PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
+ file_ini.ru licence.en licence.ru release.txt unix.txt
-.if ${ARCH} != "i386"
-MAKE_ARGS+= TARGET_PLATFORM=generic
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' ${WRKSRC}/configure
post-build:
- @ ${LN} -sf ../../biewlib ${WRKSRC}/tools/biewhlp/biewlib
- cd ${WRKSRC}/tools/biewhlp; ${GMAKE} ${MAKE_ARGS}
- @ ${LN} -sf ../../biewlib ${WRKSRC}/tools/lzss/biewlib
- cd ${WRKSRC}/tools/lzss; ${GMAKE} ${MAKE_ARGS}
- @ (cd ${WRKSRC}/hlp;${LN} -sf ../tools/biewhlp/biewhlp ./;\
- ${LN} -sf ../tools/lzss/lzss ./;./biewhlp biewhlp.prj)
+ ${LN} -sf ../../biewlib ${WRKSRC}/tools/biewhlp/biewlib
+ cd ${WRKSRC}/tools/biewhlp && ${GMAKE} ${MAKE_ARGS}
+ ${LN} -sf ../../biewlib ${WRKSRC}/tools/lzss/biewlib
+ cd ${WRKSRC}/tools/lzss && ${GMAKE} ${MAKE_ARGS}
+ (cd ${WRKSRC}/hlp; ${LN} -sf ../tools/biewhlp/biewhlp; \
+ ${LN} -sf ../tools/lzss/lzss; ./biewhlp biewhlp.prj)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/biew ${PREFIX}/bin
- @ ${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/bin_rc/skn/*.skn ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/hlp/biew.hlp ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/biew.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@@ -64,4 +56,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/biew/distinfo b/editors/biew/distinfo
index 8e3b3470f7e8..3bebe2fa6912 100644
--- a/editors/biew/distinfo
+++ b/editors/biew/distinfo
@@ -1,3 +1,3 @@
-MD5 (biew562.tar.bz2) = 622fb1f02a6d921b273f0a39407f8e7d
-SHA256 (biew562.tar.bz2) = 82263fdd9f9854a9326889b8d4e138c0dba3f08460922d4683f659873313e46a
-SIZE (biew562.tar.bz2) = 594367
+MD5 (biew-564.tar.bz2) = 807c691fa9372ffd1b0840523c27c23a
+SHA256 (biew-564.tar.bz2) = 787c8128de0ba589e6f7ad1547f1c46c86975a41c72bc187918a30f28deaba5e
+SIZE (biew-564.tar.bz2) = 626711
diff --git a/editors/biew/files/patch-ac b/editors/biew/files/patch-ac
deleted file mode 100644
index 2812ff31fcae..000000000000
--- a/editors/biew/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- makefile.inc.orig Thu Jul 6 14:27:58 2000
-+++ makefile.inc Mon Jul 24 23:15:43 2000
-@@ -115,7 +115,7 @@
- ifeq ($(TARGET_PLATFORM),i386)
- MACHINE=ia32
- CDEFSYS=-D__MACHINE__=ia32 -D__CPU_NAME__='"i386"' -D__CPU__=386\
-- -D__DEFAULT_DISASM=0 -fno-builtin -DCAN_COMPILE_X86_GAS=1
-+ -D__DEFAULT_DISASM=0 -DCAN_COMPILE_X86_GAS=1
- endif
- ifeq ($(TARGET_PLATFORM),i486)
- MACHINE=ia32
-@@ -216,7 +216,7 @@
- ifeq ($(compilation),debug)
- CFLAGS += -g3 -p -ax -fcheck-memory-usage -fstack-check
- else
--CFLAGS += -O2 -fomit-frame-pointer -DNDEBUG=1
-+CFLAGS += -fomit-frame-pointer -DNDEBUG=1
- endif
- adv_warn = -W -Winline -Wuninitialized -Wcast-align\
- -Wswitch -Wshadow -Wbad-function-cast -Wmissing-noreturn -Wcast-qual\
diff --git a/editors/biew/files/patch-ad b/editors/biew/files/patch-ad
deleted file mode 100644
index 9826637cff75..000000000000
--- a/editors/biew/files/patch-ad
+++ /dev/null
@@ -1,14 +0,0 @@
---- biewlib/sysdep/generic/unix/vio.c.orig Thu Jul 6 14:31:08 2000
-+++ biewlib/sysdep/generic/unix/vio.c Mon Jul 24 23:04:47 2000
-@@ -84,7 +84,11 @@
- #endif
-
- #ifdef _CURSES_
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 400010
-+#include <ncurses/curses.h>
-+#else
- #include <curses.h>
-+#endif
- #define _bg(x) (((x) >> 4) & 7)
- #define _fg(x) ((x) & 7)
- #define _2cpair(x) (_bg(x) * 010 + _fg(x))
diff --git a/editors/biew/files/patch-ae b/editors/biew/files/patch-ae
deleted file mode 100644
index 14c4df4bc7df..000000000000
--- a/editors/biew/files/patch-ae
+++ /dev/null
@@ -1,14 +0,0 @@
---- biewlib/sysdep/generic/unix/kbd_code.h.orig Thu Jul 6 14:31:08 2000
-+++ biewlib/sysdep/generic/unix/kbd_code.h Mon Jul 24 23:05:25 2000
-@@ -78,7 +78,11 @@
-
-
- #ifdef _CURSES_
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 400010
-+#include <ncurses/curses.h>
-+#else
- #include <curses.h>
-+#endif
- #define _2B(x) (((x) & 0xff) << 8)
- /* #define KE_ENTER _2B(KEY_ENTER) */
- #define KE_BKSPACE _2B(KEY_BACKSPACE)
diff --git a/editors/biew/files/patch-af b/editors/biew/files/patch-af
deleted file mode 100644
index 4025e1976c91..000000000000
--- a/editors/biew/files/patch-af
+++ /dev/null
@@ -1,14 +0,0 @@
---- biewlib/sysdep/generic/unix/keyboard.c.orig Wed Mar 31 16:16:47 2004
-+++ biewlib/sysdep/generic/unix/keyboard.c Wed Mar 31 16:16:58 2004
-@@ -44,7 +44,11 @@
- #endif
-
- #ifdef _CURSES_
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 400010
-+#include <ncurses/curses.h>
-+#else
- #include <curses.h>
-+#endif
- char *rawkb_name="Curses";
- unsigned rawkb_size=sizeof(int); /* size of rawkb_buf elements 1,2 or 4*/
- int rawkb_method=0;
diff --git a/editors/biew/files/patch-biewlib-sysdep-ia16_cmn_ix86.c b/editors/biew/files/patch-biewlib-sysdep-ia16_cmn_ix86.c
deleted file mode 100644
index 0d50e6559a73..000000000000
--- a/editors/biew/files/patch-biewlib-sysdep-ia16_cmn_ix86.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- biewlib/sysdep/ia16/cmn_ix86.c.orig 2003-03-27 07:19:30.000000000 +0100
-+++ biewlib/sysdep/ia16/cmn_ix86.c 2007-10-04 15:24:45.000000000 +0200
-@@ -47,7 +47,7 @@
- ctrl_arr = c_arr;
- /* align pointer on 16-byte boundary */
-
-- if((tUInt32)ctrl_arr & 15) ((tUInt32)ctrl_arr) += 16-((tUInt32)ctrl_arr&15);
-+ if((tUInt32)ctrl_arr & 15) ctrl_arr = ((tUInt32)ctrl_arr) + 16-((tUInt32)ctrl_arr&15);
-
- memset(ctrl_arr,0,sizeof(ctrl_arr));
- if(time_interval)
diff --git a/editors/biew/files/patch-biewlib-sysdep-ia32_aclib_template.c b/editors/biew/files/patch-biewlib-sysdep-ia32_aclib_template.c
deleted file mode 100644
index e58a58796bd7..000000000000
--- a/editors/biew/files/patch-biewlib-sysdep-ia32_aclib_template.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- biewlib/sysdep/ia32/aclib_template.c.orig 2002-12-13 16:31:20.000000000 +0100
-+++ biewlib/sysdep/ia32/aclib_template.c 2007-10-04 15:22:15.000000000 +0200
-@@ -209,8 +209,8 @@
- MOVNTQ" %%mm6, 48(%1)\n"
- MOVNTQ" %%mm7, 56(%1)\n"
- :: "r" (from), "r" (to) : "memory");
-- ((const unsigned char *)from)+=64;
-- ((unsigned char *)to)+=64;
-+ from = ((const unsigned char *)from)+64;
-+ to = ((unsigned char *)to)+64;
- }
-
- // Pure Assembly cuz gcc is a bit unpredictable ;)
-@@ -297,8 +297,8 @@
- MOVNTQ" %%mm6, 48(%1)\n"
- MOVNTQ" %%mm7, 56(%1)\n"
- :: "r" (from), "r" (to) : "memory");
-- ((const unsigned char *)from)+=64;
-- ((unsigned char *)to)+=64;
-+ from = ((const unsigned char *)from)+64;
-+ to = ((unsigned char *)to)+64;
- }
-
- #endif /* Have SSE */
-@@ -393,7 +393,7 @@
- MOVNTQ" %%mm0, 112(%0)\n"
- MOVNTQ" %%mm0, 120(%0)\n"
- :: "r" (to) : "memory");
-- ((unsigned char *)to)+=128;
-+ to = ((unsigned char *)to)+128;
- }
- #endif /* Have SSE */
- #ifdef HAVE_MMX2
diff --git a/editors/biew/files/patch-biewlib_file_ini.c b/editors/biew/files/patch-biewlib_file_ini.c
deleted file mode 100644
index d3b1e7e94620..000000000000
--- a/editors/biew/files/patch-biewlib_file_ini.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- biewlib/file_ini.c.orig 2007-10-04 15:09:06.000000000 +0200
-+++ biewlib/file_ini.c 2007-10-04 15:11:14.000000000 +0200
-@@ -1295,7 +1295,7 @@
- void __HUGE__ *found;
- ini_cache __HUGE__ *it;
- ini_cache ic;
-- (const char *)ic.item = section;
-+ ic.item = section;
- ic.flags = 0;
- if(!(found =la_Find((linearArray *)opening->cache,&ic,__full_compare_cache)))
- {
-@@ -1325,7 +1325,7 @@
- {
- do_subsect:
- it = (ini_cache __HUGE__ *)found;
-- (const char *)ic.item = subsection;
-+ ic.item = subsection;
- if(!(found=la_Find(it->v.leaf,&ic,__full_compare_cache)))
- {
- ic.item = PMalloc(strlen(subsection)+1);
-@@ -1354,7 +1354,7 @@
- {
- do_item:
- it = (ini_cache __HUGE__ *)found;
-- (const char *)ic.item = item;
-+ ic.item = item;
- ic.flags = IC_STRING;
- if(!(found=la_Find(it->v.leaf,&ic,__full_compare_cache)))
- {
-@@ -1589,15 +1589,15 @@
- ini_cache ic;
- void __HUGE__ *found,__HUGE__ *foundi,__HUGE__ *foundv;
- ini_cache __HUGE__ *fi;
-- (const char *)ic.item = section;
-+ ic.item = section;
- ic.flags = 0;
- if((found=la_Find(ini->cache,&ic,__full_compare_cache))!=NULL)
- {
-- (const char *)ic.item=subsection;
-+ ic.item=subsection;
- fi = (ini_cache __HUGE__ *)found;
- if((foundi=la_Find(fi->v.leaf,&ic,__full_compare_cache))!=NULL)
- {
-- (const char *)ic.item = _item;
-+ ic.item = _item;
- ic.flags = IC_STRING;
- fi = (ini_cache __HUGE__ *)foundi;
- if((foundv=la_Find(fi->v.leaf,&ic,__full_compare_cache))!=NULL)
diff --git a/editors/biew/files/patch-biewlib_tw_clawss.c b/editors/biew/files/patch-biewlib_tw_clawss.c
deleted file mode 100644
index e20529af2def..000000000000
--- a/editors/biew/files/patch-biewlib_tw_clawss.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- biewlib/tw_class.c.orig 2007-10-04 15:14:56.000000000 +0200
-+++ biewlib/tw_class.c 2007-10-04 15:15:16.000000000 +0200
-@@ -71,6 +71,6 @@
- TwClass * __FASTCALL__ twcFindClass(const char *name)
- {
- TwClass key;
-- (const char *)(key.name) = name;
-+ key.name = name;
- return (TwClass *)la_Find(class_set,&key, comp_class);
- }
diff --git a/editors/biew/files/patch-biewlib_twin.c b/editors/biew/files/patch-biewlib_twin.c
deleted file mode 100644
index b49c4beb5fd5..000000000000
--- a/editors/biew/files/patch-biewlib_twin.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- biewlib/twin.c.orig 2007-10-04 15:13:06.000000000 +0200
-+++ biewlib/twin.c 2007-10-04 15:13:33.000000000 +0200
-@@ -1891,9 +1891,9 @@
- strcpy(__nls,str);
- __nls_OemToOsdep((unsigned char *)__nls,len);
- }
-- else (const char *)__nls = str;
-+ else __nls = str;
- }
-- else (const char *)__nls = str;
-+ else __nls = str;
- __nls_ptr = __nls;
- __oem_ptr = str;
- vidx = active->cur_x + active->cur_y*active->wwidth;
diff --git a/editors/biew/files/patch-configure b/editors/biew/files/patch-configure
new file mode 100644
index 000000000000..b850fe302eea
--- /dev/null
+++ b/editors/biew/files/patch-configure
@@ -0,0 +1,141 @@
+--- configure.orig 2007-04-11 13:26:12.000000000 +0700
++++ configure 2008-06-14 23:02:43.000000000 +0700
+@@ -199,7 +199,7 @@
+ if test $? -eq 0
+ then
+ _target_system=qnx
+- host_arch=ia32
++ _target_arch=ia32
+ _install=cp
+ else
+ _target_system=qnxnto
+@@ -217,45 +217,16 @@
+ ;;
+ *msdosdjgpp*)
+ _target_system=dos
+- host_arch=ia32
++ _target_arch=ia32
+ _tee=
+ ;;
+ # |FreeBSD|NetBSD|BSD/OS|OpenBSD|SunOS|BeOS)
+-# *)
+-# _target_system=unix
+-# ;;
+- esac
+- else
+- _target_system=auto
+- fi
+-fi
+-
+-if test "$_target_system" = auto ; then
+- if test -z "$system_name" ; then
+- # OS name
+- system_name=`/bin/sh --version 2>&1 | sed -n 's/^.*\([(]\)./\1/p'`
+- case "$system_name" in
+- *linux*)
+- _target_system=linux
+- ;;
+- *[cC][yY][gG][wW][iI][nN]*)
+- _target_system=win32
+- ;;
+- *[eE][mM][xX]*)
+- _target_system=os2
+- ;;
+- *msdosdjgpp*)
+- _target_system=dos
+- host_arch=ia32
+- _tee=
+- ;;
+-# |FreeBSD|NetBSD|BSD/OS|OpenBSD|SunOS|BeOS)
+ *)
+ _target_system=unix
+ ;;
+ esac
+ else
+- _target_system=unix
++ _target_system=$system_name
+ fi
+ fi
+ echores "$_target_system"
+@@ -263,33 +234,21 @@
+ echocheck "architecture"
+ if test "$_target_arch" = auto ; then
+ if test -z "$host_arch" ; then
+- host_arch=`( uname -p ) 2>&1`
+- case "$host_arch" in
+- i*86|sparc|ppc|alpha|arm|mips)
+- ;;
+-
+- *) # uname -p on Linux returns 'unknown' for the processor type,
+- # OpenBSD returns 'Intel Pentium/MMX ("Genuine Intel" 586-class)'
+-
+- # Maybe uname -m (machine hardware name) returns something we
+- # recognize.
+-
+- case "`( uname -m ) 2>&1`" in
+- i*86|x86*|amd64*) host_arch=ia32 ;;
+- ppc) host_arch=ppc ;;
+- alpha) host_arch=alpha ;;
+- sparc*) host_arch=sparc ;;
+- arm*) host_arch=arm ;;
+- *) host_arch=generic ;;
++ # Host architecture
++ host_arch=`uname -m`
++ case "$host_arch" in
++ i*86|x86*|amd64*) _target_arch=ia32 ;;
++ ppc) _target_arch=ppc ;;
++ alpha) _target_arch=alpha ;;
++ sparc*) _target_arch=sparc ;;
++ arm*) _target_arch=arm ;;
++ *) _target_arch=generic ;;
+ esac
+- ;;
+- esac
++ else
++ _target_arch=$host_arch
+ fi
+-else
+- host_arch=$_target_arch
+ fi
+-echores "$host_arch"
+-echo "Detected host..."$system_name
++echores "$_target_arch"
+
+ if test -z "$_x11incdir" ; then
+ echocheck "X11 headers"
+@@ -474,7 +433,7 @@
+
+ # Printout architecture
+ _cdefsys=
+-case "$host_arch" in
++case "$_target_arch" in
+ ia32)
+ # TODO: enable >386 optimizations here
+ _cdefsys="-D__MACHINE__=ia32 -D__CPU_NAME__='\"ia32\"' -D__CPU__=386 -D__DEFAULT_DISASM=0 -DCAN_COMPILE_X86_GAS=1"
+@@ -487,7 +446,7 @@
+
+ *)
+ echo "It seems noone has ported biew to your OS or CPU type yet."
+- echo "using $host_arch architecture"
++ echo "using $_target_arch architecture"
+ ;;
+ esac
+
+@@ -517,7 +476,7 @@
+ DATADIR=$_datadir
+ LIBDIR=$_libdir
+ HOST=$_target_system
+-MACHINE=$host_arch
++MACHINE=$_target_arch
+ CDEFOS=$_cdefos $_extraincdir $_x11incdir
+ OSLDEF=$_osldef
+ OS_LIBS=$_extralibdir $_x11libdir $_oslibs
+@@ -539,7 +498,7 @@
+ Remover: $_rm
+ TARGETS
+ system: $_target_system
+- arch: $host_arch
++ arch: $_target_arch
+
+ EOF
+
diff --git a/editors/biew/files/patch-tools_biewhlp_makefile b/editors/biew/files/patch-tools_biewhlp_makefile
new file mode 100644
index 000000000000..74a6f68e15b5
--- /dev/null
+++ b/editors/biew/files/patch-tools_biewhlp_makefile
@@ -0,0 +1,16 @@
+--- tools/biewhlp/makefile.orig 2002-11-29 23:06:55.000000000 +0600
++++ tools/biewhlp/makefile 2008-06-16 15:34:45.000000000 +0700
+@@ -46,9 +46,12 @@
+ ifeq ($(findstring qnx,$(TARGET_OS)),qnx)
+ include ../../make_qnx.inc
+ else
+-include ../../makefile.inc
++include ../../config.mak
+ endif
+
++CFLAGS = $(CDEFOS) $(CDEFSYS) $(HOST_CFLAGS)
++LDFLAGS = $(OSLDEF) $(HOST_LDFLAGS)
++
+ ###########################################################################
+ # TARGET: put name of executable image here #
+ ###########################################################################
diff --git a/editors/biew/files/patch-tools_lzss_makefile b/editors/biew/files/patch-tools_lzss_makefile
new file mode 100644
index 000000000000..dad903898c4e
--- /dev/null
+++ b/editors/biew/files/patch-tools_lzss_makefile
@@ -0,0 +1,16 @@
+--- tools/lzss/makefile.orig 2002-11-29 23:06:56.000000000 +0600
++++ tools/lzss/makefile 2008-06-16 15:35:53.000000000 +0700
+@@ -45,9 +45,12 @@
+ ifeq ($(findstring qnx,$(TARGET_OS)),qnx)
+ include ../../make_qnx.inc
+ else
+-include ../../makefile.inc
++include ../../config.mak
+ endif
+
++CFLAGS = $(CDEFOS) $(CDEFSYS) $(HOST_CFLAGS)
++LDFLAGS = $(OSLDEF) $(HOST_LDFLAGS)
++
+ ###########################################################################
+ # TARGET: put name of executable image here #
+ ###########################################################################