aboutsummaryrefslogtreecommitdiff
path: root/editors/boiling-egg
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-09 10:30:31 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-09 10:30:31 +0000
commit816fa062f739ec6f406cbcd10ce6faf9b718c877 (patch)
tree8dd71e8066abd17c1cf8c11cd78845d1b9bd5b25 /editors/boiling-egg
parente0481c23f43a3b267a98e5326daf5dc45c25f497 (diff)
downloadports-816fa062f739ec6f406cbcd10ce6faf9b718c877.tar.gz
ports-816fa062f739ec6f406cbcd10ce6faf9b718c877.zip
Add boiling-egg, a front-end of Egg (Tamago) V4.
PR: ports/26400 Submitted by: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
Notes
Notes: svn path=/head/; revision=41119
Diffstat (limited to 'editors/boiling-egg')
-rw-r--r--editors/boiling-egg/Makefile29
-rw-r--r--editors/boiling-egg/distinfo1
-rw-r--r--editors/boiling-egg/pkg-comment1
-rw-r--r--editors/boiling-egg/pkg-descr11
-rw-r--r--editors/boiling-egg/pkg-plist1
5 files changed, 43 insertions, 0 deletions
diff --git a/editors/boiling-egg/Makefile b/editors/boiling-egg/Makefile
new file mode 100644
index 000000000000..8a4f7139765c
--- /dev/null
+++ b/editors/boiling-egg/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: boiling-egg
+# Date created: 9 January 2001
+# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boiling-egg
+PORTVERSION= 0.02
+CATEGORIES= editors elisp
+MASTER_SITES= http://www.gcd.org/sengoku/boiling-egg/
+DISTNAME= ${PORTNAME}.el
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= yoichi@eken.phys.nagoya-u.ac.jp
+
+RUN_DEPENDS= tamago:${PORTSDIR}/editors/tamago
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+ELISPDIR= ${PREFIX}/share/emacs/site-lisp
+
+do-install:
+ ${MKDIR} ${ELISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${ELISPDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/boiling-egg/distinfo b/editors/boiling-egg/distinfo
new file mode 100644
index 000000000000..9690ca39e896
--- /dev/null
+++ b/editors/boiling-egg/distinfo
@@ -0,0 +1 @@
+MD5 (boiling-egg.el) = b5e889b18e7acc8bf4c55b864f8a6313
diff --git a/editors/boiling-egg/pkg-comment b/editors/boiling-egg/pkg-comment
new file mode 100644
index 000000000000..b5cd3f43e212
--- /dev/null
+++ b/editors/boiling-egg/pkg-comment
@@ -0,0 +1 @@
+A front-end of Egg V4
diff --git a/editors/boiling-egg/pkg-descr b/editors/boiling-egg/pkg-descr
new file mode 100644
index 000000000000..8607cf09489d
--- /dev/null
+++ b/editors/boiling-egg/pkg-descr
@@ -0,0 +1,11 @@
+Boiling egg is a front-end of Egg (Tamago) V4.
+You can convert roma-ji to kana without toggling input method.
+
+Put the expression below into your ~/.emacs.
+
+(autoload 'boiling-rK-trans "boiling-egg" "romaji-kanji conversion" t)
+(autoload 'boiling-rhkR-trans "boiling-egg" "romaji-kana conversion" t)
+(global-set-key "\C-o" 'boiling-rK-trans)
+(global-set-key "\eo" 'boiling-rhkR-trans)
+
+WWW: http://www.gcd.org/sengoku/boiling-egg/
diff --git a/editors/boiling-egg/pkg-plist b/editors/boiling-egg/pkg-plist
new file mode 100644
index 000000000000..ef4ebce30dad
--- /dev/null
+++ b/editors/boiling-egg/pkg-plist
@@ -0,0 +1 @@
+share/emacs/site-lisp/boiling-egg.el