aboutsummaryrefslogtreecommitdiff
path: root/editors/chexedit
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-17 16:33:32 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-17 16:33:32 +0000
commit28bcf4c281e05ad95c7557633785bf962ef7d15e (patch)
tree465e321a9d09af704afb14082a9082d83f7d025c /editors/chexedit
parent2a80c2c568dc1af42128134f5986e0a59c1567fe (diff)
downloadports-28bcf4c281e05ad95c7557633785bf962ef7d15e.tar.gz
ports-28bcf4c281e05ad95c7557633785bf962ef7d15e.zip
Full screen text mode Hex editor using the [n]curses library
PR: ports/24761 Submitted by: Roman Shterenzon <roman@xpert.com>
Notes
Notes: svn path=/head/; revision=39979
Diffstat (limited to 'editors/chexedit')
-rw-r--r--editors/chexedit/Makefile24
-rw-r--r--editors/chexedit/distinfo1
-rw-r--r--editors/chexedit/files/patch-docs_hexedit.c30
-rw-r--r--editors/chexedit/files/patch-misc.c11
-rw-r--r--editors/chexedit/files/patch-src_file.c21
-rw-r--r--editors/chexedit/files/patch-src_init.c23
-rw-r--r--editors/chexedit/files/patch-src_misc.c11
-rw-r--r--editors/chexedit/pkg-comment1
-rw-r--r--editors/chexedit/pkg-descr19
-rw-r--r--editors/chexedit/pkg-plist1
10 files changed, 142 insertions, 0 deletions
diff --git a/editors/chexedit/Makefile b/editors/chexedit/Makefile
new file mode 100644
index 000000000000..f879db3877b7
--- /dev/null
+++ b/editors/chexedit/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: chexedit
+# Date Created: 8 Jul 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chexedit
+PORTVERSION= 0.9.7
+CATEGORIES= editors
+MASTER_SITES= http://ccwf.cc.utexas.edu/~apoc/programs/c/hexedit/
+DISTNAME= hexedit-0.9.7
+
+MAINTAINER= roman@xpert.com
+
+GNU_CONFIGURE= yes
+
+MAN1= chexedit.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/hexedit ${PREFIX}/bin/chexedit
+ ${INSTALL_MAN} ${WRKSRC}/docs/hexedit.1 ${PREFIX}/man/man1/chexedit.1
+
+.include <bsd.port.mk>
diff --git a/editors/chexedit/distinfo b/editors/chexedit/distinfo
new file mode 100644
index 000000000000..7e179fa192bd
--- /dev/null
+++ b/editors/chexedit/distinfo
@@ -0,0 +1 @@
+MD5 (hexedit-0.9.7.tar.gz) = 2658b81ab1bd0813c0117e9459071c13
diff --git a/editors/chexedit/files/patch-docs_hexedit.c b/editors/chexedit/files/patch-docs_hexedit.c
new file mode 100644
index 000000000000..24cd5a36c68f
--- /dev/null
+++ b/editors/chexedit/files/patch-docs_hexedit.c
@@ -0,0 +1,30 @@
+--- docs/hexedit.1.orig Fri Apr 23 22:16:42 1999
++++ docs/hexedit.1 Wed Jan 31 22:39:36 2001
+@@ -1,14 +1,14 @@
+ .\" Copyright (C) 1998,1999 Adam Rogoyski
+-.TH HEXEDIT 1
++.TH CHEXEDIT 1
+ .SH NAME
+-hexedit \- Full screen curses Hex editor
++chexedit \- Full screen curses Hex editor
+ .SH SYNOPSIS
+ .nr a \n(.j
+ .ad l
+ .nr i \n(.i
+-.in +\w'\fBhexedit 'u
++.in +\w'\fBchexedit 'u
+ .ti \niu
+-.B hexedit
++.B chexedit
+ .de OP
+ .ie \\n(.$-1 .RI "[\ \fB\\$1fP" "\\$2" "\ ]"
+ .el .RB "[\ " "\\$1" "\ ]"
+@@ -18,7 +18,7 @@
+ .br
+ .ad \na
+ .SH DESCRIPTION
+-.I Hexedit
++.I Chexedit
+ is an editor to edit binary (or any) files or disks. The Display consists
+ of the current offset from 0 (the first byte), the next sixteen bytes
+ (aligned by bytes or 32-bit words), and it's ASCII or EBCDIC text
diff --git a/editors/chexedit/files/patch-misc.c b/editors/chexedit/files/patch-misc.c
new file mode 100644
index 000000000000..bfa8c60aa666
--- /dev/null
+++ b/editors/chexedit/files/patch-misc.c
@@ -0,0 +1,11 @@
+--- src/misc.c.orig Wed Jan 31 22:44:38 2001
++++ src/misc.c Wed Jan 31 22:44:56 2001
+@@ -394,7 +394,7 @@
+ " -a, --alltext Print all text characters.\n"
+ " -b, --buffer Buffer the entire file in memory.\n"
+ " Much faster and enables insert/delete.\n"
+-#if defined (__linux__) || defined (__OpenBSD__)
++#if defined (__linux__) || defined (__OpenBSD__) || defined(__FreeBSD__)
+ " -d, --disk Edit a fixed disk, i.e. /dev/hda (Read-only)\n"
+ " -f, --force Force editing of disk.\n"
+ " Needed to write to disks.\n"
diff --git a/editors/chexedit/files/patch-src_file.c b/editors/chexedit/files/patch-src_file.c
new file mode 100644
index 000000000000..8bc63e1589d7
--- /dev/null
+++ b/editors/chexedit/files/patch-src_file.c
@@ -0,0 +1,21 @@
+--- src/file.c.orig Wed Jun 30 05:57:15 1999
++++ src/file.c Sat Mar 17 22:23:57 2001
+@@ -19,6 +19,7 @@
+ #include <dirent.h>
+ #endif
+
++#include <sys/types.h>
+ #include <grp.h>
+ #include <pwd.h>
+
+@@ -618,8 +619,8 @@
+
+ wprintw (Globals.wmain,
+ /* why does it seem like on OpenBSD this is broken? */
+-#if defined(__OpenBSD__) || defined(BROKEN)
+- "%s %-8s %-8s %10ld %1d\b2d-%02d-%02d %02d:%02d ",
++#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(BROKEN)
++ "%s %-8s %-8s %10ld %1d\b%04d-%02d-%02d %02d:%02d ",
+ #else
+ "%s %-8s %-8s %10ld %d-%02d-%02d %02d:%02d ",
+ #endif
diff --git a/editors/chexedit/files/patch-src_init.c b/editors/chexedit/files/patch-src_init.c
new file mode 100644
index 000000000000..9aaaee5c9745
--- /dev/null
+++ b/editors/chexedit/files/patch-src_init.c
@@ -0,0 +1,23 @@
+--- src/init.c.orig Sun Aug 8 09:56:11 1999
++++ src/init.c Sat Mar 17 22:23:57 2001
+@@ -33,6 +33,11 @@
+ #include <sys/disklabel.h>
+ #endif
+
++#if defined(__FreeBSD__)
++#include <fcntl.h>
++#include <sys/disklabel.h>
++#endif
++
+ extern char **environ;
+
+
+@@ -463,7 +468,7 @@
+ filestat.st_size = DEFAULT_BUFFER_SIZE;
+ }
+
+-#elif defined (__OpenBSD__)
++#elif defined (__OpenBSD__) || defined(__FreeBSD__)
+ else if (Globals.fixed_disk)
+ {
+
diff --git a/editors/chexedit/files/patch-src_misc.c b/editors/chexedit/files/patch-src_misc.c
new file mode 100644
index 000000000000..5688159b449c
--- /dev/null
+++ b/editors/chexedit/files/patch-src_misc.c
@@ -0,0 +1,11 @@
+--- src/misc.c.orig Wed Jun 30 06:00:47 1999
++++ src/misc.c Sat Mar 17 22:23:58 2001
+@@ -394,7 +394,7 @@
+ " -a, --alltext Print all text characters.\n"
+ " -b, --buffer Buffer the entire file in memory.\n"
+ " Much faster and enables insert/delete.\n"
+-#if defined (__linux__) || defined (__OpenBSD__)
++#if defined (__linux__) || defined (__OpenBSD__) || defined(__FreeBSD__)
+ " -d, --disk Edit a fixed disk, i.e. /dev/hda (Read-only)\n"
+ " -f, --force Force editing of disk.\n"
+ " Needed to write to disks.\n"
diff --git a/editors/chexedit/pkg-comment b/editors/chexedit/pkg-comment
new file mode 100644
index 000000000000..b17e6e6193f0
--- /dev/null
+++ b/editors/chexedit/pkg-comment
@@ -0,0 +1 @@
+Full screen text mode Hex editor using the [n]curses library
diff --git a/editors/chexedit/pkg-descr b/editors/chexedit/pkg-descr
new file mode 100644
index 000000000000..2993e84f773f
--- /dev/null
+++ b/editors/chexedit/pkg-descr
@@ -0,0 +1,19 @@
+Hexedit is a Curses based Hex editor. Unlike a text editor, which
+is used for editing text documents in the desired language, hexedit
+lets you edit any file as it's byte(1) for byte representation. It can
+even let you view and edit your fixed disks on your Linux system. This
+is not ideal for writing a letter or writing c code, but there are my
+times when this is ideal:
+
+ * Editing binary executables.
+
+ * Editing your fixed disks (i.e. /dev/xyz)
+
+ * Checking the output of a Program's binary data file.
+
+ * Any place you might use od(1) but need more power. Compare more
+ vs less.
+
+WWW: http://ccwf.cc.utexas.edu/~apoc/programs/c/hexedit/
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/editors/chexedit/pkg-plist b/editors/chexedit/pkg-plist
new file mode 100644
index 000000000000..a81cb4ce729e
--- /dev/null
+++ b/editors/chexedit/pkg-plist
@@ -0,0 +1 @@
+bin/chexedit