aboutsummaryrefslogtreecommitdiff
path: root/editors/chexedit
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-22 17:28:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-22 17:28:38 +0000
commitcce604f272e145ca2d0f1feb03913e42cb827ef9 (patch)
tree5dba4826ba7eae02477b81ecd0509d88304a37ac /editors/chexedit
parent966b9efb65481c4f0b6a3233778bb31926ac4e23 (diff)
downloadports-cce604f272e145ca2d0f1feb03913e42cb827ef9.tar.gz
ports-cce604f272e145ca2d0f1feb03913e42cb827ef9.zip
- Fix timestamp display in file view
- Fix colors on some terminals - Add LICENSE PR: 180623 Submitted by: "r4721@tormail.org" <r4721@tormail.org>
Notes
Notes: svn path=/head/; revision=323482
Diffstat (limited to 'editors/chexedit')
-rw-r--r--editors/chexedit/Makefile3
-rw-r--r--editors/chexedit/files/patch-src-file.c11
-rw-r--r--editors/chexedit/files/patch-src-init.c10
3 files changed, 12 insertions, 12 deletions
diff --git a/editors/chexedit/Makefile b/editors/chexedit/Makefile
index a65486b6f69f..03aba1a955fc 100644
--- a/editors/chexedit/Makefile
+++ b/editors/chexedit/Makefile
@@ -12,6 +12,9 @@ DISTNAME= hexedit-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Full screen text mode Hex editor using the [n]curses library
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
PLIST_FILES= bin/chexedit
diff --git a/editors/chexedit/files/patch-src-file.c b/editors/chexedit/files/patch-src-file.c
index 8bc63e1589d7..33ae6f461bef 100644
--- a/editors/chexedit/files/patch-src-file.c
+++ b/editors/chexedit/files/patch-src-file.c
@@ -8,14 +8,3 @@
#include <grp.h>
#include <pwd.h>
-@@ -618,8 +619,8 @@
-
- wprintw (Globals.wmain,
- /* why does it seem like on OpenBSD this is broken? */
--#if defined(__OpenBSD__) || defined(BROKEN)
-- "%s %-8s %-8s %10ld %1d\b2d-%02d-%02d %02d:%02d ",
-+#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(BROKEN)
-+ "%s %-8s %-8s %10ld %1d\b%04d-%02d-%02d %02d:%02d ",
- #else
- "%s %-8s %-8s %10ld %d-%02d-%02d %02d:%02d ",
- #endif
diff --git a/editors/chexedit/files/patch-src-init.c b/editors/chexedit/files/patch-src-init.c
index 9aaaee5c9745..742533888f30 100644
--- a/editors/chexedit/files/patch-src-init.c
+++ b/editors/chexedit/files/patch-src-init.c
@@ -12,7 +12,15 @@
extern char **environ;
-@@ -463,7 +468,7 @@
+@@ -250,6 +255,7 @@
+ if (color_term != -1)
+ {
+ start_color ();
++ use_default_colors();
+ if ((color_term = has_colors ()))
+ {
+ color_term = 1;
+@@ -463,7 +469,7 @@
filestat.st_size = DEFAULT_BUFFER_SIZE;
}