aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2015-08-16 18:25:55 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2015-08-16 18:25:55 +0000
commit76fcda0b5653420ef1cafee817d9c7c776a9eed3 (patch)
tree4ef97b2be7168db063936c4ce6fa9fe36177eae8 /editors/codelite
parent4d74500834d1ec514d7d77d860c9c2c7212ea163 (diff)
downloadports-76fcda0b5653420ef1cafee817d9c7c776a9eed3.tar.gz
ports-76fcda0b5653420ef1cafee817d9c7c776a9eed3.zip
editors/codelite: Fix clang code completion.
Let the port detect clang versions 3.3-3.6. Remove duplicate pkg-plist locales.
Notes
Notes: svn path=/head/; revision=394417
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/files/patch-cmake_Modules_FindLibClang.cmake26
-rw-r--r--editors/codelite/pkg-plist5
2 files changed, 26 insertions, 5 deletions
diff --git a/editors/codelite/files/patch-cmake_Modules_FindLibClang.cmake b/editors/codelite/files/patch-cmake_Modules_FindLibClang.cmake
new file mode 100644
index 000000000000..c5e2333163f2
--- /dev/null
+++ b/editors/codelite/files/patch-cmake_Modules_FindLibClang.cmake
@@ -0,0 +1,26 @@
+--- cmake/Modules/FindLibClang.cmake.orig 2015-08-16 12:16:16.000000000 +0300
++++ cmake/Modules/FindLibClang.cmake 2015-08-16 12:18:08.000000000 +0300
+@@ -12,6 +12,11 @@
+ # For fedora
+ /usr/lib/llvm
+ /usr/lib64/llvm
++ # For FreeBSD
++ /usr/local/llvm36/lib
++ /usr/local/llvm35/lib
++ /usr/local/llvm34/lib
++ /usr/local/llvm33/lib
+ ${CMAKE_INSTALL_LIBDIR})
+
+ find_path(LIBCLANG_INCLUDE_T NAMES clang-c/Index.h
+@@ -28,6 +33,11 @@
+ /usr/local/include
+ # For fedora
+ /usr/include
++ # For FreeBSD
++ /usr/local/llvm36/include
++ /usr/local/llvm35/include
++ /usr/local/llvm34/include
++ /usr/local/llvm33/include
+ )
+
+ if ( LIBCLANG_T STREQUAL "LIBCLANG_T-NOTFOUND" OR LIBCLANG_INCLUDE_T STREQUAL "LIBCLANG_INCLUDE_T-NOTFOUND" )
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index bc011cb99dc3..dc9c4648e8dd 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -1,6 +1,3 @@
-%%CLANG%%bin/codelite-clang
-%%CLANG%%bin/codelite-clang-format
-%%CLANG%%lib/codelite/libclang.so
bin/clg++
bin/clgcc
bin/codelite
@@ -279,5 +276,3 @@ man/man1/codelite_fix_files.1.gz
%%NLS%%share/locale/zh_CN/LC_MESSAGES/codelite.mo
share/applications/codelite.desktop
share/icons/hicolor/32x32/apps/codelite.png
-share/locale/cs/LC_MESSAGES/codelite.mo
-share/locale/zh_CN/LC_MESSAGES/codelite.mo