aboutsummaryrefslogtreecommitdiff
path: root/editors/cooledit/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-06-09 00:05:23 +0000
committerSteve Price <steve@FreeBSD.org>1999-06-09 00:05:23 +0000
commit2954c55b1dfa973284f35fc074e8fdf6507a55d0 (patch)
tree943f70f2cda10b9f6acdec7aad572ef9ed6b2dc2 /editors/cooledit/files
parent11b65813546aca7c5d0d9874cb87cd8beb0f8815 (diff)
Notes
Diffstat (limited to 'editors/cooledit/files')
-rw-r--r--editors/cooledit/files/patch-ac11
-rw-r--r--editors/cooledit/files/patch-ad11
-rw-r--r--editors/cooledit/files/patch-ae11
-rw-r--r--editors/cooledit/files/patch-af11
-rw-r--r--editors/cooledit/files/patch-ag11
-rw-r--r--editors/cooledit/files/patch-ah29
-rw-r--r--editors/cooledit/files/patch-ai11
-rw-r--r--editors/cooledit/files/patch-aj23
-rw-r--r--editors/cooledit/files/patch-ak11
9 files changed, 129 insertions, 0 deletions
diff --git a/editors/cooledit/files/patch-ac b/editors/cooledit/files/patch-ac
new file mode 100644
index 000000000000..bce2dd765710
--- /dev/null
+++ b/editors/cooledit/files/patch-ac
@@ -0,0 +1,11 @@
+--- icon/Makefile.in.orig Sun May 30 07:47:33 1999
++++ icon/Makefile.in Mon Jun 7 14:54:23 1999
+@@ -119,7 +119,7 @@
+ datadir = $(prefix)/@DATADIRNAME@
+ localedir = $(datadir)/locale
+
+-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/coolicon\" @DEFS@
++DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/coolicon\" -DSYSCONFDIR=\"$(sysconfdir)\" -DDATADIR=\"$(datadir)/coolicon\" @DEFS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/files/patch-ad b/editors/cooledit/files/patch-ad
new file mode 100644
index 000000000000..b31264e0e7e4
--- /dev/null
+++ b/editors/cooledit/files/patch-ad
@@ -0,0 +1,11 @@
+--- icon/iconmanager.c.orig Mon Jun 7 14:43:54 1999
++++ icon/iconmanager.c Mon Jun 7 14:44:08 1999
+@@ -443,7 +443,7 @@
+ if (p->x + 20 > WidthOfScreen (DefaultScreenOfDisplay (CDisplay)))
+ p->x = WidthOfScreen (DefaultScreenOfDisplay (CDisplay)) - 20;
+ if (*p->xpm_filename != '/')
+- f = catstrs (LIBDIR, "/", p->xpm_filename, 0);
++ f = catstrs (DATADIR, "/", p->xpm_filename, 0);
+ else
+ f = p->xpm_filename;
+ w = CDrawIcon (catstrs ("_icon", itoa (n), 0), CRoot, p->x, p->y, f, p->title);
diff --git a/editors/cooledit/files/patch-ae b/editors/cooledit/files/patch-ae
new file mode 100644
index 000000000000..0bcbab8d53a9
--- /dev/null
+++ b/editors/cooledit/files/patch-ae
@@ -0,0 +1,11 @@
+--- syntax/Makefile.in.orig Mon Jun 7 15:12:47 1999
++++ syntax/Makefile.in Mon Jun 7 15:15:31 1999
+@@ -99,7 +99,7 @@
+ VERSION = @VERSION@
+ l = @l@
+
+-syntaxdir = $(libdir)/cooledit/syntax
++syntaxdir = $(datadir)/cooledit/syntax
+
+ syntax_DATA = c.syntax changelog.syntax diff.syntax diffc.syntax html.syntax java.syntax latex.syntax lsm.syntax makefile.syntax ml.syntax nroff.syntax pascal.syntax perl.syntax python.syntax sh.syntax smalltalk.syntax texinfo.syntax unknown.syntax swig.syntax
+
diff --git a/editors/cooledit/files/patch-af b/editors/cooledit/files/patch-af
new file mode 100644
index 000000000000..225028776078
--- /dev/null
+++ b/editors/cooledit/files/patch-af
@@ -0,0 +1,11 @@
+--- widget/syntax.c.orig Sun May 30 07:47:04 1999
++++ widget/syntax.c Mon Jun 7 15:55:34 1999
+@@ -728,7 +728,7 @@
+ f = fopen (p, "r");
+ if (f)
+ return f;
+- strcpy (p, LIBDIR "/syntax/");
++ strcpy (p, DATADIR "/cooledit/syntax/");
+ strcat (p, filename);
+ syntax_free (error_file_name);
+ error_file_name = strdup (p);
diff --git a/editors/cooledit/files/patch-ag b/editors/cooledit/files/patch-ag
new file mode 100644
index 000000000000..0c5244b8beb7
--- /dev/null
+++ b/editors/cooledit/files/patch-ag
@@ -0,0 +1,11 @@
+--- widget/Makefile.in.orig Mon Jun 7 15:15:24 1999
++++ widget/Makefile.in Mon Jun 7 15:17:00 1999
+@@ -113,7 +113,7 @@
+
+ libCw_la_LDFLAGS = -version-info 1:0:0
+
+-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" @DEFS@
++DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" -DDATADIR=\"$(datadir)\" @DEFS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/files/patch-ah b/editors/cooledit/files/patch-ah
new file mode 100644
index 000000000000..0cdd748518ab
--- /dev/null
+++ b/editors/cooledit/files/patch-ah
@@ -0,0 +1,29 @@
+--- editor/coolpython.c.orig Mon Jun 7 15:26:22 1999
++++ editor/coolpython.c Mon Jun 7 15:26:58 1999
+@@ -1329,7 +1329,7 @@
+ PyDict_SetItemString (d, "Mod3Mask", PyInt_FromLong ((long) Mod3Mask));
+ PyDict_SetItemString (d, "Mod4Mask", PyInt_FromLong ((long) Mod4Mask));
+ PyDict_SetItemString (d, "Mod5Mask", PyInt_FromLong ((long) Mod5Mask));
+- PyDict_SetItemString (d, "LIBDIR", PyString_FromString (LIBDIR));
++ PyDict_SetItemString (d, "DATADIR", PyString_FromString (DATADIR));
+ }
+
+ void coolpython_run_file (char *filename)
+@@ -1387,7 +1387,7 @@
+ import sys\n\
+ sys.path.append('%s')\n\
+ sys.path.append('%s%s')\n\
+-", LIBDIR, home_dir, EDIT_DIR);
++", DATADIR, home_dir, EDIT_DIR);
+ e = PyRun_String (s, Py_file_input, name_space, name_space);
+ if (!e) {
+ PyErr_Print ();
+@@ -1396,7 +1396,7 @@
+ }
+ Py_DECREF (e);
+ coolpython_constants (name_space);
+- sprintf (s, "%s/%s", LIBDIR, GLOBAL_STARTUP_FILE);
++ sprintf (s, "%s/%s", DATADIR, GLOBAL_STARTUP_FILE);
+ coolpython_run_file (s);
+ sprintf (s, "%s%s/%s", home_dir, EDIT_DIR, GLOBAL_STARTUP_FILE);
+ if ((fd = open (s, O_RDONLY)) >= 0)
diff --git a/editors/cooledit/files/patch-ai b/editors/cooledit/files/patch-ai
new file mode 100644
index 000000000000..db8a14013322
--- /dev/null
+++ b/editors/cooledit/files/patch-ai
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig Mon Jun 7 15:25:44 1999
++++ lib/Makefile.in Mon Jun 7 15:25:54 1999
+@@ -99,7 +99,7 @@
+ VERSION = @VERSION@
+ l = @l@
+
+-pythondir = $(libdir)/cooledit
++pythondir = $(datadir)/cooledit
+
+ python_DATA = global.py
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/editors/cooledit/files/patch-aj b/editors/cooledit/files/patch-aj
new file mode 100644
index 000000000000..3f56b16090c2
--- /dev/null
+++ b/editors/cooledit/files/patch-aj
@@ -0,0 +1,23 @@
+--- pixmap/Makefile.in.orig Mon Jun 7 14:39:02 1999
++++ pixmap/Makefile.in Mon Jun 7 14:40:45 1999
+@@ -99,9 +99,9 @@
+ VERSION = @VERSION@
+ l = @l@
+
+-pixmapdir = $(libdir)/coolicon
++pixmapdir = $(datadir)/coolicon
+
+-pixmap_DATA = browse.xpm cooledit.xpm coolicon.config dynamite.xpm e.data launch.xpm manual.xpm mc.xpm netscape.xpm nscape.xpm phonedown.xpm phoneup.xpm printer.xpm spanner.xpm xterm.xpm xv.xpm cdrom_eject.xpm cdrom_view.xpm modify-xinitrc gmc.xpm lyx.xpm
++pixmap_DATA = browse.xpm cooledit.xpm dynamite.xpm e.data launch.xpm manual.xpm mc.xpm netscape.xpm nscape.xpm phonedown.xpm phoneup.xpm printer.xpm spanner.xpm xterm.xpm xv.xpm cdrom_eject.xpm cdrom_view.xpm gmc.xpm lyx.xpm
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+@@ -227,8 +227,6 @@
+
+
+ install-data-local:
+- chmod 0755 $(libdir)/coolicon/modify-xinitrc
+- $(libdir)/coolicon/modify-xinitrc
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/editors/cooledit/files/patch-ak b/editors/cooledit/files/patch-ak
new file mode 100644
index 000000000000..4e98815650f4
--- /dev/null
+++ b/editors/cooledit/files/patch-ak
@@ -0,0 +1,11 @@
+--- icon/coolicon.c.orig Mon Jun 7 11:23:06 1999
++++ icon/coolicon.c Mon Jun 7 11:24:05 1999
+@@ -49,7 +49,7 @@
+ void free_icon_elements (CPowerIcon * icon);
+ void free_all_lists (void);
+
+-#define SYSTEM_ICONS LIBDIR "/coolicon.config"
++#define SYSTEM_ICONS SYSCONFDIR "/coolicon.config"
+ #define E_DATA LIBDIR "/e.data"
+ #define START_WIDTH size_of_e
+ #define START_HEIGHT size_of_e