aboutsummaryrefslogtreecommitdiff
path: root/editors/cooledit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-15 15:21:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-15 15:21:50 +0000
commit9f6c3c0d1bdd3090a5fe8c31288f34d29c9adcf5 (patch)
treebaa9c51f744e91b62b16d20ec950fb01098aeee4 /editors/cooledit
parent262787fd7748546df90d5aad2da6a84e8acb5ecb (diff)
downloadports-9f6c3c0d1bdd3090a5fe8c31288f34d29c9adcf5.tar.gz
ports-9f6c3c0d1bdd3090a5fe8c31288f34d29c9adcf5.zip
Update to version 3.17.14
PR: ports/75110 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=124121
Diffstat (limited to 'editors/cooledit')
-rw-r--r--editors/cooledit/Makefile22
-rw-r--r--editors/cooledit/distinfo4
-rw-r--r--editors/cooledit/files/patch-widget::widechar.c18
-rw-r--r--editors/cooledit/pkg-plist2
4 files changed, 31 insertions, 15 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index f63a89af406c..a2bf9908790e 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cooledit
-PORTVERSION= 3.17.8
+PORTVERSION= 3.17.14
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/editors/X/cooledit
@@ -22,25 +22,21 @@ USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
- AUTOMAKE="${TRUE}"
INSTALLS_SHLIB= yes
MAN1= cooledit.1 coolman.1 smalledit.1
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_GETTEXT ${PTHREAD_CFLAGS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+CFLAGS+= -DHAVE_MBRTOWC
+.endif
+
.if defined(WITH_NEXT_LOOK)
CONFIGURE_ARGS+= --enable-NeXT-look
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|^PACKAGE_FORCE|#PACKAGE_FORGE|g ; \
- s|USE_INCLUDED_LIBINTL=yes|USE_INCLUDED_LIBINTL=no|g ; \
- s|\\$${top_builddir}/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|#undef HAVE_WCHAR_H||g ; \
- s|#undef HAVE_DCGETTEXT||g' ${WRKSRC}/config.h.in
- @${REINPLACE_CMD} -e 's|m4 intl rxvt|m4 rxvt|g' ${WRKSRC}/Makefile.in
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/cooledit/distinfo b/editors/cooledit/distinfo
index 8e8d213954e1..f467a5c0ba8e 100644
--- a/editors/cooledit/distinfo
+++ b/editors/cooledit/distinfo
@@ -1,2 +1,2 @@
-MD5 (cooledit-3.17.8.tar.gz) = 7b55c892f5b90b9f4eedda6b68f2e15b
-SIZE (cooledit-3.17.8.tar.gz) = 1655037
+MD5 (cooledit-3.17.14.tar.gz) = c5bfa0efbd6160b5ba868b722418cc02
+SIZE (cooledit-3.17.14.tar.gz) = 1671619
diff --git a/editors/cooledit/files/patch-widget::widechar.c b/editors/cooledit/files/patch-widget::widechar.c
new file mode 100644
index 000000000000..c60929714b2c
--- /dev/null
+++ b/editors/cooledit/files/patch-widget::widechar.c
@@ -0,0 +1,18 @@
+--- widget/widechar.c.orig Sat Nov 27 17:46:03 2004
++++ widget/widechar.c Wed Dec 15 01:17:59 2004
+@@ -227,6 +227,7 @@
+ static inline struct mb_rule apply_mb_rules_going_right (WEdit * edit, long byte_index, struct mb_rule mb_rule)
+ {
+ #ifdef HAVE_WCHAR_H
++#ifdef HAVE_MBRTOWC
+ wchar_t wc;
+ unsigned char p[16];
+ int n;
+@@ -252,6 +253,7 @@
+ }
+ mb_rule.end = 0;
+ mb_rule.ch = -1;
++#endif
+ #endif
+ return mb_rule;
+ }
diff --git a/editors/cooledit/pkg-plist b/editors/cooledit/pkg-plist
index 276a3f959c6f..cfc7684fa4a5 100644
--- a/editors/cooledit/pkg-plist
+++ b/editors/cooledit/pkg-plist
@@ -21,6 +21,7 @@ lib/libCw.so.1
%%DATADIR%%/syntax/java.syntax
%%DATADIR%%/syntax/latex.syntax
%%DATADIR%%/syntax/lsm.syntax
+%%DATADIR%%/syntax/lsm4.syntax
%%DATADIR%%/syntax/lua.syntax
%%DATADIR%%/syntax/mail.syntax
%%DATADIR%%/syntax/makefile.syntax
@@ -33,6 +34,7 @@ lib/libCw.so.1
%%DATADIR%%/syntax/php.syntax
%%DATADIR%%/syntax/prolog.syntax
%%DATADIR%%/syntax/python.syntax
+%%DATADIR%%/syntax/scm.syntax
%%DATADIR%%/syntax/sh.syntax
%%DATADIR%%/syntax/smalltalk.syntax
%%DATADIR%%/syntax/sql.syntax