aboutsummaryrefslogtreecommitdiff
path: root/editors/cpeditor
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-07-22 20:56:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-07-22 20:56:43 +0000
commit5fc3d82cd7dff4f5b4c9584f800e39274983f240 (patch)
tree729ed8397f1c3f09af7bde457ad2e18dd0933f39 /editors/cpeditor
parentf6c9e69f538c607d0733dd0184f85cc8af9393e2 (diff)
downloadports-5fc3d82cd7dff4f5b4c9584f800e39274983f240.tar.gz
ports-5fc3d82cd7dff4f5b4c9584f800e39274983f240.zip
New port: editors/cpeditor: Lightweight and cross-platform code editor for competitive programming
Notes
Notes: svn path=/head/; revision=542895
Diffstat (limited to 'editors/cpeditor')
-rw-r--r--editors/cpeditor/Makefile27
-rw-r--r--editors/cpeditor/distinfo13
-rw-r--r--editors/cpeditor/files/patch-src_Settings_settings.json18
-rw-r--r--editors/cpeditor/pkg-descr6
4 files changed, 64 insertions, 0 deletions
diff --git a/editors/cpeditor/Makefile b/editors/cpeditor/Makefile
new file mode 100644
index 000000000000..98610db1ab48
--- /dev/null
+++ b/editors/cpeditor/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= cpeditor
+DISTVERSION= 6.6.2
+CATEGORIES= editors devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight and cross-platform code editor for competitive programming
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++14-lang qt:5
+USE_QT= core gui network widgets buildtools_build linguisttools_build qmake_build
+USE_GITHUB= yes
+GH_TUPLE= \
+ cpeditor:QCodeEditor:baf096a7f2d4898913640f9f0bc401659fe2c087:cpeditor_QCodeEditor/third_party/QCodeEditor \
+ itay-grudev:SingleApplication:e93c12ab69a25fcaa963416f0e348d3269263190:itay_grudev_SingleApplication/third_party/singleapplication \
+ cpeditor:QtFindReplaceDialog:d6adb0091641aed078e1f41a48278374fa3b328b:cpeditor_QtFindReplaceDialog/third_party/QtFindReplaceDialog \
+ cpeditor:lsp-cpp:44e7cdea787c19646f3c88ba8cbd0ed5da02b9cd:cpeditor_lsp_cpp/third_party/lsp-cpp \
+ MikeMirzayanov:testlib:7354daf4a2a90868ef267185c23f14c30799c4a6:MikeMirzayanov_testlib/third_party/testlib
+
+PLIST_FILES= bin/cpeditor \
+ share/applications/cpeditor.desktop \
+ share/icons/cpeditor-icon.png
+
+.include <bsd.port.mk>
diff --git a/editors/cpeditor/distinfo b/editors/cpeditor/distinfo
new file mode 100644
index 000000000000..80fd9deded37
--- /dev/null
+++ b/editors/cpeditor/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1595449765
+SHA256 (cpeditor-cpeditor-6.6.2_GH0.tar.gz) = d3e9aa13988740b1a9afc028b061b98137de41281afb21298b4a6e0892724f5c
+SIZE (cpeditor-cpeditor-6.6.2_GH0.tar.gz) = 439007
+SHA256 (cpeditor-QCodeEditor-baf096a7f2d4898913640f9f0bc401659fe2c087_GH0.tar.gz) = 4c3679f82f3647dfbea047bb1220b27bca1d9a59ff2613ea93909333315b688c
+SIZE (cpeditor-QCodeEditor-baf096a7f2d4898913640f9f0bc401659fe2c087_GH0.tar.gz) = 94361
+SHA256 (itay-grudev-SingleApplication-e93c12ab69a25fcaa963416f0e348d3269263190_GH0.tar.gz) = 370d8ea1c3883cada3db24745b0b814e6b212c53b93694b67f4995e65abcd23f
+SIZE (itay-grudev-SingleApplication-e93c12ab69a25fcaa963416f0e348d3269263190_GH0.tar.gz) = 19320
+SHA256 (cpeditor-QtFindReplaceDialog-d6adb0091641aed078e1f41a48278374fa3b328b_GH0.tar.gz) = 3514b5c5d9509b32277f16500d86b32a964c4c911f8745d68739cc2d20d8ae18
+SIZE (cpeditor-QtFindReplaceDialog-d6adb0091641aed078e1f41a48278374fa3b328b_GH0.tar.gz) = 146972
+SHA256 (cpeditor-lsp-cpp-44e7cdea787c19646f3c88ba8cbd0ed5da02b9cd_GH0.tar.gz) = 43545556df3b32b506a2ab4e8db7d1167e1d00e4cf2533b520812a9e3f005127
+SIZE (cpeditor-lsp-cpp-44e7cdea787c19646f3c88ba8cbd0ed5da02b9cd_GH0.tar.gz) = 154649
+SHA256 (MikeMirzayanov-testlib-7354daf4a2a90868ef267185c23f14c30799c4a6_GH0.tar.gz) = cb4f3c3ac16291e6d40106007efe48d91c4fc8ccd1aec59e43575ab6dfcae2b0
+SIZE (MikeMirzayanov-testlib-7354daf4a2a90868ef267185c23f14c30799c4a6_GH0.tar.gz) = 40299
diff --git a/editors/cpeditor/files/patch-src_Settings_settings.json b/editors/cpeditor/files/patch-src_Settings_settings.json
new file mode 100644
index 000000000000..b93ae671524b
--- /dev/null
+++ b/editors/cpeditor/files/patch-src_Settings_settings.json
@@ -0,0 +1,18 @@
+--- src/Settings/settings.json.orig 2020-07-22 20:35:15 UTC
++++ src/Settings/settings.json
+@@ -120,7 +120,7 @@
+ {
+ "name": "C++/Compile Command",
+ "type": "QString",
+- "default": "g++ -Wall",
++ "default": "c++ -Wall",
+ "tip": "The command used to compile C++. It should NOT include the path to the source file or \"-o <output file>\"."
+ },
+ {
+@@ -984,4 +984,4 @@
+ "default": "true",
+ "trtip": "tr(\"When there are file changes that are not made in CP Editor and is not automatically loaded by\\n\\\"%1\\\", ask for whether to load the changes.\\nIf this is disabled, external file changes will be ignored unless they are loaded by\\n\\\"%1\\\".\").arg(tr(\"Auto-load external file changes if there's no unsaved modification\"))"
+ }
+-]
+\ No newline at end of file
++]
diff --git a/editors/cpeditor/pkg-descr b/editors/cpeditor/pkg-descr
new file mode 100644
index 000000000000..32b39c632d99
--- /dev/null
+++ b/editors/cpeditor/pkg-descr
@@ -0,0 +1,6 @@
+CP Editor is a Qt-based, lightweight and cross-platform code editor specially
+designed for competitive programming.
+It makes your competitive coding life easier grin by automating many things
+for you.
+
+WWW: https://github.com/cpeditor/cpeditor