aboutsummaryrefslogtreecommitdiff
path: root/editors/editorconfig-core-c
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2013-10-23 10:29:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2013-10-23 10:29:10 +0000
commit334a0b71dcee53406091901312c8082d40093255 (patch)
treea045bf7677671891749568e6533f10c083723c8c /editors/editorconfig-core-c
parent34ac44a2b41b94e776559e46fda8cc7bf44c4795 (diff)
downloadports-334a0b71dcee53406091901312c8082d40093255.tar.gz
ports-334a0b71dcee53406091901312c8082d40093255.zip
Add editorconfig-core-c 0.11.5.
Notes
Notes: svn path=/head/; revision=331364
Diffstat (limited to 'editors/editorconfig-core-c')
-rw-r--r--editors/editorconfig-core-c/Makefile23
-rw-r--r--editors/editorconfig-core-c/distinfo2
-rw-r--r--editors/editorconfig-core-c/pkg-descr8
-rw-r--r--editors/editorconfig-core-c/pkg-plist9
4 files changed, 42 insertions, 0 deletions
diff --git a/editors/editorconfig-core-c/Makefile b/editors/editorconfig-core-c/Makefile
new file mode 100644
index 000000000000..8d881a74e740
--- /dev/null
+++ b/editors/editorconfig-core-c/Makefile
@@ -0,0 +1,23 @@
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
+# $FreeBSD$
+
+PORTNAME= editorconfig-core-c
+PORTVERSION= 0.11.5
+CATEGORIES= editors
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= EditorConfig core library and executable written in C
+
+USE_GITHUB= yes
+GH_ACCOUNT= editorconfig
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= c5e2a58
+
+USES= cmake
+USE_LDCONFIG= yes
+
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ SHLIB_MAJOR=${PORTVERSION:C/\..+//} \
+ SHLIB_VER=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/editors/editorconfig-core-c/distinfo b/editors/editorconfig-core-c/distinfo
new file mode 100644
index 000000000000..37d76017451a
--- /dev/null
+++ b/editors/editorconfig-core-c/distinfo
@@ -0,0 +1,2 @@
+SHA256 (editorconfig-core-c-0.11.5.tar.gz) = 78e2a515a899785349272f264395f0d934c8eebfbd074ab07c281e4638ecba0b
+SIZE (editorconfig-core-c-0.11.5.tar.gz) = 76868
diff --git a/editors/editorconfig-core-c/pkg-descr b/editors/editorconfig-core-c/pkg-descr
new file mode 100644
index 000000000000..71abf5050a64
--- /dev/null
+++ b/editors/editorconfig-core-c/pkg-descr
@@ -0,0 +1,8 @@
+EditorConfig helps developers define and maintain consistent coding
+styles between different editors and IDEs.
+
+This package provides the core library and editorconfig(1) executable
+both written in C for use by text editor plugins supporting
+EditorConfig parsing.
+
+WWW: http://editorconfig.org/
diff --git a/editors/editorconfig-core-c/pkg-plist b/editors/editorconfig-core-c/pkg-plist
new file mode 100644
index 000000000000..961ffe6db0f9
--- /dev/null
+++ b/editors/editorconfig-core-c/pkg-plist
@@ -0,0 +1,9 @@
+bin/editorconfig
+bin/editorconfig-%%PORTVERSION%%
+include/editorconfig/editorconfig.h
+include/editorconfig/editorconfig_handle.h
+@dirrm include/editorconfig
+lib/libeditorconfig.so
+lib/libeditorconfig.so.%%SHLIB_MAJOR%%
+lib/libeditorconfig.so.%%SHLIB_VER%%
+lib/libeditorconfig_static.a