aboutsummaryrefslogtreecommitdiff
path: root/editors/elementary-code
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-07-01 20:43:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-07-01 20:43:23 +0000
commitd5363d97dff6d743978f2960387d1225b35d6d92 (patch)
treed482fdf795b4b38a82b0f7350504fdfc2192ccf3 /editors/elementary-code
parentd854684bd48408c41c34a97a1a20c1b1b830b5e0 (diff)
downloadports-d5363d97dff6d743978f2960387d1225b35d6d92.tar.gz
ports-d5363d97dff6d743978f2960387d1225b35d6d92.zip
Add compiler:c++11-lang to USES to fix build on GCC-based systems:
/usr/local/include/libgit2-glib-1.0/libgit2-glib/ggit-ref.h:33: error: redefinition of typedef 'GgitRef' Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=540992
Diffstat (limited to 'editors/elementary-code')
-rw-r--r--editors/elementary-code/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/elementary-code/Makefile b/editors/elementary-code/Makefile
index 3116ede14829..2af15e6574bf 100644
--- a/editors/elementary-code/Makefile
+++ b/editors/elementary-code/Makefile
@@ -28,8 +28,8 @@ LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libzeitgeist-2.0.so:sysutils/zeitgeist
-USES= desktop-file-utils gettext gnome meson ninja pkgconfig \
- python:build xorg
+USES= compiler:c++11-lang desktop-file-utils gettext gnome meson \
+ ninja pkgconfig python:build xorg
USE_GITHUB= yes
GH_ACCOUNT= elementary
GH_PROJECT= code