aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2019-01-31 19:34:22 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2019-01-31 19:34:22 +0000
commit70923fe9f6e2d45db77b9267347c7f162a80dcb5 (patch)
tree0a1b0e0a176cefdbf4e2da2cf8d2bd20e5347c45 /editors/emacs
parent08c9b9fff3d0cca68dfbbf600b59eb7abc7d8d64 (diff)
downloadports-70923fe9f6e2d45db77b9267347c7f162a80dcb5.tar.gz
ports-70923fe9f6e2d45db77b9267347c7f162a80dcb5.zip
editors/emacs: Fix spellchecking with hunspell 1.7.0
While here, silence warning about USE_GNOME without USES=gnome. PR: 235201 Reported by: abij@tuta.io
Notes
Notes: svn path=/head/; revision=491755
Diffstat (limited to 'editors/emacs')
-rw-r--r--editors/emacs/Makefile10
-rw-r--r--editors/emacs/files/patch-lisp_textmodes_ispell.el16
2 files changed, 25 insertions, 1 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index c83c404fd626..dba351cdaf10 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= emacs
DISTVERSION= ${EMACS_VER}
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 3
CATEGORIES= editors ipv6
MASTER_SITES= GNU
@@ -128,26 +128,32 @@ XWIDGETS_DESC= Experimental GTK widgets (requires GTK3)
ACL_CONFIGURE_ENABLE= acl
ALSA_CONFIGURE_ON= --with-sound=alsa
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+CAIRO_USES= gnome
CAIRO_USE= GNOME=cairo
CAIRO_CONFIGURE_WITH= cairo
CAIRO_IMPLIES= PNG XFT
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_CONFIGURE_WITH= dbus
+GCONF_USES= gnome
GCONF_USE= GNOME=gconf2
GCONF_CONFIGURE_WITH= gconf
GFILE_CONFIGURE_ON= --with-file-notification=gfile
+GFILE_USES= gnome
GFILE_USE= GNOME=glib20
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
GIF_CONFIGURE_WITH= gif
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_WITH= gnutls
+GSETTINGS_USES= gnome
GSETTINGS_USE= GNOME=glib20
GSETTINGS_CONFIGURE_WITH= gsettings
GSETTINGS_IMPLIES= DBUS
+GTK2_USES= gnome
GTK2_USE= GNOME=cairo,gtk20
GTK2_CONFIGURE_ON= --with-x-toolkit=gtk2
GTK2_LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
+GTK3_USES= gnome
GTK3_USE= GNOME=cairo,gtk30
GTK3_CONFIGURE_ON= --with-x-toolkit=gtk3
JPEG_USES= jpeg
@@ -180,6 +186,7 @@ SCROLLBARS_CONFIGURE_WITH= toolkit-scroll-bars
.if ${FLAVOR:U} == canna
SOURCES_PLIST_FILES= ${DATADIR}/${EMACS_VER}/src/canna.c
.endif
+SVG_USES= gnome
SVG_USE= GNOME=cairo,librsvg2
SVG_CONFIGURE_WITH= rsvg
SVG_IMPLIES= PNG
@@ -195,6 +202,7 @@ XFT_CONFIGURE_WITH= xft
XFT_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
XIM_CONFIGURE_WITH= xim
+XML_USES= gnome
XML_USE= GNOME=libxml2
XML_CONFIGURE_WITH= xml2
XPM_USE= XORG=xpm
diff --git a/editors/emacs/files/patch-lisp_textmodes_ispell.el b/editors/emacs/files/patch-lisp_textmodes_ispell.el
new file mode 100644
index 000000000000..c2ea531603c7
--- /dev/null
+++ b/editors/emacs/files/patch-lisp_textmodes_ispell.el
@@ -0,0 +1,16 @@
+--- lisp/textmodes/ispell.el.orig 2018-05-25 08:53:30 UTC
++++ lisp/textmodes/ispell.el
+@@ -1111,7 +1111,12 @@ dictionary from that list was found."
+ null-device
+ t
+ nil
+- "-D")
++ ;; Hunspell 1.7.0 (and later?) won't
++ ;; show LOADED DICTIONARY unless
++ ;; there's at least one file argument
++ ;; on the command line. So we feed
++ ;; it with the null device.
++ "-D" null-device)
+ (buffer-string))
+ "[\n\r]+"
+ t))