aboutsummaryrefslogtreecommitdiff
path: root/editors/encryptpad
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-05 20:09:27 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-05 20:09:27 +0000
commit28aaaf199257fe081d1f4e8e675df9840affd235 (patch)
tree3af8fcdf693bb33ee3c7b6ef82d30dc5b8dbb28e /editors/encryptpad
parent1a785b569638b791ea42871e011d4e464a0e92ae (diff)
downloadports-28aaaf199257fe081d1f4e8e675df9840affd235.tar.gz
ports-28aaaf199257fe081d1f4e8e675df9840affd235.zip
This port requires USES=c++11-lang to build on architectures that
use GCC in base. Also requires switching from freebsd-clang++ to freebsd-g++ where GCC needs to be used. PR: 232012 Submitted by: Piotr Kubaj Approved by: maintainer
Notes
Notes: svn path=/head/; revision=484216
Diffstat (limited to 'editors/encryptpad')
-rw-r--r--editors/encryptpad/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
index 157a2e662bed..9466c8b55095 100644
--- a/editors/encryptpad/Makefile
+++ b/editors/encryptpad/Makefile
@@ -16,7 +16,8 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libbotan-2.so:security/botan2
-USES= desktop-file-utils gl gmake pkgconfig qt:5 shared-mime-info shebangfix
+USES= compiler:c++11-lang desktop-file-utils gl gmake pkgconfig qt:5 \
+ shared-mime-info shebangfix
USE_GL= gl
USE_QT= core gui widgets buildtools_build qmake_build
SHEBANG_FILES= deps/libencryptmsg/configure
@@ -29,6 +30,14 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e 's/freebsd-clang/freebsd-g++/' \
+ ${WRKSRC}/build/Makefile.qt_ui
+.endif
+
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} MAKE=${MAKE_CMD} \
./configure.sh --all --use-system-libs
@@ -51,4 +60,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}/${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>