aboutsummaryrefslogtreecommitdiff
path: root/editors/encryptpad
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-19 09:21:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-19 09:21:01 +0000
commit5d6cba076e6e57f5e1749feac56c4facca107543 (patch)
tree415d1e745b622b5f245211f3abfe12feccd75c38 /editors/encryptpad
parent91215fb952edc35120ae810092246f0d06a0b47b (diff)
Notes
Diffstat (limited to 'editors/encryptpad')
-rw-r--r--editors/encryptpad/Makefile52
-rw-r--r--editors/encryptpad/distinfo3
-rw-r--r--editors/encryptpad/pkg-descr9
-rw-r--r--editors/encryptpad/pkg-plist7
4 files changed, 71 insertions, 0 deletions
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
new file mode 100644
index 000000000000..6b10ada2f1dc
--- /dev/null
+++ b/editors/encryptpad/Makefile
@@ -0,0 +1,52 @@
+# Created by: Dmitri Goutnik <dg@syrec.org>
+# $FreeBSD$
+
+PORTNAME= encryptpad
+PORTVERSION= 0.3.2.5
+DISTVERSIONPREFIX= v
+CATEGORIES= editors security
+
+MAINTAINER= dg@syrec.org
+COMMENT= Minimalist secure text editor and binary encryptor
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libbotan-1.10.so:security/botan110
+
+USE_GITHUB= yes
+GH_ACCOUNT= evpo
+GH_PROJECT= EncryptPad
+
+USES= desktop-file-utils gmake pkgconfig shared-mime-info
+USE_QT5= core gui widgets qmake_build buildtools_build
+USE_GL= gl
+
+PORTDOCS= CHANGES.* README.* docs
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ (cd ${WRKSRC} && ${SETENV} MAKE=${MAKE_CMD} PATH=${QT_BINDIR}:${PATH} \
+ ./configure.sh --all --use-system-libs)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/release/* ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/encryptpad.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
+ ${INSTALL_DATA} ${WRKSRC}/encryptpad.xml \
+ ${STAGEDIR}${PREFIX}/share/mime/packages
+.for sz in 16 32 128
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps
+ ${INSTALL_DATA} ${WRKSRC}/images/icns.iconset/icon_${sz}x${sz}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps/encryptpad.png
+.endfor
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -a ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/encryptpad/distinfo b/editors/encryptpad/distinfo
new file mode 100644
index 000000000000..d9b798798b46
--- /dev/null
+++ b/editors/encryptpad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484432907
+SHA256 (evpo-EncryptPad-v0.3.2.5_GH0.tar.gz) = f9870c4aad45dd8171f92e97632e748b9504a52a1436c232cb387246672666e5
+SIZE (evpo-EncryptPad-v0.3.2.5_GH0.tar.gz) = 7988782
diff --git a/editors/encryptpad/pkg-descr b/editors/encryptpad/pkg-descr
new file mode 100644
index 000000000000..9c0aa83887b4
--- /dev/null
+++ b/editors/encryptpad/pkg-descr
@@ -0,0 +1,9 @@
+EncryptPad is an application for viewing and editing symmetrically encrypted
+text. It also provides a tool for encrypting and decrypting binary files on
+disk. The application offers effective measures for protecting information
+with simple and convenient graphical and command line interface. The editor
+uses most widely chosen quality file format OpenPGP RFC 4880. Unlike other
+OpenPGP software which main purpose is asymmetric encryption, the primary
+focus of EncryptPad is symmetric encryption.
+
+WWW: http://evpo.net/encryptpad/
diff --git a/editors/encryptpad/pkg-plist b/editors/encryptpad/pkg-plist
new file mode 100644
index 000000000000..12f2baf09c68
--- /dev/null
+++ b/editors/encryptpad/pkg-plist
@@ -0,0 +1,7 @@
+bin/encryptpad
+bin/encryptcli
+share/applications/encryptpad.desktop
+share/icons/hicolor/128x128/apps/encryptpad.png
+share/icons/hicolor/16x16/apps/encryptpad.png
+share/icons/hicolor/32x32/apps/encryptpad.png
+share/mime/packages/encryptpad.xml