aboutsummaryrefslogtreecommitdiff
path: root/editors/encryptpad
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-16 19:08:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-16 19:08:40 +0000
commitee78dfe29166d4147cb217ed7969a1b96afca212 (patch)
treee34dbc873f0ea8844a71dff477d61192c4f48b96 /editors/encryptpad
parent0643d2d5f42563ee03d81c939753d8e6e4363a4e (diff)
downloadports-ee78dfe29166d4147cb217ed7969a1b96afca212.tar.gz
ports-ee78dfe29166d4147cb217ed7969a1b96afca212.zip
editors/encryptpad: fix runtime on powerpc64
configure.py sets ppc32 as target architecture: INFO: Canonicalized CPU target powerpc to ppc32 INFO: Autodetected platform information: OS="FreeBSD" machine="powerpc" proc="powerpc64" MFH: 2020Q3 (runtime fix)
Notes
Notes: svn path=/head/; revision=542378
Diffstat (limited to 'editors/encryptpad')
-rw-r--r--editors/encryptpad/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
index 04753372b1bf..b51e251bc680 100644
--- a/editors/encryptpad/Makefile
+++ b/editors/encryptpad/Makefile
@@ -4,6 +4,7 @@
PORTNAME= encryptpad
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0.0
+PORTVERSION= 1
CATEGORIES= editors security
MAINTAINER= dmgk@FreeBSD.org
@@ -29,6 +30,12 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+CONFIGURE_ARGS= --cpu="${ARCH}"
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
@@ -38,7 +45,7 @@ post-patch:
.endif
do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./configure.py
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./configure.py ${CONFIGURE_ARGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/release/* ${STAGEDIR}${PREFIX}/bin