aboutsummaryrefslogtreecommitdiff
path: root/editors/flim
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2017-07-28 21:45:20 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2017-07-28 21:45:20 +0000
commitf872930d0e52c8802d4085a53fd91d3af6e0ddad (patch)
treea79f71211dc0ed6f08a805235e59f1fc3946e774 /editors/flim
parent0f17cf99be7bb6defa0b0a6f7788fad50febe6fb (diff)
downloadports-f872930d0e52c8802d4085a53fd91d3af6e0ddad.tar.gz
ports-f872930d0e52c8802d4085a53fd91d3af6e0ddad.zip
Set MAKEINFO to the full path of makeinfo when USES=makeinfo is set.
PR: 221027 Reviewed by: mat Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=446854
Diffstat (limited to 'editors/flim')
-rw-r--r--editors/flim/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index 8f2b7ccf0146..23ab1fc19363 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -60,7 +60,7 @@ BUILD_DEPENDS+= nkf:japanese/nkf
.endif
# makeinfo stuff
-MAKEINFO= makeinfo --no-split --no-validate
+MAKEINFO_FLAGS= --no-split --no-validate
MAKEINFO_EMACS= ${EMACS_CMD} -no-site-file -no-init-file -batch
MAKEINFO_EMACS_FLAGS= -e texinfo-format-buffer -f save-buffer
@@ -109,14 +109,14 @@ info-build:
for i in mime-en.texi; do \
${MV} $${i} $${i}.jis ; \
${CAT} $${i}.jis | nkf -e > $${i} ; \
- ${MAKEINFO} $${i} || ${TRUE} ; \
+ ${MAKEINFO} ${MAKEINFO_FLAGS} $${i} || ${TRUE} ; \
done)
.if defined(EMACS_HAS_MULE) && (${EMACS_HAS_MULE} == "YES")
@(cd ${WRKSRC} ; \
for i in mime-ja.texi; do \
${MV} $${i} $${i}.jis ; \
${CAT} $${i}.jis | nkf -e > $${i} ; \
- ${MAKEINFO} $${i} || ${TRUE} ; \
+ ${MAKEINFO} ${MAKEINFO_FLAGS} $${i} || ${TRUE} ; \
done)
.endif