aboutsummaryrefslogtreecommitdiff
path: root/editors/fte
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 02:27:49 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 02:27:49 +0000
commit56742b3e321f2bf365248467927b0dac1bf3b4b4 (patch)
tree2b3d850e16a4e1d60c7ee07b1282feb1cef7c563 /editors/fte
parentc4428ccb691de20d9b90892077ca0d3ec7c4ff6d (diff)
downloadports-56742b3e321f2bf365248467927b0dac1bf3b4b4.tar.gz
ports-56742b3e321f2bf365248467927b0dac1bf3b4b4.zip
Add FTE, a full-featured text editor for X11.
PR: 18493 Submitted by: Alexander Gelfenbain <mail@gelf.com>
Notes
Notes: svn path=/head/; revision=29419
Diffstat (limited to 'editors/fte')
-rw-r--r--editors/fte/Makefile48
-rw-r--r--editors/fte/distinfo1
-rw-r--r--editors/fte/files/conffiles64
-rw-r--r--editors/fte/files/patch-aa58
-rw-r--r--editors/fte/files/patch-ab275
-rw-r--r--editors/fte/files/patch-ac63
-rw-r--r--editors/fte/files/patch-ad13
-rw-r--r--editors/fte/pkg-comment1
-rw-r--r--editors/fte/pkg-descr11
-rw-r--r--editors/fte/pkg-plist70
10 files changed, 604 insertions, 0 deletions
diff --git a/editors/fte/Makefile b/editors/fte/Makefile
new file mode 100644
index 000000000000..33e87c5cea23
--- /dev/null
+++ b/editors/fte/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: fte
+# Date created: 8 May 2000
+# Whom: gelf
+#
+# $FreeBSD$
+#
+
+PORTNAME= fte
+PORTVERSION= 46.5
+CATEGORIES= editors
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/fte/ \
+ http://download.sourceforge.net/fte/
+DISTNAME= ${PORTNAME}s${PORTVERSION:S/./b/}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= mail@gelf.com
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+EXTRACT_CMD= unzip
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS=
+USE_NEWGCC= yes
+
+.include "${.CURDIR}/files/conffiles"
+
+do-build:
+ (cd ${WRKSRC}/src ; ${MAKE} -f fte-unix.mak)
+ (cd ${WRKSRC}/config ; ../src/cfte main.fte)
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc/fte
+ ${MKDIR} ${PREFIX}/lib/fte/etc/kbd
+ ${MKDIR} ${PREFIX}/lib/fte/etc/menu
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xfte ${PREFIX}/bin/fte
+ ${INSTALL_DATA} ${WRKSRC}/config/fte-new.cnf ${PREFIX}/etc/fte/system.fterc
+.for CONFFILE in ${CONFFILES}
+ ${INSTALL_DATA} ${WRKSRC}/config/${CONFFILE} ${PREFIX}/lib/fte/etc
+.endfor
+.for KBDFILE in ${KBDFILES}
+ ${INSTALL_DATA} ${WRKSRC}/config/kbd/${KBDFILE} ${PREFIX}/lib/fte/etc/kbd
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/config/menu/m_c.fte ${PREFIX}/lib/fte/etc/menu
+ ${INSTALL_DATA} ${WRKSRC}/config/menu/m_html.fte ${PREFIX}/lib/fte/etc/menu
+
+.include <bsd.port.mk>
diff --git a/editors/fte/distinfo b/editors/fte/distinfo
new file mode 100644
index 000000000000..ff84924048c7
--- /dev/null
+++ b/editors/fte/distinfo
@@ -0,0 +1 @@
+MD5 (ftes46b5.zip) = 8a3c0f27769e8bc937c086d7f870ca0e
diff --git a/editors/fte/files/conffiles b/editors/fte/files/conffiles
new file mode 100644
index 000000000000..509fb9396e4f
--- /dev/null
+++ b/editors/fte/files/conffiles
@@ -0,0 +1,64 @@
+CONFFILES= \
+ ab_c.fte \
+ ab_c_os2.fte \
+ color.fte \
+ global.fte \
+ k_brief.fte \
+ m_ada.fte \
+ m_asm.fte \
+ m_asm370.fte \
+ m_bin.fte \
+ m_c.fte \
+ m_clario.fte \
+ m_diff.fte \
+ m_ebnf.fte \
+ m_fort90.fte \
+ m_fte.fte \
+ m_html.fte \
+ m_ipf.fte \
+ m_java.fte \
+ m_ldsgml.fte \
+ m_make.fte \
+ m_msg.fte \
+ m_mvsasm.fte \
+ m_pascal.fte \
+ m_perl.fte \
+ m_plain.fte \
+ m_resdlg.fte \
+ m_rexx.fte \
+ m_sh.fte \
+ m_tcl.fte \
+ m_tex.fte \
+ m_texi.fte \
+ m_text.fte \
+ m_vi.fte \
+ m_xp.fte \
+ main.fte \
+ pal_blk.fte \
+ pal_blue.fte \
+ pal_wht.fte \
+ ui_brief.fte \
+ ui_fte.fte \
+ ui_fte2.fte \
+ ui_k_fte.fte \
+ ui_k_fte2.fte \
+ ui_k_ne.fte \
+ ui_k_ws.fte \
+ ui_m_fte.fte \
+ ui_m_fte2.fte \
+ ui_m_ne.fte \
+ ui_m_ws.fte \
+ ui_mew.fte \
+ ui_ne.fte \
+ ui_vi.fte \
+ ui_ws.fte \
+ m_siod.fte \
+ uicstyle.fte
+
+KBDFILES= \
+ k_c.fte \
+ k_fte.fte \
+ k_html.fte \
+ k_java.fte \
+ k_perl.fte \
+ k_rexx.fte
diff --git a/editors/fte/files/patch-aa b/editors/fte/files/patch-aa
new file mode 100644
index 000000000000..b67ab084884d
--- /dev/null
+++ b/editors/fte/files/patch-aa
@@ -0,0 +1,58 @@
+--- src/con_x11.cpp.orig Mon May 8 18:28:23 2000
++++ src/con_x11.cpp Mon May 8 05:52:27 2000
+@@ -109,6 +109,7 @@
+ int r, g, b;
+ } dcolors[] =
+ {
++#if 0
+ { 0, 0, 0 }, // black
+ { 0, 0, 128 }, // darkBlue
+ { 0, 128, 0 }, // darkGreen
+@@ -125,6 +126,24 @@
+ { 255, 0, 255 }, // magenta
+ { 255, 255, 0 }, // yellow
+ { 255, 255, 255 }, // white
++#else
++ { 0, 0, 0 }, // black
++ { 0, 0, 191 }, // darkBlue
++ { 0, 191, 0 }, // darkGreen
++ { 0, 191, 191 }, // darkCyan
++ { 238, 0, 0 }, // darkRed
++ { 205, 0, 205 }, // darkMagenta
++ { 165, 42, 42 }, // darkYellow
++ { 192, 192, 192 }, // paleGray
++ { 128, 128, 128 }, // darkGray
++ { 0, 0, 255 }, // blue
++ { 0, 255, 0 }, // green
++ { 0, 255, 255 }, // cyan
++ { 255, 0, 64 }, // red
++ { 255, 0, 255 }, // magenta
++ { 255, 255, 64 }, // yellow
++ { 255, 255, 255 }, // white
++#endif
+ };
+
+ static void SetColor(int i) {
+--- src/o_directory.cpp.orig Mon May 8 18:28:41 2000
++++ src/o_directory.cpp Mon May 8 05:54:15 2000
+@@ -63,7 +63,7 @@
+ " %04d/%02d/%02d %02d:%02d:%02d %8ld %.500s%c",
+ #endif
+ Year, Mon, Day, Hour, Min, Sec,
+- Files[Line]->Size(),
++ (long int) Files[Line]->Size(),
+ Files[Line]->Name(),
+ // (Files[Line]->Type() == fiDIRECTORY)? '\\' : ' ');
+ (Files[Line]->Type() == fiDIRECTORY)? SLASH : ' ');
+--- src/sysdep.h.orig Mon May 8 18:28:48 2000
++++ src/sysdep.h Mon May 8 05:18:58 2000
+@@ -33,7 +33,8 @@
+ !defined(HPUX) && \
+ !defined(AIX) && \
+ !defined(IRIX) && \
+- !defined(SUNOS)
++ !defined(SUNOS) && \
++ !defined(FREEBSD)
+ # error Target not supported.
+ #endif
+
diff --git a/editors/fte/files/patch-ab b/editors/fte/files/patch-ab
new file mode 100644
index 000000000000..790a4a865417
--- /dev/null
+++ b/editors/fte/files/patch-ab
@@ -0,0 +1,275 @@
+--- config/m_plain.fte- Mon May 8 18:51:19 2000
++++ config/m_plain.fte Mon May 8 05:32:25 2000
+@@ -47,10 +47,10 @@
+ MultiLineHilit = 0;
+ WordChars = 'A-Za-z0-9_';
+ Abbreviations = 1;
+- PersistentBlocks = 1; # 1 = persistent blocks, 0 = transient
+- BackSpKillBlock = 0; # to delete block if marked
+- DeleteKillBlock = 0; # ""
+- InsertKillBlock = 0; # inserting char kills selected block
++ PersistentBlocks = 0; # 1 = persistent blocks, 0 = transient
++ BackSpKillBlock = 1; # to delete block if marked
++ DeleteKillBlock = 1; # ""
++ InsertKillBlock = 1; # inserting char kills selected block
+ }
+
+ # for viewing nnrrooffff output (do NOT use for editing).
+--- config/main.fte- Mon May 8 18:51:27 2000
++++ config/main.fte Mon May 8 05:50:09 2000
+@@ -13,7 +13,8 @@
+ # experimental
+
+ #%define(COLORS_WHITE_BG)
+-%define(COLORS_BLACK_BG)
++#%define(COLORS_BLACK_BG)
++%define(COLORS_BLUE_BG)
+
+ %if(OS_OS2)
+ %define(GUI_PM)
+@@ -59,6 +60,10 @@
+ include 'pal_wht.fte';
+ %endif
+
++%if(COLORS_BLUE_BG)
++include 'pal_blue.fte';
++%endif
++
+ object GLOBAL {
+ # fonts for GUI version
+
+@@ -87,8 +92,8 @@
+ # WindowFont = "6x8";
+ # WindowFont = "7x13";
+ # WindowFont = "8x13";
+- WindowFont = "9x15";
+-# WindowFont = "10x20";
++# WindowFont = "9x15";
++ WindowFont = "10x20";
+ %endif
+ }
+
+@@ -160,8 +165,8 @@
+ # ui*.fte -files define all keyboard bindings and menus.
+ # pick only one file.
+ %if(UI_FTE)
+-include 'ui_fte.fte'; # fte CUA style bindings
+-##include 'ui_fte2.fte'; # fte CUA style bindings with conditional cascade menus
++##include 'ui_fte.fte'; # fte CUA style bindings
++include 'ui_fte2.fte'; # fte CUA style bindings with conditional cascade menus
+ %endif
+ %if(UI_WS)
+ include 'ui_ws.fte'; # wordstar like
+@@ -184,6 +189,9 @@
+ include 'ab_c_os2.fte';
+ %endif
+
++
++
++
+ # some customizations
+
+ object GLOBAL {
+@@ -198,6 +206,15 @@
+ #eventmap C { key [S+G-Ins] { BlockPasteStream; BlockReIndent } }
+
+ eventmap PLAIN {
++
++ key [S+F4] { PopGlobalBookmark }
++ key [C+F4] { PopGlobalBookmark; PushGlobalBookmark }
++ key [F4] { PushGlobalBookmark }
++ key [C+Up] {WinPrev }
++ key [C+Down] {WinNext}
++ key [A+S+/] {BlockSelectWord}
++ key [C+W] {BlockSelectWord}
++
+ key [A+S+-] { # select block between {}()[]<>
+ BlockUnmark; BlockMarkStream; MatchBracket; BlockMarkStream;
+ SavePos; MoveBlockEnd;
+@@ -244,8 +261,8 @@
+ MoveLineStart; ?FindReplace /^(\s*)/ /\1\/\// "xnc"; MoveDown
+ }
+ key [G-Home] { MoveBeginOrNonWhite }
+- key [C+G-Up] { PopGlobalBookmark }
+- key [C+G-Down] { PushGlobalBookmark }
++# key [C+G-Up] { PopGlobalBookmark }
++# key [C+G-Down] { PushGlobalBookmark }
+ }
+
+ object GLOBAL {
+--- config/ui_k_fte2.fte- Mon May 8 18:51:35 2000
++++ config/ui_k_fte2.fte Mon May 8 05:41:05 2000
+@@ -160,8 +160,8 @@
+ key [C+G-PgUp] { MoveFileStart }
+ key [G-PgDn] { MovePageDown }
+ key [C+G-PgDn] { MoveFileEnd }
+-# key [A+G-Up] { ScrollUp }
+-# key [A+G-Down] { ScrollDown }
++ key [A+Down] { ScrollUp }
++ key [A+Up] { ScrollDown }
+ # key [A+G-Left] { ScrollLeft }
+ # key [A+G-Right] { ScrollRight }
+
+@@ -188,7 +188,7 @@
+ key [A+G-C+Left] { MovePrevTab }
+ key [A+G-C+Right] { MoveNextTab }
+ key [C+G-Ins] { BlockCopy }
+- key [C+G-Del] { BlockKill }
++# key [C+G-Del] { BlockKill }
+ key [S+G-Ins] { BlockPasteStream }
+ key [S+G-Del] { BlockCut }
+ key [A+G-Ins] { BlockPasteColumn }
+@@ -207,6 +207,7 @@
+ key [G-S+Enter] { LineInsert }
+ key [A+G-Enter] { LineAdd }
+ key [A+G-Del] { KillWord }
++ key [C+G-Del] { KillWord }
+ key [A+G-End] { KillToLineEnd }
+ key [A+BackSp] { Undo }
+ key [A+S+BackSp] { Redo }
+@@ -245,6 +246,7 @@
+ key [C+G] { FindRepeat }
+ key [C+I] { ListRoutines }
+ key [C+J] { LineJoin }
++ key [C+K] { KillToLineEnd }
+ key [C+H] { FindRepeatReverse }
+ key [C+M] { DirOpen }
+ key [C+Q] { InsertChar }
+--- /dev/null Mon May 8 18:50:40 2000
++++ config/pal_blue.fte Mon May 8 05:41:33 2000
+@@ -0,0 +1,135 @@
++# color palette (blue background)
++
++# the color palette is the definition of the symbolic colors
++# that are used everywhere else in the configuration files
++
++# syntax of the color specification is:
++#
++# fore back
++# or
++# symbolic_fore:symbolic_back
++# or
++# symbolic
++
++color_palette {
++ # map system colors to symbolic
++
++ { 'black', '0 0' },
++ { 'darkBlue', '1 1' },
++ { 'darkGreen', '2 2' },
++ { 'darkCyan', '3 3' },
++ { 'darkRed', '4 4' },
++ { 'darkMagenta', '5 5' },
++ { 'brown', '6 6' },
++ { 'gray', '7 7' },
++ { 'darkGray', '8 8' },
++ { 'blue', '9 9' },
++ { 'green', 'A A' },
++ { 'cyan', 'B B' },
++ { 'red', 'C C' },
++ { 'magenta', 'D D' },
++ { 'yellow', 'E E' },
++ { 'white', 'F F' },
++
++ { 'ScrollBar_Arrows', 'black:gray' },
++ { 'ScrollBar_Background', 'gray:black' },
++ { 'ScrollBar_Slider', 'black:gray' },
++
++ { 'Status_Normal', 'black:darkCyan' },
++ { 'Status_Active', 'black:gray' },
++
++ { 'Message_Normal', 'cyan:darkBlue' },
++ { 'Message_Error', 'white:darkBlue' },
++ { 'Message_Bold', 'white:darkRed' },
++
++ { 'EntryField_Field', 'cyan:darkBlue' },
++ { 'EntryField_Prompt', 'white:darkBlue' },
++ { 'EntryField_Selection', 'black:darkGreen' },
++
++ { 'List_Status', 'black:gray' },
++ { 'List_Normal', 'yellow:darkBlue' },
++ { 'List_Selected', 'black:gray' },
++
++ { 'ASCII_Chars', 'gray:black' },
++
++ { 'Menu_Background', 'black:gray' },
++ { 'Menu_ActiveItem', 'white:darkBlue' },
++ { 'Menu_ActiveChar', 'red:darkBlue' },
++ { 'Menu_NormalItem', 'black:gray' },
++ { 'Menu_NormalChar', 'red:gray' },
++
++ { "Choice_Title", 'white:darkBlue' },
++ { "Choice_Param", 'cyan:darkBlue' },
++ { "Choice_Background", 'gray:darkBlue' },
++ { "Choice_ActiveItem", 'black:darkGreen' },
++ { "Choice_ActiveChar", 'white:darkGreen' },
++ { "Choice_NormalItem", 'white:darkBlue' },
++ { "Choice_NormalChar", 'yellow:darkBlue' },
++
++ { "bg", 'darkBlue:darkBlue' }, # background
++ { "fg", 'yellow:yellow' }, # foreground
++
++ { 'Editor_Selected', 'black:gray' },
++ { 'Editor_Markers', 'darkCyan:bg' },
++ { 'Editor_FoundText', 'white:darkRed' },
++ { 'Editor_Folds', 'green:bg' },
++ { 'Editor_HilitWord', 'red:bg' },
++
++ { 'Editor_Default', 'fg:bg' },
++ { 'Editor_Bold', 'cyan:bg' },
++ { 'Editor_Keywords', 'white:bg' },
++ { 'Editor_Keywords2', 'cyan:bg' },
++ { 'Editor_Keywords3', 'green:bg' },
++ { 'Editor_Keywords4', 'yellow:bg' },
++ { 'Editor_Keywords5', 'blue:bg' },
++
++ { 'Msg_Header', 'darkCyan:bg' },
++ { 'Msg_Quotes', 'green:bg' },
++ { 'Msg_Tag', 'white:bg' },
++ { 'Msg_Signature', 'darkCyan:bg' },
++
++ { 'Comment', 'white:bg' },
++ { 'String', 'white:bg' },
++
++ { 'Lang_Default', 'Editor_Default' },
++ { 'Lang_Number', 'yellow:bg' },
++ { 'Lang_DecimalNumber', 'Lang_Number' },
++ { 'Lang_HexNumber', 'yellow:bg' },
++ { 'Lang_OctalNumber', 'yellow:bg' },
++ { 'Lang_BinaryNumber', 'yellow:bg' },
++ { 'Lang_Punctuation', 'yellow:bg' },
++ { 'Lang_String', 'String' },
++ { 'Lang_Comment', 'Comment' },
++ { 'Lang_Preprocessor', 'green:bg' },
++ { 'Lang_Function', 'cyan:bg' },
++ { 'Lang_Label', 'yellow:bg' },
++ { 'Lang_Command', 'cyan:bg' },
++ { 'Lang_Regexp', 'magenta:bg' },
++ { 'Lang_Variable', 'gray:bg' },
++ { 'Lang_Control', 'darkCyan:bg' },
++ { 'Lang_Assembler', 'blue:bg' }, # embedded assembler (Pascal)
++
++ { 'Markup_Default', 'gray:bg' },
++ { 'Markup_Punctuation', 'darkCyan:bg' },
++ { 'Markup_String', 'String' },
++ { 'Markup_Symbol', 'green:bg' },
++ { 'Markup_Tag', 'cyan:bg' },
++ { 'Markup_Comment', 'Comment' },
++ { 'Markup_Special', 'red:bg' },
++ { 'Markup_Control', 'magenta:bg' },
++ { 'Markup_Quotes', 'yellow:bg' },
++ { 'Markup_Math', 'red:bg' },
++
++ # diff/diff3
++ { 'DIFF_Default', 'Editor_Default' },
++ { 'DIFF_Old', 'gray:bg' },
++ { 'DIFF_New', 'white:bg' },
++ { 'DIFF_Changed', 'darkCyan:bg' },
++
++ # rcsmerge
++ { 'MERGE_Default', 'Editor_Default' },
++ { 'MERGE_Changed', 'white:bg' },
++ { 'MERGE_Old', 'gray:bg' },
++ { 'MERGE_New', 'red:bg' },
++ { 'MERGE_Control', 'yellow:bg' },
++}
diff --git a/editors/fte/files/patch-ac b/editors/fte/files/patch-ac
new file mode 100644
index 000000000000..36bdc7d68a29
--- /dev/null
+++ b/editors/fte/files/patch-ac
@@ -0,0 +1,63 @@
+--- src/fte-unix.mak Sun Feb 1 12:29:36 1998
++++ src/fte-unix.mak.new Thu Jun 8 21:59:24 2000
+@@ -5,17 +5,24 @@
+
+ # vfte - for Linux console directly (with limitations, see con_linux.cpp)
+
+-#TARGETS = xfte
+-TARGETS = xfte vfte
++TARGETS = xfte
++#TARGETS = xfte vfte
+
+ PRIMARY = xfte
+
+ # choose your os here
+
++###
++# FreeBSD
++X11BASE?=/usr/X11R6
++UOS = -DFREEBSD
++XINCDIR = -I${X11BASE}/include
++XLIBDIR = -L${X11BASE}/lib
++
+ #######################################################################
+ # Linux
+-UOS = -DLINUX
+-XLIBDIR = -L/usr/X11R6/lib
++#UOS = -DLINUX
++#XLIBDIR = -L/usr/X11R6/lib
+
+ #######################################################################
+ # HP/UX
+@@ -51,8 +58,8 @@
+ MOC = moc
+
+ # for GCC
+-CC = g++
+-LD = gcc
++CC ?= g++
++LD = ${CC}
+ COPTIONS = -xc++ -Wall
+ # for IRIX CC
+ #CC = CC
+@@ -64,9 +71,9 @@
+
+ #OPTIMIZE = -g
+ #OPTIMIZE = -O -g
+-OPTIMIZE = -O -s
++#OPTIMIZE = -O -s
+
+-CCFLAGS = $(OPTIMIZE) $(COPTIONS) -DUNIX $(UOS) $(INCDIR) $(XINCDIR) $(QINCDIR) $(MINCDIR)
++CCFLAGS = $(CFLAGS) $(OPTIMIZE) $(COPTIONS) -DUNIX $(UOS) $(INCDIR) $(XINCDIR) $(QINCDIR) $(MINCDIR)
+ LDFLAGS = $(OPTIMIZE) $(LIBDIR) $(XLIBDIR) $(QLIBDIR) $(MLIBDIR)
+
+ OEXT = o
+@@ -77,7 +84,7 @@
+
+ XLIBS = -lX11
+ QLIBS = -lqt
+-VLIBS = -lgpm -ltermcap
++#VLIBS = -lgpm -ltermcap
+ MLIBS = -lXm -lXt
+
+ .cpp.o:
diff --git a/editors/fte/files/patch-ad b/editors/fte/files/patch-ad
new file mode 100644
index 000000000000..8a5463284225
--- /dev/null
+++ b/editors/fte/files/patch-ad
@@ -0,0 +1,13 @@
+--- src/c_hilit.h Mon Aug 25 03:11:28 1997
++++ src/c_hilit.h.new Thu Jun 8 22:08:05 2000
+@@ -128,10 +128,6 @@
+ int TabSize = BFI(BF, BFI_TabSize); \
+ int ExpandTabs = BFI(BF, BFI_ExpandTabs);
+
+-//#define HILIT_VARS2() \
+-// int len1 = len;
+-// char *last = p + len1 - 1;
+-
+ #define IF_TAB() \
+ if (*p == '\t' && ExpandTabs) { \
+ NC = NextTab(C, TabSize); \
diff --git a/editors/fte/pkg-comment b/editors/fte/pkg-comment
new file mode 100644
index 000000000000..b4e810f95e87
--- /dev/null
+++ b/editors/fte/pkg-comment
@@ -0,0 +1 @@
+A full-featured text editor for X11
diff --git a/editors/fte/pkg-descr b/editors/fte/pkg-descr
new file mode 100644
index 000000000000..2514a26eb1cc
--- /dev/null
+++ b/editors/fte/pkg-descr
@@ -0,0 +1,11 @@
+A port of an extremely powerful FTE editor that was
+originally developed for OS/2 and ported by its author,
+Marko Macek, to X11/UNIX.
+
+Among other features it supports syntax highlighting,
+compiler invocation and error parsing and folds.
+
+WWW: http://fte.sourceforge.net/
+
+Alexander Gelfenbain
+mail@gelf.com
diff --git a/editors/fte/pkg-plist b/editors/fte/pkg-plist
new file mode 100644
index 000000000000..8a01c9166e1f
--- /dev/null
+++ b/editors/fte/pkg-plist
@@ -0,0 +1,70 @@
+bin/fte
+etc/fte/system.fterc
+lib/fte/etc/ab_c.fte
+lib/fte/etc/ab_c_os2.fte
+lib/fte/etc/color.fte
+lib/fte/etc/global.fte
+lib/fte/etc/k_brief.fte
+lib/fte/etc/m_ada.fte
+lib/fte/etc/m_asm.fte
+lib/fte/etc/m_asm370.fte
+lib/fte/etc/m_bin.fte
+lib/fte/etc/m_c.fte
+lib/fte/etc/m_clario.fte
+lib/fte/etc/m_diff.fte
+lib/fte/etc/m_ebnf.fte
+lib/fte/etc/m_fort90.fte
+lib/fte/etc/m_fte.fte
+lib/fte/etc/m_html.fte
+lib/fte/etc/m_ipf.fte
+lib/fte/etc/m_java.fte
+lib/fte/etc/m_ldsgml.fte
+lib/fte/etc/m_make.fte
+lib/fte/etc/m_msg.fte
+lib/fte/etc/m_mvsasm.fte
+lib/fte/etc/m_pascal.fte
+lib/fte/etc/m_perl.fte
+lib/fte/etc/m_plain.fte
+lib/fte/etc/m_resdlg.fte
+lib/fte/etc/m_rexx.fte
+lib/fte/etc/m_sh.fte
+lib/fte/etc/m_siod.fte
+lib/fte/etc/m_tcl.fte
+lib/fte/etc/m_tex.fte
+lib/fte/etc/m_texi.fte
+lib/fte/etc/m_text.fte
+lib/fte/etc/m_vi.fte
+lib/fte/etc/m_xp.fte
+lib/fte/etc/main.fte
+lib/fte/etc/pal_blk.fte
+lib/fte/etc/pal_blue.fte
+lib/fte/etc/pal_wht.fte
+lib/fte/etc/ui_brief.fte
+lib/fte/etc/ui_fte.fte
+lib/fte/etc/ui_fte2.fte
+lib/fte/etc/ui_k_fte.fte
+lib/fte/etc/ui_k_fte2.fte
+lib/fte/etc/ui_k_ne.fte
+lib/fte/etc/ui_k_ws.fte
+lib/fte/etc/ui_m_fte.fte
+lib/fte/etc/ui_m_fte2.fte
+lib/fte/etc/ui_m_ne.fte
+lib/fte/etc/ui_m_ws.fte
+lib/fte/etc/ui_mew.fte
+lib/fte/etc/ui_ne.fte
+lib/fte/etc/ui_vi.fte
+lib/fte/etc/ui_ws.fte
+lib/fte/etc/uicstyle.fte
+lib/fte/etc/kbd/k_c.fte
+lib/fte/etc/kbd/k_fte.fte
+lib/fte/etc/kbd/k_html.fte
+lib/fte/etc/kbd/k_java.fte
+lib/fte/etc/kbd/k_perl.fte
+lib/fte/etc/kbd/k_rexx.fte
+lib/fte/etc/menu/m_c.fte
+lib/fte/etc/menu/m_html.fte
+@dirrm etc/fte
+@dirrm lib/fte/etc/kbd
+@dirrm lib/fte/etc/menu
+@dirrm lib/fte/etc
+@dirrm lib/fte